Bug 215366 - /usr/bin/tail +nn doesn't work as it used to
/usr/bin/tail +nn doesn't work as it used to
Status: CLOSED DUPLICATE of bug 187479
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 12:54 EST by Alan Crosswell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 05:34:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Crosswell 2006-11-13 12:54:41 EST
Description of problem:

"/usr/bin/tail +<lines>" no longer works.  One must use "tail -n +<lines>".
 
Version-Release number of selected component (if applicable):

coreutils-5.97-11

How reproducible:

Run the tail command with +<lines>

Steps to Reproduce:
1. /usr/bin/tail +3 /etc/motd and see it tries to open "+3" as a file:

 
Actual results:

# /usr/bin/tail +3 /etc/motd
/usr/bin/tail: cannot open `+3' for reading: No such file or directory
==> /etc/motd <==

Expected results:

(as seen on FC 4)

$ /usr/bin/tail -n +3 /etc/motd
$ rpm -qf  /usr/bin/tail
coreutils-5.2.1-48.1


Additional info:

This specifcally breaks the Real Networks Producer 11 installation script.

The +<lines> syntax for tail has been there forever.
Comment 1 Tim Waugh 2006-11-14 05:34:55 EST
Please read the info page about Standards Conformance:

  info coreutils 'Standards Conformance'

In particular, you can re-enable this '+2' behaviour by setting an environment
variable:

  For example, if you have a newer system but are running
  software that assumes an older version of POSIX and uses `sort +1' or
  `tail +10', you can work around any compatibility problems by setting
  `_POSIX2_VERSION=199209' in your environment.

*** This bug has been marked as a duplicate of 187479 ***

Note You need to log in before you can comment on or make changes to this bug.