Bug 215377 - oocalc: crash at start
oocalc: crash at start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 222288 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 13:53 EST by Need Real Name
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 09:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-11-13 13:53:27 EST
Not sure what I did.

libGL warning: 3D driver claims to not support visual 0x4b

---start copy and paste here---
(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-30-i386
(V)    kernel is: Linux 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.3-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora Core release 6 (Zod)
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x4fb7af28: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x22f28
0x4fb7bbbb: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23bbb
0x443420:  + 0x420 (__kernel_sigreturn + 0x0)
0x49347a50: /lib/ld-linux.so.2 + 0x9a50
0x4934bae0: /lib/ld-linux.so.2 + 0xdae0
0x49350ed0: /lib/ld-linux.so.2 + 0x12ed0
0x43044eb2: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xb3eb2
0x4fb71ece: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x19ece
0x494ce3db: /lib/libpthread.so.0 + 0x53db
0x4942806e: /lib/libc.so.6 + 0xcd06e (clone + 0x5e)
...end stackreport details ...
...start sample ldd details ...
        linux-gate.so.1 =>  (0x0011d000)
        libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3
(0x0041b000)
        libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x003c3000)
        libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3
(0x00693000)
        libdl.so.2 => /lib/libdl.so.2 (0x00110000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0011e000)
        libstlport_gcc.so =>
/usr/lib/openoffice.org2.0/program/libstlport_gcc.so (0x00135000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x001fc000)
        libm.so.6 => /lib/libm.so.6 (0x002e8000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00ad3000)
        libc.so.6 => /lib/libc.so.6 (0x006ab000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00b53000)
        /lib/ld-linux.so.2 (0x4933e000)
...end sample ldd details ...
---end copy and paste here---
paste the above into your bug report
Comment 1 Caolan McNamara 2006-11-14 04:35:15 EST
method 

framework::ConfigAccess::open(framework::ConfigAccess::EOpenMode)

so, did this happen on launching OOo ?

and let me guess it doesn't happen every time :-(
Comment 2 Need Real Name 2006-11-14 06:14:22 EST
(In reply to comment #1)
> so, did this happen on launching OOo ?
Yes. Using oocalc filename.ext

I can't reproduce it unfortunately.
Comment 3 Need Real Name 2006-11-14 18:00:09 EST
Perhaps related to my two other bugs? Bug 215634 and bug 215551.
Comment 4 Caolan McNamara 2006-11-15 14:37:52 EST
it's possible similar to bug 212424 which also occurs for no good reason in
configmgr
Comment 5 Need Real Name 2006-11-15 14:42:51 EST
Any chance I can have a look at that bug, or get the gist of it?
I've just had another crash - this time launching evolution.
Comment 6 Caolan McNamara 2006-11-16 03:23:36 EST
caolanm->jakub: This looks very like 210748 for the glibc stack frames
Comment 7 Jakub Jelinek 2007-01-11 14:54:09 EST
*** Bug 222288 has been marked as a duplicate of this bug. ***
Comment 8 Need Real Name 2007-01-27 06:08:11 EST
Will 210748 (glibc stack frames) be fixed for FC7?
Comment 9 Need Real Name 2007-02-06 12:47:51 EST
I haven't had a crash for weeks, so will close this soon.
Comment 10 Jakub Jelinek 2007-06-28 06:03:55 EDT
Please try glibc-2.5-17.fc6 in FC6 testing updates.
Comment 11 Need Real Name 2007-07-11 10:34:00 EDT
I don't have the crashes since upgrading to F7.
Comment 12 Jakub Jelinek 2007-07-19 09:28:26 EDT
glibc-2.5-18.fc6 has been pushed as FC6 errata a week ago.

Note You need to log in before you can comment on or make changes to this bug.