Bug 215385 - pm-suspend unnecessarily checks for existance of /sys/power/disk
pm-suspend unnecessarily checks for existance of /sys/power/disk
Status: CLOSED DUPLICATE of bug 214407
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 14:13 EST by Till Maas
Modified: 2015-03-04 20:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 15:52:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2006-11-13 14:13:31 EST
Description of problem:

pm-suspend (the script to run suspend to ram) checks whether /sys/power/disk is
a file and exits if not. This is not needed since pm-suspend works for me
without /sys/power/disk beeing present, which is the case if one uses the pae
kernel atm.

Version-Release number of selected component (if applicable):

0.19-3

How reproducible:

always

Steps to Reproduce:
1. boot kernel-pae
2. try to use pm-suspend
  
Actual results:
nothing happens

Expected results:

machine suspends to ram
Additional info:
I will open another bug because it is very unhelpful that pm-suspend quits
without any message instead of reporting that it quit because of missing
/sys/power/disk
Comment 1 Till Maas 2006-11-14 15:52:42 EST

*** This bug has been marked as a duplicate of 214407 ***

Note You need to log in before you can comment on or make changes to this bug.