Bug 21562 - Anaconda fails when using a kickstart file
Anaconda fails when using a kickstart file
Status: CLOSED DUPLICATE of bug 19384
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-30 19:30 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 15:29:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-30 19:30:31 EST
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/partitioning_text.py", $
  todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in
allowL$    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 820b1b8>
self: <lilo.LiloConfiguration instance at 8287b98>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


I'm using the following kickstart file:

          lang en_US

network --bootproto static --ip 216.89.164.162 --netmask 255.255.255.248
--gate$
cdrom

device ethernet old_tulip

keyboard "us"

zerombr yes
clearpart --linux
part swap --size 134
install

mouse genericps/2

timezone Etc/GMT-6

rootpw --iscrypted $1$XkLrDZZ6$Du5dvD8wLTE3.HnC6zSoc/

auth --useshadow

lilo --location mbr

%packages
filesystem
glibc
mktemp
libtermcap
anacron
anonftp
info
sed
grep
apache
mingetty
e2fsprogs
popt
sysklogd
which
modutils
arpwatch
aspell
authconfig
automake
bdflush
words
pwdb
glib
sh-utils
gdbm
bind
binutils
byacc
bzip2-devel
cdecl
zlib
SysVinit
console-tools
cpp
crontabs
cvs
db1
devfile
finger
flex
ftp
gcc-c++
gd
gdb
gettext
ghostscript-fonts
glibc-devel
gnupg
gpm-devel
groff-perl
hdparm
indexhtml
ipchains
iptables
isapnptools
kbdconfig
kernel-pcmcia-cs
krb5-devel
kudzu
less
libjpeg-devel
libpng-devel
libstdc++-devel
libtiff
m4
libtool-libs
libxml
lilo
linuxconf
losetup
lrzsz
ltrace
dhcpcd
diffstat
sgml-common
ed
elm
 mailx
MAKEDEV
man-pages
mkbootdisk
mkisofs
openssl
mount
mpage
mutt
ncompress
net-tools
netpbm-devel
newt-devel
njamd
ntsysv
openldap
openssh-askpass
openssh-server
passwd
pciutils
pidentd
pmake
portmap
postgresql-devel
ppp
pspell
python
python-xmlrpc
raidtools
rdate
readline
redhat-logos
rhn_register
rootfiles
rpm
rpm-devel
rsh-server
rusers
rwall-server
sash
sendmail
setuptool
shapecfg
slang
slocate
stat
strace
stylesheets
talk-server
tcl
tcpdump
telnet
texinfo
time
tin
traceroute
ucd-snmp
unzip
urlview
utempter
vim-common
whois
xinetd
ypbind
zip
auth_ldap
cipe
db3-utils
ftpcopy
imjed
jikes
kaffe
libgcj-devel
mawk
mod_dav
mtr
mysql-devel
nc
open
openldap-devel
openssl-perl
php-imap
php-manual
php-pgsql
postgresql-odbc
procinfo
rarpd
squid
tftp
tripwire
unixODBC
vim-enhanced
w3c-libwww-apps
setup
basesystem
chkconfig
termcap
bash
shadow-utils
ncurses
fileutils
mailcap
textutils
apmdgawk
procps
logrotate
psmisc
vixie-cron
initscripts
ash
at
autoconf
bc
cracklib
cracklib-dicts
db3
pam
db2
perl
bind-utils
bison
bzip2
caching-nameserver
XFree86-libs
XFree86-xfs
chkfontpath
cpio
cproto
ctags
cyrus-sasl
db1-devel
dev86
dialog
diffutils
docbook
eject
fetchmail
findutilsfinger-server
freetype
gcc
gcc-g77
gd-devel
gdbm-devel
ghostscript
kernel-headers
gmp
gpm
groff
gzip
indent
inews
iproute
iputils
isdn4k-utils
kernel
kernel-utils
krb5-libs
kudzu-devel
libjpeg
libpng
libstdc++
libtermcap-devel
libtiff-devel
libtool
libungif
libxml-devel
links
linuxconf-devel
LPRng
lsof
lynx
makeman
metamail
mkinitrd
mod_perl
mod_ssl
mouseconfig
mt-st
ncftp
ncurses-devel
netpbm
newt
nfs-utils
nmh
openjade
openssh
openssh-clients
openssl-devel
patch
pciutils-devel
pine
pnm2ppa
postgresql
postgresql-server
procmail
pump
python-devel
quota
rcs
rdist
readline-devel
redhat-release
rhs-printfilters
rp-pppoe
rpm-build
rpm-pythonrsync
rusers-server
rwho
screen
setserial
sgml-tools
sharutils
slang-devel
slrn
statserial
stunnel
sysstat
talk
tar
tcp_wrappers
tcsh
telnet-server
tftp-server
timeconfig
tmpwatch
trn
ucd-snmp-utils
up2date
urw-fonts
util-linux
vim-minimal
wu-ftpd
yp-tools
ypserv
zlib-devel
bind-devel
db2-devel
ext2ed
gcc-java
imap-develjed-common
joe
libgcj
libpcap
mkkickstart
mod_php
mysql
mysql-server
nss_ldap
openldap-clients
openldap-servers
php
php-ldap
php-mysql
postgresql-jdbc
postgresql-perl
psacct
rgrep
symlinks
tree
unarj
unixODBC-devel
w3c-libwww
wget

%post
Comment 1 Michael Fulbright 2000-12-01 11:24:43 EST
Assigned to QA to reproduce.

This is a dupe of bug 19384.
Comment 2 Brock Organ 2001-01-09 15:29:50 EST

*** This bug has been marked as a duplicate of 19384 ***

Note You need to log in before you can comment on or make changes to this bug.