Bug 215657 - Can't mount flash drive on FC6 SMB
Can't mount flash drive on FC6 SMB
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
6
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
: 244897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 20:53 EST by Leslie Satenstein
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-05 23:03:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2006-11-14 20:53:21 EST
Description of problem:
Put sandisk in usb port, no automount atkes place. However, automount appears to
work for CD/DVD reader/writer

Version-Release number of selected component (if applicable):unname -a shows
Linux localhost.localdomain 2.6.18-1.2849.fc6xen #1 SMP Fri Nov 10 13:56:52 EST
2006 i686 i686 i386 GNU/Linux
also autofs is autofs-5.0.1-0.rc2.22

System Mother board, Intel 945gnt. Processor  Intel D930. 32/64 bit
1 gig memory.


How reproducible:

take a flashdrive and insert it into the usb port. The flashdrive light
(sandisk) shows power and there is some hd activity, and sandisk light flash.


Steps to Reproduce:
1.
2.
3.
  
Actual results:

dmseg log shows nothing related

Expected results:

Flash drive should be mounted and accessable, as it was in FC5.
 


Additional info:

Refer to linux questions for this topic. I am not the only one experiencing this
problem  (use flashdrive in linux questions for other commentaries
Comment 1 Ian Kent 2006-11-15 00:24:57 EST
(In reply to comment #0)
> Description of problem:
> Put sandisk in usb port, no automount atkes place. However, automount appears to
> work for CD/DVD reader/writer
> 
> Version-Release number of selected component (if applicable):unname -a shows
> Linux localhost.localdomain 2.6.18-1.2849.fc6xen #1 SMP Fri Nov 10 13:56:52 EST
> 2006 i686 i686 i386 GNU/Linux
> also autofs is autofs-5.0.1-0.rc2.22

What makes you think this is an autofs problem?

If your sure it is an autofs problem then provide
the configuration you have setup in the autofs
configuration file to use the flashdrive and also
describe how you disabled hal from manageing this
type of media.

Ian
Comment 2 Jeffrey Moyer 2006-11-15 10:04:45 EST
This sounds more like a udev/hald problem.  If I've assigned it to the wrong
place, please correct it.

Thanks!
Comment 3 Leslie Satenstein 2006-11-16 20:13:36 EST
I had a Bugzilla crash and replied directly to the assigned individual. Here is
the cut and paste of the email to him which explains the bypass to the problem. 

This following file, if renamed, does not stop problem. It still persists still
persists. Either delete file, or chmod 000 gparted-disable-automount.fdi

Path to it is  /usr/share/hal/fdi/policy/

File is gparted-disable-automount.fdi


I did the latter (chmod 000).  I can see the flash drive in fileystem, and in gnome.

This file is also in my fc6 vanilla installation for which I used annaconda disk
partitioning, and then backed out of repartitioning to let the installer
defaults be taken.

So, it's origins could be there with annaconda or gparted.


Here is a cut and paste of the contents of the aforementioned file (a one-liner)

<deviceinfo version='0.2'><device><match
key='@block.storage_device:storage.hotpluggable' bool='true'><merge
key='volume.ignore' type='bool'>true</merge></match[root@localhost policy]# 
 
 
 
Comment 4 Michael Cronenworth 2006-11-17 10:01:01 EST
I'm also getting a similar problem using XFCE. I insert a USB flash drive and no
drive shows up on my desktop (an icon should be created). If I put in a CD or
DVD it will show up on the desktop. I've also loaded up hal-device-manager and I
cannot see my USB flash drive in it as I have been able to.

This seems to have broken in just the past week. This worked perfectly last
week. I think there was a udev update wasn't there?

HAL and/or UDEV are broken with USB flash drives.
Comment 5 lejeczek 2006-11-21 17:43:53 EST
Very same problem:
2.6.18-1.2849.fc6xen #1 SMP Fri Nov 10 12:57:36 EST 2006 x86_64 x86_64 x86_64
GNU/Linux. Initially it worked thoug. Then something happened. I din't do
anything, nothing techy at least. Just applied some updates, installed some
rpms. Suddenly got no HDDs via USB nor Flashes being picked up when plugged but
DVD which is USB too works like this:

Cannot mount volume.
Error <i>org.freedesktop.Hal.Device.UnknownError.</i>
Details -> An unknown error occured.

there is some more when I do:
gnome-mount -t -v -d /dev/dvd
i get:
Resolved device file /dev/dvd -> /dev/scd0
libhal-storage.c 1401 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was
not set.
** (gnome-mount:27577): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_label_UNDEFINED
** (gnome-mount:27577): DEBUG: read default option 'uid=' from gconf strlist key
/system/storage/default_options/udf/mount_options
** (gnome-mount:27577): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_label_UNDEFINED with
mount_point='UNDEFINED', fstype='', num_options=1
** (gnome-mount:27577): DEBUG:   option='uid=0'

** (gnome-mount:27577): WARNING **: Mount failed for
/org/freedesktop/Hal/devices/volume_label_UNDEFINED
org.freedesktop.Hal.Device.UnknownError : An unknown error occured
Comment 6 Phil Hale 2006-12-30 23:24:31 EST
I've incountered the same issue.  I did a chmod 000 on the file
/usr/share/hal/fdi/policy/gparted-disable-automount.fdi and both my USB hard
disks and my iPod work.
Comment 7 Leslie Satenstein 2006-12-31 19:27:57 EST
So is this a gparted problem, in that it does not clean up properly?
Comment 8 David Zeuthen 2007-01-02 15:00:40 EST
Reassigning to gparted maintainer. Can anyone explain what fdi files gparted is
shipping / creating? Including if the fdi file is only temporarily written? Thanks.

Comment 9 Deji Akingunola 2007-01-02 15:43:46 EST
The fdi file is not shipped, but its created at runtime to allow gparted perform
it operation and then removed before it exit. I'll check and if I can find why
its not removing the file or push the issue up to upstream.
Comment 10 Deji Akingunola 2007-01-02 15:53:55 EST
Leslie, were you plugging in your disk while gparted is running? I've just
looked again at gparted source and it stills properly remove that fdi file
before it exits. I've used gparted myself (though not in the last ~1.5 months),
and I still have my usb disks automounts. 
Comment 11 David Zeuthen 2007-01-02 16:12:05 EST
OK, I'll make sure there's a better way for gparted to do this (poke the HAL
daemon to lock out automounters).
Comment 12 Deji Akingunola 2007-01-02 16:39:38 EST
Thanks David. And people having this issue can just remove that
file(/usr/share/hal/fdi/policy/gparted-disable-automount.fdi) if gparted is not
running. 
Comment 13 Leslie Satenstein 2007-01-02 22:02:51 EST
Leslie, were you plugging in your disk while gparted is running? I've just
looked again at gparted source and it stills properly remove that fdi file
before it exits. I've used gparted myself (though not in the last ~1.5 months),
and I still have my usb disks automounts. 


The answer is no. However, I may have hit the reboot or shutdown command just
just prior to exiting gparted or perhhaps a reboot immediately on a gparted
message confirmation.
Comment 14 Luis Felipe Marzagao 2007-01-09 22:34:27 EST
Same issue happend to me. But I was indeed working with gparted on a usb
pendrive when, for some reason I don't know, gparted locked-up... The only to
restar again was to reboot the machine. Now, everything runs ok when I insert
any usb drives... I'm able to mount then manually, but none of them gets
automounted... I don't have the gparted-disable-automount.fdi file under
/usr/share/hal/fdi/policy. Gparted creates ir and erases it when exited.

There are, however, these files.. (I don't know its relevancy):

[root@localhost policy]# ll
total 16
drwxr-xr-x 2 root root 4096 Jan  1 19:55 10osvendor
drwxr-xr-x 2 root root 4096 Jan  1 19:56 20thirdparty

[root@localhost policy]# uname -rm
2.6.18-1.2869.fc6 i686

I also have run an update, but I don't believe it has something to do with it. I
think it was the previous gparted crash...

Any ideas?
Comment 15 Tim Waugh 2007-01-11 11:08:26 EST
Just fell for this too.  Perhaps the %postun script should make sure to remove
that file?  I had already removed the gparted package ages ago and this problem
persisted.
Comment 16 Andrew Overholt 2007-02-12 21:47:00 EST
This just hit me as well.  I wasn't running gparted at the time that I plugged
in the device.
Comment 17 John Crick 2007-04-03 19:49:32 EDT
I upgraded to 2.6.20-1.2933.fc6 last night an my sd media cards no longer auto
mount. Inserting of the card is detected as shown:

[jcrick@localhost ~]$ dmesg | tail
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
SoftMAC: Scanning finished: scanned 14 channels starting with channel 1
tifm_7xx1: sd card detected in socket 1
tifm_7xx1: demand removing card from socket 1
tifm_7xx1: sd card detected in socket 1


I cannot figure out what could cause this problem. I think this problem is back
but I don't know what broke it.
Comment 18 John Crick 2007-04-03 19:59:08 EDT
additionally to previous entry, previous entries suggest deleting orchmoding
/usr/share/hal/fdi/policy/gparted-disable-automount.fdi.  This file does not
exist in the directory in my machine.
Comment 19 Deji Akingunola 2007-04-05 23:03:56 EDT
Thanks to David Zeuthen and the new hal-lock, the root cause of this bug is now
solved in rawhide by using latest hal (hal-0.5.9). Unless upstream come up with
another solution or FC-6 get a hal upgrade, I might not be able to fix the bug
in  FC-6.

John Crick,
If you don't have /usr/share/hal/fdi/policy/gparted-disable-automount.fdi on
your  system, then this is not the same bug you experiencing. You may consider
filing a new bug for your issue.
Thanks. 
Comment 20 Deji Akingunola 2007-06-19 15:26:10 EDT
*** Bug 244897 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.