This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 244897 - running gparted can leave standard usb auto-mount not working
running gparted can leave standard usb auto-mount not working
Status: CLOSED DUPLICATE of bug 215657
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 14:36 EDT by simd
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 15:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description simd 2007-06-19 14:36:09 EDT
Description of problem:

gparted can leave the following file around:
/usr/share/hal/fdi/policy/gparted-disable-automount.fdi

This sets ignore=true for all disk drives, which causes nothing afterwards to be
auto-mounted.

Haven't established whether this is normal or under error conditions (my drive
is formatted now with data on!)

This has just taken me 2 days to find out why suddenly automount had stopped
working! I had just formatted a new external drive using gparted, but couldn't
put the link to gparted.

I assume this is needed for good reasons, so quite how you fix it, I don't know,
but it's REALLY confusing and irritating when it happens! Maybe it's actually a
system boot intialisation issue..

Additional info:
I got the answer from:
http://www.nabble.com/gnome-volume-manager-not-mounting-USB-drives-t3206706.html
Comment 1 simd 2007-06-19 15:03:27 EDT
More details - the contents of the file are:
<deviceinfo version='0.2'>
<device>
<match key='@block.storage_device:storage.hotpluggable' bool='true'>
<merge key='volume.ignore' type='bool'>true</merge>
</match>
</device>
</deviceinfo>

Plus comment (afterthought)
Also, actually, the 'clean' way here, should gparted go out leaving this file
hanging, is actually that hal grants a temporary blocking of hotpluggable, which
hal then resets at next system boot. Or you have to crate a boot script to clean
out the file. So actually the best fix might be in hal or the system boot
routines...
Comment 2 Deji Akingunola 2007-06-19 15:26:05 EDT
This most likely happened to you because gparted didn't exit cleanly after its
last use (something like you rebooting the system while gparted is still
running). Anyway, the issue is fixed with F7 and above; unfortunately this no
fix for it for FC-6 other than manually removing the file
'/usr/share/hal/fdi/policy/gparted-disable-automount.fdi'.

*** This bug has been marked as a duplicate of 215657 ***

Note You need to log in before you can comment on or make changes to this bug.