Bug 215801 - installation using an added "Updates Repo" fails
installation using an added "Updates Repo" fails
Status: CLOSED DUPLICATE of bug 217184
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 15:14 EST by Zing
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 11:36:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (133.27 KB, text/plain)
2006-11-17 13:46 EST, Zing
no flags Details
anaconda syslog (20.57 KB, text/plain)
2006-11-17 13:47 EST, Zing
no flags Details

  None (edit)
Description Zing 2006-11-15 15:14:17 EST
Description of problem:

It's noted in the FC6 install guide that by adding an Updates Repo you can have
a fully updated FC6 upon finish of installation:

http://fedora.redhat.com/docs/install-guide/fc6/en/ch-packageselection.html#sn-additional-repos

This just doesn't seem to work at all for me.  I'm doing an nfs install and then
specifying an updates repository in the "Add additional software repository".

I get "Unable to find a group file for 'update repo'. This will make manual
selection of packages from the repository not work".  

The install completes and upon reboot I get "Unable to load SELinux Policy.
Machine is in enforcing mode. Halting now." similar to bug #208040.  

Add enforcing=0 to the boot kernel and then I get "INIT: No inittab file found,
Enter runlevel:"

Booting rescue disk I see the initscripts package is not even installed.  In
fact it seems a bunch of packages are missing or misconfigured --> like say
haldaemon user is missing.


Version-Release number of selected component (if applicable):

FC6 Anaconda

How reproducible:
every time

Steps to Reproduce:
1. see above

Actual results:
1. an incomplete installation

Expected results:
1. a complete updated installation
Comment 1 Chris Lumens 2006-11-16 11:15:50 EST
Please attach /var/log/anaconda.log and /var/log/anaconda.syslog from your
installed system to this bug report.

The no group file message is harmless in this case.  It just means there's no
comps file for this repo.
Comment 2 Zing 2006-11-17 13:46:56 EST
Created attachment 141514 [details]
anaconda log
Comment 3 Zing 2006-11-17 13:47:24 EST
Created attachment 141515 [details]
anaconda syslog
Comment 4 Zing 2006-11-17 13:54:33 EST
More info: the URL I'm using above for the additional repo "FC6 Updates" is a
rsynced mirror of the official FC6 updates repo.  
Comment 5 Alex W. Jackson 2007-01-08 17:17:19 EST
This happened to me too.  Could someone please add this bug to the Common Bugs
Wiki page (http://fedoraproject.org/wiki/Bugs/FC6Common)?  It's pretty important
that users know that an installation/upgrade method explicitly recommended in
the documentation doesn't actually work.
Comment 6 Ahmed Kamal 2007-02-27 05:11:42 EST
Yep, confirmed here. Seen this too.
Comment 7 Jeremy Katz 2007-03-28 11:36:43 EDT

*** This bug has been marked as a duplicate of 217184 ***

Note You need to log in before you can comment on or make changes to this bug.