Bug 215919 - global symbol abuse
global symbol abuse
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libsoup (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks: 216170
  Show dependency treegraph
 
Reported: 2006-11-16 06:17 EST by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 12:55:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2006-11-16 06:17:32 EST
$ nm -D /usr/lib/libsoup-2.2.so.8.4.0  | grep ' [TD] ' | grep -v soup_
077132e4 T _fini
076f5248 T _init
0770a890 T queue_message
0771e420 D reason_phrases
076fc190 T send_request

looks like three functions lost a "static" or something; either need to be
static or they need a namespace.
Comment 1 Matthias Clasen 2006-11-17 12:55:03 EST
Should be fixed in libsoup-2.2.97-2.fc7

Note You need to log in before you can comment on or make changes to this bug.