Bug 215938 - libgaim/libgaim-client duplicate symbols
libgaim/libgaim-client duplicate symbols
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks: 216170
  Show dependency treegraph
 
Reported: 2006-11-16 08:33 EST by Joe Orton
Modified: 2008-01-07 09:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 09:45:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2006-11-16 08:33:24 EST
Description of problem:
This looks like an automake screwup or something: libgaim seems to contain a
statically linked copy of libgaim-client; or is this intended?

jorton@jolt:~$ nm -D /usr/lib/libgaim.so.0.0.0 | grep 'T gaim'  | head
4f774410 T gaim_GList_to_array
4f774380 T gaim_GSList_to_array
4f715ee0 T gaim_account_add_buddies
4f716860 T gaim_account_add_buddy
4f7165c0 T gaim_account_change_password
4f717c60 T gaim_account_clear_settings
4f718ab0 T gaim_account_connect
4f719140 T gaim_account_destroy
4f7168f0 T gaim_account_destroy_log
4f718920 T gaim_account_disconnect
jorton@jolt:~$ nm -D /usr/lib/libgaim-client.so.0.0.0 | grep 'T gaim'  | head
4f5390b0 T gaim_account_add_buddies
4f539140 T gaim_account_add_buddy
4f538e40 T gaim_account_change_password
4f53a750 T gaim_account_clear_settings
4f53b2d0 T gaim_account_connect
4f53b350 T gaim_account_destroy
4f5391d0 T gaim_account_destroy_log
4f53b1d0 T gaim_account_disconnect
4f539a50 T gaim_account_get_active_status
4f53a000 T gaim_account_get_alias
Comment 1 Warren Togami 2006-11-17 14:46:55 EST
Upstream?
Comment 2 Stu Tomlinson 2008-01-07 09:45:42 EST
libgaim-client doesn't exist in any form anymore

Note You need to log in before you can comment on or make changes to this bug.