Bug 215968 - Updgrade from FC5 to FC6 crashes mediawiki
Updgrade from FC5 to FC6 crashes mediawiki
Status: CLOSED DUPLICATE of bug 212600
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-11-16 12:03 EST by Vitaliy S
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-23 11:35:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to fix spec file. (498 bytes, patch)
2006-11-23 11:05 EST, Emily Brantley
no flags Details | Diff

  None (edit)
Description Vitaliy S 2006-11-16 12:03:47 EST
Description of problem:
Updgrade from FC5 to FC6 crashes mediawiki 

Version-Release number of selected component (if applicable): mediawiki-1.8.2-5.fc6

How reproducible:
Install mediawiki in fedora 5 upgrade to fedora 6
Actual results:
MediaWiki internal error.

Original exception: exception 'MWException' with message 'Utf8Case.ser is
missing, please run "make" in the serialized directory
' in /var/www/mediawiki/languages/Language.php:1718
Stack trace:
#0 /var/www/mediawiki/languages/Language.php(840): Language::getCaseMaps()
#1 /var/www/mediawiki/languages/Language.php(1686): Language->lc('??????????')
#2 /var/www/mediawiki/languages/Language.php(1644): Language->fixUpSettings()
#3 /var/www/mediawiki/languages/Language.php(1056): Language->load()
#4 /var/www/mediawiki/languages/Language.php(1069): Language->getMagicWords()
#5 /var/www/mediawiki/includes/MagicWord.php(157):
#6 /var/www/mediawiki/includes/MagicWord.php(128): MagicWord->load('int')
#7 /var/www/mediawiki/includes/Parser.php(3872): MagicWord::get('int')
#8 /var/www/mediawiki/includes/Parser.php(142): Parser->setFunctionHook('int',
Array, 1)
#9 [internal function]: Parser->firstCallInit()
#10 /var/www/mediawiki/includes/StubObject.php(32): call_user_func_array(Array,
#11 /var/www/mediawiki/includes/StubObject.php(40):
StubObject->_call('firstCallInit', Array)
#12 [internal function]: StubObject->__call('firstCallInit', Array)
#13 /var/www/mediawiki/includes/MessageCache.php(553): StubObject->firstCallInit()
#14 /var/www/mediawiki/includes/MessageCache.php(499):
#15 /var/www/mediawiki/includes/GlobalFunctions.php(423):
MessageCache->get('mainpage', true, true)
#16 /var/www/mediawiki/includes/GlobalFunctions.php(382):
wfMsgGetKey('mainpage', true, true, true)
#17 /var/www/mediawiki/includes/GlobalFunctions.php(331): wfMsgReal('mainpage',
Array, true, true)
#18 /var/www/mediawiki/includes/Wiki.php(74): wfMsgForContent('mainpage')
#19 /var/www/mediawiki/index.php(29): MediaWiki->checkInitialQueries(NULL,
'view', Object(StubObject), Object(WebRequest), Object(StubContLang))
#20 {main}

Additional info:
Tested on French  and Russian locale
Comment 1 Vitaliy S 2006-11-16 12:46:11 EST
I found out that mediawiki tar ball from sf.net contains serialized folder while
package provided with Red Had doesn't. 
Hope it will help.
Vitaliy S
Comment 2 Vitaliy S 2006-11-16 13:02:44 EST
I found the way to fix the problem manually
I copied serialized folder from sf.net mediawiki 1.8.2 tar ball to
#cd /var/www/mediawiki
after that I copied  AdminSettings.php from same tar ball to /var/www/mediawiki
#cd /var/www/mediawiki/maintenance
#php update.php

and after that mediawiki start working.

Vitaliy S

Comment 3 Emily Brantley 2006-11-23 11:05:57 EST
Created attachment 141997 [details]
Patch to fix spec file.
Comment 4 Emily Brantley 2006-11-23 11:06:51 EST
I've ever so slightly edited the spec file provided with the mediawiki 1.8.2-5
SRPM from Fedora Extras.  This fixes the issues described by bug 215968 (this
bug) and 214758 (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=214758). 
I've tested it here, and it works completely, as expected.

Bug 213997 (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=213997), being
a duplicate of this one, would also be closed by this fix.  I don't know how to
mark it as such a duplicate.

Attached a patch for the spec file (I'm not good at diff, so I'm not sure if
it's backwards or not).
Comment 5 Axel Thimm 2006-11-23 11:35:16 EST

*** This bug has been marked as a duplicate of 212600 ***

Note You need to log in before you can comment on or make changes to this bug.