Bug 212600 - mediawiki-1.8.2-4.fc6 missing files
Summary: mediawiki-1.8.2-4.fc6 missing files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 213997 214758 215968 217144 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-27 17:41 UTC by Stanislav Bozhkov
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 1.8.2-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 07:57:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stanislav Bozhkov 2006-10-27 17:41:12 UTC
Description of problem:
StartProfiler absend from fresh instgall of mediawiki. I found this after
upgrade from fc5 to fc6.

Version-Release number of selected component (if applicable): mediawiki-1.8.2-4.fc6


How reproducible:
Install version 1.8.2-4.fc6

Access the wiki from web and check logs

Actual results:
[Fri Oct 27 20:06:20 2006] [error] [client xxxx] PHP Warning: 
require_once(./StartProfiler.php) [<a
href='function.require-once'>function.require-once</a>]: failed to open stream:
No such file or directory in /var/www/mediawiki/includes/WebStart.php on line 59
[Fri Oct 27 20:06:20 2006] [error] [client xxxx] PHP Fatal error: 
require_once() [<a href='function.require'>function.require</a>]: Failed opening
required './StartProfiler.php' (include_path='.:/usr/share/pear') in
/var/www/mediawiki/includes/WebStart.php on line 59


Additional info:
I checked WebStart.php and really tries to load a file with name that doesn't
exist.

Comment 1 Axel Thimm 2006-11-23 16:35:09 UTC
*** Bug 213997 has been marked as a duplicate of this bug. ***

Comment 2 Axel Thimm 2006-11-23 16:35:24 UTC
*** Bug 214758 has been marked as a duplicate of this bug. ***

Comment 3 Axel Thimm 2006-11-23 16:35:29 UTC
*** Bug 215968 has been marked as a duplicate of this bug. ***

Comment 4 Chris Mohler 2006-11-23 22:58:57 UTC
mediawiki-1.8.2-5.fc6 is also missing files.

Specifically, the directory mediawiki-x.x.x/serialized needs to be copied to the
mediawiki directory, and then a 'make' needs to be issued in the new serialized
directory.

I see the closed dupes, and apologize if this futher info is not helpful.

Comment 5 Axel Thimm 2006-11-23 23:19:21 UTC
Chris, yes, I already pushed a -6 release to the repos (waits for the repo
maintainers to sign and release it), I changed the subject and used the version
mentioned in there, not the current available one.

But indeed I missed the make invocation in serialized. The package needs a total
revamping anyway, and it looks like the missing make for now would only be
required for performance improvements (or not?). I'd like to see the package
working at all first :)


Comment 6 Chris Mohler 2006-11-23 23:25:40 UTC
Axel,

Without the serialized directory, mediawiki barfs when you post an edit.  If you
enable debug messages in the mediawiki config, you see something like this:

Utf8Case.ser is missing, please run "make" in the serialized directory

Backtrace:

#0 /var/www/mediawiki/languages/Language.php(950): Language::getCaseMaps()
#1 /var/www/mediawiki/includes/SearchUpdate.php(51):=20
Language->stripForSearch('What you will f...')
#2 /var/www/mediawiki/includes/Wiki.php(269): SearchUpdate->doUpdate()
#3 /var/www/mediawiki/includes/Wiki.php(251): MediaWiki->doUpdates(Array)
#4 /var/www/mediawiki/index.php(48): MediaWiki->finalCleanup(Array,=20
Object(LoadBalancer), Object(OutputPage))
#5 {main}

I hope this is useful.


Comment 7 Axel Thimm 2006-11-24 11:01:30 UTC
Utf8Case.ser is already part of mediawiki-1_8_2-6, but this still hasn't been
signed and released. The system seems to have stalled since 2 days:

http://buildsys.fedoraproject.org/build-status/success.psp

Comment 8 Axel Thimm 2006-11-24 11:03:14 UTC
*** Bug 217144 has been marked as a duplicate of this bug. ***

Comment 9 Axel Thimm 2006-11-25 02:09:08 UTC
The package is now available, can you please confirm it's working in your setups?

Comment 10 Chris Mohler 2006-11-25 03:10:47 UTC
I removed mediawiki via yum, whacked the /var/www/mediawiki dir, and
re-installed via yum.

Worked out-of-the box.

I did copy my LocalSettings.php file back in instead of generating a new one -
probably doesn't matter, but thought I'd mention  it.  I used the DB from the
previous install also.

Chris


Note You need to log in before you can comment on or make changes to this bug.