Bug 216030 - Two different cursors were shown in the console of VM in virt-manager
Two different cursors were shown in the console of VM in virt-manager
Status: CLOSED DUPLICATE of bug 223805
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
: 216877 222971 (view as bug list)
Depends On: 211618 212949
Blocks: 222399
  Show dependency treegraph
 
Reported: 2006-11-16 15:42 EST by Jay Turner
Modified: 2015-01-07 19:15 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 15:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2006-11-16 15:42:54 EST
+++ This bug was initially created as a clone of Bug #212949 +++

Description of problem:
Two different cursors were shown in the console of VM in virt-manager.
It is very difficult to operate with the two cursors.

Version-Release number of selected component (if applicable):
FC6 GA was used. 
virt-manager-0.2.3-2.fc6

How reproducible:
It can be reprodced while installing a VM every time 

Steps to Reproduce:
1. Operate a VM with graphic mode console in virt-manager.
2. Two cursors will be shown in the console every time.

  
Actual results:
Two different cursors were shown up.

Expected results:
Just one cursor is expected.


Additional info:
None.
Comment 1 Jay Turner 2006-11-16 15:48:57 EST
I'm seeing this with virt-manager-0.2.5-1.el5.x86_64 as well.
Comment 2 Daniel Berrange 2006-11-22 09:53:14 EST
*** Bug 216877 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Berrange 2006-11-22 10:05:03 EST
One cursor is drawn by the guest X server, the other by the local X server under
which virt-manager is running. There is no direct connection between the VNC
server in Dom0, and the X server in DomU - they merely both access a shared
chunk of memory representing the framebuffer. Because of the way the mouse
pointer updates are sent, the 2 cursors get out of sync with each other very
easily. Since they do not correspond it is important to be able to see both
otherwise you will get very wierd user experiance. Work is ongoing to fix the
mouse pointer co-ordinate updates such that the 2 cursors are completely in
sync. Once they are in sync it will be feasible to hide the locally drawn cursor
completely.
Comment 4 Daniel Berrange 2006-11-29 14:42:21 EST
Adding bug 211618 as a dependancy, because until the xen kernel side is fixed,
there's nothing useful we can do in virt-manager.
Comment 5 Daniel Berrange 2007-01-17 10:13:41 EST
*** Bug 222971 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Berrange 2007-06-14 15:55:43 EDT
This was previously resolved as a Day-0 errata  virt-manager-0.2.6-7.0.2.el5


*** This bug has been marked as a duplicate of 223805 ***

Note You need to log in before you can comment on or make changes to this bug.