This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 216169 - vncfb does not run on IA64
vncfb does not run on IA64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Markus Armbruster
:
: 220095 225539 (view as bug list)
Depends On: 212515 218050
Blocks: 221626
  Show dependency treegraph
 
Reported: 2006-11-17 11:33 EST by Markus Armbruster
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHEA-2007-0635
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:08:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch posted to virtualist on 12/19 (5.84 KB, patch)
2006-12-22 10:15 EST, Chris Lalancette
no flags Details | Diff
Crash running against vmcore from hanging xen guest (12.35 KB, text/plain)
2006-12-22 15:07 EST, Jarod Wilson
no flags Details

  None (edit)
Comment 1 Markus Armbruster 2006-12-08 04:36:26 EST
Update to backport of latest upstream version (bz#218050) will resolve this.
Comment 2 Markus Armbruster 2006-12-19 13:32:57 EST
*** Bug 220095 has been marked as a duplicate of this bug. ***
Comment 3 Jarod Wilson 2006-12-21 09:34:49 EST
Latest upstream backport required a bit more patching to run on ia64 (posted to
rhkernel-list and virtualist), but works now, at least as far as firing up
graphics is concerned. Still looking into a hang on shutdown that appears to
only trigger when graphics are turned on.
Comment 4 Chris Lalancette 2006-12-22 10:15:11 EST
Created attachment 144287 [details]
Patch posted to virtualist on 12/19
Comment 5 Jarod Wilson 2006-12-22 15:07:21 EST
Created attachment 144308 [details]
Crash running against vmcore from hanging xen guest

Unfortunately, because ia64 xen guest crash dump process doen't lay down a
"switch_stack" register dump on the kernel stack of the panicking process, we
don't get a completely useful dump. Without that info, its impossible to get a
backtrace of the crashing process (Dave Anderson can explain in further
detail). Not seeing much of anything useful in the log output either....
Comment 6 Jarod Wilson 2007-01-05 13:19:42 EST
The guest shutdown hang is now being tracked in bug 221626.
Comment 7 Markus Armbruster 2007-01-31 03:33:43 EST
*** Bug 225539 has been marked as a duplicate of this bug. ***
Comment 8 Jarod Wilson 2007-01-31 14:50:55 EST
Note that the shutdown hang mentioned in comment #3 only manifests itself if a
'poweroff' command is issued from a shell within the guest itself -- the
Shutdown button in virt-manager and xm shutdown both work.
Comment 9 RHEL Product and Program Management 2007-03-29 14:45:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 Markus Armbruster 2007-06-07 09:28:37 EDT
We're considering updates to hypervisor and libxc, which should remove the need
for the attached patch.  Jarod, please confirm using the latest kernel-xen and
xen from the appropriate branches.
Comment 15 Jarod Wilson 2007-06-19 17:44:04 EDT
For the moment, the latest kernel and xen combo does indeed provide a working
paravirt framebuffer on ia64 without need for any additional patching. However,
with the current x86_64 breakage and it being up in the air which ia64 patch is
at fault, I'd like to retest this once that is all sorted out.
Comment 16 Jarod Wilson 2007-06-21 16:34:48 EDT
So it turned out not to be one of the ia64 patches, and with the latest kernel,
things are still working just fine. I'm going to say we're good to go on this one.
Comment 20 errata-xmlrpc 2007-11-07 12:08:31 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0635.html

Note You need to log in before you can comment on or make changes to this bug.