Bug 216294 - speexenc crashes on amd64, but not on i686
Summary: speexenc crashes on amd64, but not on i686
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: speex
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords: Desktop
Depends On: 206413
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-18 20:56 UTC by Matthias Clasen
Modified: 2013-03-06 03:48 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-12-12 09:45:15 UTC


Attachments (Terms of Use)

Description Matthias Clasen 2006-11-18 20:56:53 UTC
+++ This bug was initially created as a clone of Bug #206413 +++

speexenc whatever.wav whatever.spx crashes on x86_64 with a segfault, but it
works just fine on x86_32.

Version-Release number of selected component (if applicable):
speex-1.0.5-2.1

How reproducible:
Every time, for every file I tried.

-- Additional comment from oliva@lsd.ic.unicamp.br on 2006-09-14 04:19 EST --
*** Bug 206412 has been marked as a duplicate of this bug. ***

-- Additional comment from jean-marc.valin@usherbrooke.ca on 2006-11-18 06:14 EST --
(I'm the Speex maintainer) This is a known bug that has been fixed in 1.1.12,
but I'm sure the 2-line patch would also apply in 1.0.5:
https://trac.xiph.org/changeset/10684

-- Additional comment from mclasen@redhat.com on 2006-11-18 15:54 EST --
rawhide already has 1.2beta1, but for FC6, we should probably get that 2 line
fix included.


...and for RHEL5 too

Comment 1 RHEL Product and Program Management 2006-11-18 21:00:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 David Zeuthen 2006-11-21 00:01:20 UTC
Patch is in speex-1.0.5-4.

Comment 3 Xiaohong Wang 2006-12-12 09:44:31 UTC
Verified on RHEL5-Client-20061207.0 with speex-1.0.5-4, no crash on amd64
system, so resolve this bug.


Note You need to log in before you can comment on or make changes to this bug.