Bug 216331 - Yum crashes one time out of three
Yum crashes one time out of three
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 217230 217817 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-19 06:53 EST by Leo Wallentin
Modified: 2014-01-21 17:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 02:43:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo Wallentin 2006-11-19 06:53:49 EST
Description of problem:
I don't understand enough of the crash reports to tell if this is already
reported, but Yum crashes all the time, often when reloading the list of
packages after installing or removing something. This is only the graphics mode.

This is the output:
Component: yumex
Version: 1.2.0
Summary: TB6100b39a warnings.py:82:warn_explicit:TypeError: unknown type (null)

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 856, in
filter_modify
    obj = self.liststore.get_value( child_model_iter, 0 )
  File "/usr/lib64/python2.4/warnings.py", line 61, in warn
    warn_explicit(message, category, filename, lineno, module, registry)
  File "/usr/lib64/python2.4/warnings.py", line 82, in warn_explicit
    for item in filters:
TypeError: unknown type (null)

Local variables in innermost frame:
category: gobject.Warning
key: ("g_value_unset: assertion `G_IS_VALUE (value)' failed", <class
gobject.Warning at 0x2aaaaab3ca10>, 856)
ln: 0
text: g_value_unset: assertion `G_IS_VALUE (value)' failed
module: yumex.yumexUtils
cat: exceptions.PendingDeprecationWarning
item: ('ignore', None, <class exceptions.PendingDeprecationWarning at
0x2aaaaaae1fb0>, None, 0)
lineno: 856
registry: {("gtk_tree_model_filter_convert_iter_to_child_iter: assertion
`filter_iter->stamp == filter->priv->stamp' failed", <class gtk.GtkWarning at
0x2aaaaedce410>, 854): 1, ("gtk_list_store_get_value: assertion `VALID_ITER
(iter, list_store)' failed", <class gtk.GtkWarning at 0x2aaaaedce410>, 856): 1}
msg: None
action: ignore
message: g_value_unset: assertion `G_IS_VALUE (value)' failed
filename: /usr/lib/python2.4/site-packages/yumex/yumexUtils.py
mod: None


Version-Release number of selected component (if applicable):

Yum-extender 1.2.0?


How reproducible:


Steps to Reproduce:
1. Use it... :-)
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2006-11-20 03:15:58 EST
I will take a deeper look.
Comment 2 Tim Lauridsen 2006-12-18 02:43:08 EST
I have add some extra checks to the code in yumex 1.2.1, to avoid this kind of
error, it will be released very soon.
Comment 3 Tim Lauridsen 2006-12-18 02:45:54 EST
*** Bug 217230 has been marked as a duplicate of this bug. ***
Comment 4 Tim Lauridsen 2006-12-18 02:54:49 EST
*** Bug 217817 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.