Bug 216443 - totem doesn't always display video in this and other RH clips
totem doesn't always display video in this and other RH clips
Status: CLOSED DUPLICATE of bug 200270
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
http://www.redhat.com/promo/shows/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 09:57 EST by Matěj Cepl
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 09:05:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2006-11-20 09:57:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Epiphany/2.16 Firefox/1.5.0.8

Description of problem:
When playing any OGG clip on the above shown URL, sounds works 100%, but most of the times video doesn't show at all (both when playing in-window and full-screen). When trying to change the size of the window, showing/hiding navigational tools etc. sometimes I get corrupted image (for example icons from navbar), sometimes it begins to show correct display. But again any move with the window, change of the size, etc. corrupts image again. The same problem is when playing the clip in browser but there I haven't managed to show image at all.

When playing with gst-launch playbin everything works perfect.

Version-Release number of selected component (if applicable):
totem-2.16.1-1.fc6

How reproducible:
Always


Steps to Reproduce:
1.click on the file icon of the downloaded clip
2.totem shows up
3.

Actual Results:
image is not shown, just black screen (audio is perfect)
when the window of the player is changed, image sometimes shows, sometimes some garbage is shown

Expected Results:
clip should be played with the video OK, change, resize etc. of the window shouldn't affect quality of playback. It's kind of sad that I cannot play our own ads :-)

Additional info:
no error messages on stdout/stderr
Comment 1 Bastien Nocera 2006-11-27 05:33:20 EST
Are you using Compiz, or Beryl?
If so, can you reproduce the problem with Metacity (ie. with the Desktop Effects
turned off).
Comment 2 Matěj Cepl 2006-11-28 08:51:26 EST
Yeah, using Compiz -- when switched Desktop Effects off, totem suddenly works
well. Oh well, yet another problem with Aiglx :-(
Comment 3 Bastien Nocera 2006-11-28 09:04:43 EST
Same as bug 200270 which I opened against Fedora. Known limitation of AIGLX.

See also the upstream GStreamer bug:
http://bugzilla.gnome.org/show_bug.cgi?id=354946
Comment 4 Bastien Nocera 2006-11-28 09:05:33 EST
Closing as a dupe.

*** This bug has been marked as a duplicate of 200270 ***

Note You need to log in before you can comment on or make changes to this bug.