Bug 216476 - glibc - something messy in specs for glibc-devel
glibc - something messy in specs for glibc-devel
Status: CLOSED DUPLICATE of bug 213555
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-11-20 13:28 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-20 13:48:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-11-20 13:28:20 EST
Description of problem:

# rpm -V glibc-devel
missing     /usr/lib/librt.so.1

Indeed, 'rpm -qvl glibc-devel | grep /librt' shows
/usr/lib/librt.so.1 -> librtkaio.so

The catch is that there is no /usr/lib/librtkaio.so.  One can
find /usr/lib/librtkaio.a and /lib/rtkaio/librtkaio-2.5.so and
/lib/rtkaio/i686/nosegneg/librtkaio-2.5.so (that last one on 'i686')
but no librtkaio.so anywhere so that link is difficult to "repair".

Consequences for linking with -lrt are easy to predict although
a presence of /usr/lib/librt.a, interestingly enough different than
/usr/lib/librtkaio.a, surely helps. :-)

Version-Release number of selected component (if applicable):
Comment 1 Jakub Jelinek 2006-11-20 13:48:01 EST

*** This bug has been marked as a duplicate of 213555 ***

Note You need to log in before you can comment on or make changes to this bug.