Bug 213555 - Missing /usr/lib/librtkaio.so and /usr/lib/librt.so.1
Missing /usr/lib/librtkaio.so and /usr/lib/librt.so.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 216476 217307 221049 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 17:47 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.5.90-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-04 20:25:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-11-01 17:47:00 EST
Description of problem:
$ rpm -V glibc-devel
Unsatisfied dependencies for glibc-devel-2.5.90-3.i386:
/usr/lib/librtkaio.so

missing     /usr/lib/librt.so.1
$

Version-Release number of selected component (if applicable):
glibc-devel-2.5.90-3

How reproducible:
After normal installation of glibc, I'm getting the result listed above.

Actual results:
Missing /usr/lib/librtkaio.so and /usr/lib/librt.so.1

Expected results:
rpm -V with no output.

Additional info:
Ah, if I force a re-installation of glibc-devel using --force, /usr/lib/librt.
so.1 is available until the next glibc update...
Comment 1 Robert Scheck 2006-11-01 18:09:49 EST
$ rpm -q --scripts glibc-devel
postinstall scriptlet (using /bin/sh):
/sbin/install-info /usr/share/info/libc.info.gz /usr/share/info/dir
preuninstall scriptlet (using /bin/sh):
if [ "$1" = 0 ]; then
    /sbin/install-info --delete /usr/share/info/libc.info.gz /usr/share/info/dir
fi
$

And where's running ldconfig? /usr/lib/librt.so is in glibc-devel and packages 
that install libraries should run ldconfig.

Ah and missing /usr/lib/librtkaio.so is caused by this broken symbolic link:
-rw-r--r-- 1 root root 52128 Okt 30 14:39 /usr/lib/librt.a
lrwxrwxrwx 1 root root    20 Okt 30 14:11 /usr/lib/librt.so -> ../../lib/librt.
so.1
lrwxrwxrwx 1 root root    12 Okt 30 14:12 /usr/lib/librt.so.1 -> librtkaio.so

librt.so.1 -> librtkaio.so - Why? librtkaio.so doesn't exist in /usr/lib
Comment 2 Robert Scheck 2006-11-04 20:25:25 EST
Fixed and verified in Rawhide, thanks. BTW, this packaging issue was detected 
using RPM 4.4.8 - just to show, that it's very useful even when Red Hat tries
to keep the very old 4.4.2...
Comment 3 Jakub Jelinek 2006-11-20 13:48:13 EST
*** Bug 216476 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2006-11-26 17:26:03 EST
*** Bug 217307 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Jelinek 2007-01-02 17:45:14 EST
*** Bug 221049 has been marked as a duplicate of this bug. ***
Comment 6 Christian Krause 2007-01-02 18:00:35 EST
Hi Jakub,

I'm not 100% familiar with Fedora's policy, so I have to ask:
Will this fix be ported to FC6, too? ;-) (would be helpful to get also FC6
consistent...)

Thanks,
Christian

Note You need to log in before you can comment on or make changes to this bug.