Bug 216529 - Software Updater Exception
Software Updater Exception
Status: CLOSED DUPLICATE of bug 224292
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 17:52 EST by Richard Thomas
Modified: 2014-01-21 17:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 13:50:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Thomas 2006-11-20 17:52:04 EST
Description of problem:

I got the following Exception when running the updater on the 20th of November:

Component: Software Updater
Summary: TBb4cd9ea1 yumRepo.py:430:__get:RepoError: failure:
repodata/updateinfo.xml.gz from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 319, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 375, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 228, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 619, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 430, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: repodata/updateinfo.xml.gz from updates: [Errno 256] No more
mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: None
url: None
text: None
self: updates
cache: True
reget: None
relative: repodata/updateinfo.xml.gz
headers: ()
checkfunc: (<bound method YumRepository.checkMD of <yum.yumRepo.YumRepository
object at 0x95ebbac>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/updates/updateinfo.xml.gz


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-11-27 17:15:43 EST
Does this occur consistently?  Do you have a network connection up when it happens?
Comment 2 Richard Thomas 2006-11-27 17:55:20 EST
Hi,

This does happen consistently and I do have a network connection when this happens.

Richard.
Comment 3 Jeremy Katz 2006-11-27 17:58:19 EST
What happens if you just run 'yum update'?
Comment 4 Stan Stead 2006-12-09 17:37:59 EST
I have the same error. If I run yum update I get the following:
# yum update
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error, run 
database recovery
error: cannot open Packages index using db3 -  (-30977)
error: cannot open Packages database in /var/lib/rpm Traceback (most recent 
call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
    self.doConfigSetup(fn=opts.conffile, root=root)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in 
doConfigSetup
    self.conf = config.readMainConfig(fn, root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 589, in 
readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, 
earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 689, in 
_getsysver    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed
Comment 5 John E. Harbold 2007-01-14 19:49:31 EST
I got a similiar error using pirut.  The TypeError is the same, TypeError: rpmdb
open failed, the traceback is different:

Component: Software Manager
Summary: TBa375070c rpmsack.py:210:_all_packages:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 182, in _searchClicked
    for (po, res) in self.searchGenerator(fields, [t]):
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1134, in
searchGenerator
    for po in sack:
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 34, in __iter__
    ret = self.returnPackages()
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 195, in
returnPackages
    return [ self._makePackageObject(hdr, idx)
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 210, in _all_packages
    mi = ts.dbMatch()
TypeError: rpmdb open failed

Local variables in innermost frame:
self: <yum.rpmsack.RPMDBPackageSack instance at 0x94c5dcc>
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x98edcec>

I'm going to try and run pirut again.  I'm at a loss why it crashed!
Comment 6 John E. Harbold 2007-01-14 21:43:26 EST
I attempted to re-run pirut and got the same failure.  I removed the database
files, /var/lib/rpm/__db.00[0-9], and killed some cron jobs, rpm in cron.daily
and makewhatis in cron.weekly, and restarted pirut successfully.  It appears
that pirut depends on /var/lib/rpm/__db.00[0-9] for some reason.  Is that
Bugzilla entry for this problem?
Comment 7 Harry Hart 2007-01-25 09:41:13 EST
I experienced this on FC-6 after doing a software upgrade on 1/23/07, or
there-abouts.  I tried removing a zero-length __db.000 file in /var/lib/rpm but
it did not help.  Any suggestions?
Thanks - Harry
Comment 8 Harry Hart 2007-01-25 09:43:46 EST
Sorry - forgot to add that 'yum update' works fine for me, although Software
Updater crashes. - Harry
Comment 9 Keith Dixon 2007-01-25 10:24:03 EST
Jan 25 GMT 07:26
pirut-1.2.8-1.fc6

Me too.  

I tried rerunning pup several times and got the same exception:-

Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x9299f98>
child: <Element 'packagereq' at 0x9299ec0>
Comment 10 Keith Dixon 2007-01-25 11:00:04 EST
Jan 25 GMT 15:50

Just tried running pup again.  No exception, but there was also no available
updates.
Comment 11 Pete 2007-01-25 11:03:19 EST
Ditto Comment #9

Software updater stalls whilst 'Recovering software information'  then generates
an exception:-

Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 445, in ?
    main()
  File "/usr/sbin/pirut", line 441, in main
    pm.run()
  File "/usr/sbin/pirut", line 350, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 365, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
self: Graphics
package: digikam
type: optinoal
packagelist_elem: <Element 'packagelist' at 0x96700f8>
child: <Element 'packagereq' at 0x964f5d8>
Comment 12 Walter Gygli 2007-01-25 12:16:10 EST
Got exactly the same result. The last component I added was the exchange plugin
for evolution. Since that no lock anymore.
Comment 13 Frederic Blanchard 2007-01-25 13:40:30 EST
I have a very similar problem on two FC6 servers that were fully updated on
1/19/07.  In both case, starting Package Updater from the GUI fails at
"Retreiving update information" step with the following dump:

Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0xa231068>
child: <Element 'packagereq' at 0xa228f68>
Comment 14 Jeremy Katz 2007-01-25 13:50:16 EST

*** This bug has been marked as a duplicate of 224292 ***

Note You need to log in before you can comment on or make changes to this bug.