Bug 224292 - Software updater caused and unhandled exception error when selecting view updates.
Software updater caused and unhandled exception error when selecting view upd...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 216529 220673 224286 224287 224288 224290 224293 224300 224303 224307 224308 224309 224312 224314 224319 224321 224323 224325 224326 224330 224333 224337 224339 224342 224345 224348 224349 224353 224354 224355 224356 224358 224362 224366 224368 224371 224372 224374 224375 224376 224382 224383 224384 224386 224389 224390 224391 224396 224401 224403 224404 224410 224419 224423 224425 224426 224428 224450 224459 224463 224466 224469 224470 224474 224478 224485 224486 224492 224495 224502 224503 224505 224508 224513 224517 224520 224525 224533 225047 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 23:12 EST by tom dunkle
Modified: 2008-08-02 19:40 EDT (History)
82 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 14:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tom dunkle 2007-01-24 23:12:08 EST
Description of problem:
Prior to this this I have updated 4 times with no problem. Software updater
caused and unhandled exception error when selecting view updates. See log data
in Acutual result section below.

Version-Release number of selected component (if applicable):


How reproducible:
Always when selecting view updates.  25 updates were available for installation.

Steps to Reproduce:
1.Select update
2.Select view update
3.Exception Occurred Box appears
  
Actual results:
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x89ec068>
child: <Element 'packagereq' at 0x89e3f68>


Expected results:


Additional info:
Comment 1 Peter Gordon 2007-01-24 23:32:30 EST
This looks like it was caused by a mistyped entry in the comps XML file (which
stores the packages and grouping information). I've fixed this in CVS and it
should go out with the next Extras push (likely tomorrow). Please let us know if
that resolves your issue when the next Extras release is pushed. 

Thanks for your bug report.
Comment 2 Peter Gordon 2007-01-24 23:36:08 EST
[ Oops; Changing the component. ]
Comment 3 Bill Wadley 2007-01-25 03:03:19 EST
Just got this same crash. I have used pirut many times since fresh FC6 install
two weeks ago. Here is my crash dump:

----------------------------------------------------------------
Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 449, in main
    pm.run()
  File "/usr/sbin/pirut", line 358, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 373, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x94fd110>
child: <Element 'packagereq' at 0x94fd020>
----------------------------------------------------------------

This also appears to be the same problem for bug #224290
Comment 4 manuel wolfshant 2007-01-25 04:25:14 EST
    Beside fixing the comps.xml... shouldn't pirut be able to cope with bad
input data ? I do not think that throwing an exception and dying in pain is the
right choice... a better way would be to sanitize the input, wouldn't it ?
Comment 5 Michael Schwendt 2007-01-25 07:14:32 EST
*** Bug 224314 has been marked as a duplicate of this bug. ***
Comment 6 Michael Schwendt 2007-01-25 07:18:07 EST
*** Bug 224290 has been marked as a duplicate of this bug. ***
Comment 7 Michael Schwendt 2007-01-25 07:20:55 EST
*** Bug 224326 has been marked as a duplicate of this bug. ***
Comment 8 Michael Schwendt 2007-01-25 07:20:55 EST
*** Bug 224345 has been marked as a duplicate of this bug. ***
Comment 9 Michael Schwendt 2007-01-25 07:21:43 EST
*** Bug 224287 has been marked as a duplicate of this bug. ***
Comment 10 Michael Schwendt 2007-01-25 07:22:08 EST
*** Bug 224319 has been marked as a duplicate of this bug. ***
Comment 11 Michael Schwendt 2007-01-25 07:22:16 EST
*** Bug 224321 has been marked as a duplicate of this bug. ***
Comment 12 Rex Dieter 2007-01-25 08:13:21 EST
My apologies, the comps typos were committed by me yesterday.
Comment 13 Michael Schwendt 2007-01-25 08:27:21 EST
updated comps files have been pushed to fedoraproject.org master repo
Comment 14 Michael Schwendt 2007-01-25 09:06:28 EST
*** Bug 224366 has been marked as a duplicate of this bug. ***
Comment 15 Bill Nottingham 2007-01-25 09:40:33 EST
*** Bug 224382 has been marked as a duplicate of this bug. ***
Comment 16 Michael Schwendt 2007-01-25 12:16:03 EST
*** Bug 224323 has been marked as a duplicate of this bug. ***
Comment 17 Michael Schwendt 2007-01-25 12:16:04 EST
*** Bug 224358 has been marked as a duplicate of this bug. ***
Comment 18 Michael Schwendt 2007-01-25 12:16:44 EST
*** Bug 224391 has been marked as a duplicate of this bug. ***
Comment 19 Michael Schwendt 2007-01-25 12:16:59 EST
*** Bug 224372 has been marked as a duplicate of this bug. ***
Comment 20 Michael Schwendt 2007-01-25 12:17:53 EST
*** Bug 224403 has been marked as a duplicate of this bug. ***
Comment 21 Michael Schwendt 2007-01-25 12:18:21 EST
*** Bug 224404 has been marked as a duplicate of this bug. ***
Comment 22 Michael Schwendt 2007-01-25 12:18:28 EST
*** Bug 224426 has been marked as a duplicate of this bug. ***
Comment 23 Michael Schwendt 2007-01-25 12:18:33 EST
*** Bug 224375 has been marked as a duplicate of this bug. ***
Comment 24 Michael Schwendt 2007-01-25 12:20:50 EST
*** Bug 224337 has been marked as a duplicate of this bug. ***
Comment 25 Michael Schwendt 2007-01-25 12:20:53 EST
*** Bug 224356 has been marked as a duplicate of this bug. ***
Comment 26 Michael Schwendt 2007-01-25 12:22:07 EST
*** Bug 224428 has been marked as a duplicate of this bug. ***
Comment 27 Michael Schwendt 2007-01-25 12:24:47 EST
*** Bug 224423 has been marked as a duplicate of this bug. ***
Comment 28 Michael Schwendt 2007-01-25 12:37:48 EST
*** Bug 224419 has been marked as a duplicate of this bug. ***
Comment 29 Michael Schwendt 2007-01-25 12:37:55 EST
*** Bug 224425 has been marked as a duplicate of this bug. ***
Comment 30 Michael Schwendt 2007-01-25 12:38:10 EST
*** Bug 224376 has been marked as a duplicate of this bug. ***
Comment 31 Michael Schwendt 2007-01-25 12:38:33 EST
*** Bug 224386 has been marked as a duplicate of this bug. ***
Comment 32 Michael Schwendt 2007-01-25 12:39:13 EST
*** Bug 224384 has been marked as a duplicate of this bug. ***
Comment 33 Michael Schwendt 2007-01-25 12:39:17 EST
*** Bug 224390 has been marked as a duplicate of this bug. ***
Comment 34 Michael Schwendt 2007-01-25 12:39:21 EST
*** Bug 224389 has been marked as a duplicate of this bug. ***
Comment 35 Michael Schwendt 2007-01-25 12:39:33 EST
*** Bug 224401 has been marked as a duplicate of this bug. ***
Comment 36 Michael Schwendt 2007-01-25 12:39:46 EST
*** Bug 224410 has been marked as a duplicate of this bug. ***
Comment 37 Michael Schwendt 2007-01-25 12:40:15 EST
*** Bug 224374 has been marked as a duplicate of this bug. ***
Comment 38 Michael Schwendt 2007-01-25 12:40:30 EST
*** Bug 224362 has been marked as a duplicate of this bug. ***
Comment 39 Michael Schwendt 2007-01-25 12:41:00 EST
*** Bug 224355 has been marked as a duplicate of this bug. ***
Comment 40 Michael Schwendt 2007-01-25 12:41:30 EST
*** Bug 224353 has been marked as a duplicate of this bug. ***
Comment 41 Michael Schwendt 2007-01-25 12:41:40 EST
*** Bug 224354 has been marked as a duplicate of this bug. ***
Comment 42 Michael Schwendt 2007-01-25 12:42:32 EST
*** Bug 224348 has been marked as a duplicate of this bug. ***
Comment 43 Michael Schwendt 2007-01-25 12:43:11 EST
*** Bug 224349 has been marked as a duplicate of this bug. ***
Comment 44 Michael Schwendt 2007-01-25 12:43:14 EST
*** Bug 224339 has been marked as a duplicate of this bug. ***
Comment 45 Michael Schwendt 2007-01-25 12:43:51 EST
*** Bug 224342 has been marked as a duplicate of this bug. ***
Comment 46 Michael Schwendt 2007-01-25 12:44:07 EST
*** Bug 224325 has been marked as a duplicate of this bug. ***
Comment 47 Michael Schwendt 2007-01-25 12:44:21 EST
*** Bug 224333 has been marked as a duplicate of this bug. ***
Comment 48 Michael Schwendt 2007-01-25 12:46:06 EST
*** Bug 224293 has been marked as a duplicate of this bug. ***
Comment 49 Michael Schwendt 2007-01-25 12:46:35 EST
*** Bug 224330 has been marked as a duplicate of this bug. ***
Comment 50 Michael Schwendt 2007-01-25 12:46:56 EST
*** Bug 224300 has been marked as a duplicate of this bug. ***
Comment 51 Michael Schwendt 2007-01-25 12:47:02 EST
*** Bug 224307 has been marked as a duplicate of this bug. ***
Comment 52 Michael Schwendt 2007-01-25 12:47:05 EST
*** Bug 224303 has been marked as a duplicate of this bug. ***
Comment 53 Michael Schwendt 2007-01-25 12:47:56 EST
*** Bug 224308 has been marked as a duplicate of this bug. ***
Comment 54 Michael Schwendt 2007-01-25 12:50:03 EST
*** Bug 224288 has been marked as a duplicate of this bug. ***
Comment 55 Michael Schwendt 2007-01-25 12:53:31 EST
*** Bug 224396 has been marked as a duplicate of this bug. ***
Comment 56 Tim McConnell 2007-01-25 13:17:40 EST
In Bug 224288 (which has been marked a duplicate of this bug)  I could update
using 'yum -y update' but still recieved the error with both Yumex And Software
Updater. I ran 'yum clean all' and then ran 'yum -y update' and now the error is
gone. Yumex still hangs on intial start and Pirut (Software Updater) doesn't
give any errors. It seems to me that both programs are having issues with
reading yum's cache properly and is throwing incorrect errors and failing
because of that problem. 
Comment 57 Jeremy Katz 2007-01-25 13:33:33 EST
*** Bug 224383 has been marked as a duplicate of this bug. ***
Comment 58 Jeremy Katz 2007-01-25 13:34:13 EST
*** Bug 220673 has been marked as a duplicate of this bug. ***
Comment 59 Jeremy Katz 2007-01-25 13:40:28 EST
*** Bug 224309 has been marked as a duplicate of this bug. ***
Comment 60 Need Real Name 2007-01-25 13:44:46 EST
I see comment #1 says the problem has been cleared up ... but how exactly are we
supposed to get this update if we are affected by this problem?

What package do we need to update to get a new comps.xml?

$ rpm -q --whatprovides /var/cache/yum/extras/comps.xml
file /var/cache/yum/extras/comps.xml is not owned by any package
Comment 61 Will Woods 2007-01-25 13:48:52 EST
*** Bug 224286 has been marked as a duplicate of this bug. ***
Comment 62 Jeremy Katz 2007-01-25 13:50:45 EST
*** Bug 216529 has been marked as a duplicate of this bug. ***
Comment 63 Henrik Johansson 2007-01-25 13:56:45 EST
I got the same problem, when I ran Package Updater (twice).
Last use of the updater, was on Tuesday.

A test with "yum update", had no problems and nothing to update.
Comment 64 Jeremy Katz 2007-01-25 14:02:51 EST
yum will update the comps.xml as it reaches the timeout for the cache.

And I've committed a change to upstream yum to be more forgiving of things like
this.
Comment 65 Will Woods 2007-01-25 14:13:17 EST
*** Bug 224312 has been marked as a duplicate of this bug. ***
Comment 66 Need Real Name 2007-01-25 14:15:31 EST
Well, 'yum clean metadata' (which removes /var/cache/yum/extras/comps.xml) and
then re-running pup doesn't fix the problem.  Have I just not waited long enough?
Comment 67 Will Woods 2007-01-25 14:25:22 EST
*** Bug 224450 has been marked as a duplicate of this bug. ***
Comment 68 Andrew D. Stadler 2007-01-25 14:30:48 EST
Just a comment.  It seems as if this event has exposed 2 obvious issues/bugs.  

1.  A metadata file was generated with a typo.  This file has been fixed (comment 1).
2.  Yum was barfing on bad files.  This has been fixed, apparently (comment 64).  

I would like to suggest (and maybe this belongs in another bug report) that there's another bug:

3.  It was even possible to generate a metadata file with a typo.

This was obviously a simple typo - but why are these files being hand-generated *and* not pre-tested 
for accuracy, etc.?

You guys need to generate those files with tools, and you also need a tool that verifies the files before 
they go out to the masses.

My 2c.  Thanks for the quick fix!
 
Comment 69 Tony Ciecierski 2007-01-25 14:45:16 EST
The fix is to run 'yum clean all' and then ran 'yum -y update' as said earlier
it does work.

Thanks for getting the fixes out there so quickly for us guys!  Appreciate it!
Comment 70 Tony Ciecierski 2007-01-25 14:45:34 EST
The fix is to run 'yum clean all' and then ran 'yum -y update' as said earlier
it does work.

Thanks for getting the fixes out there so quickly for us guys!  Appreciate it!
Comment 71 Jeremy Katz 2007-01-25 15:12:47 EST
*** Bug 224459 has been marked as a duplicate of this bug. ***
Comment 72 Jeremy Katz 2007-01-25 15:26:33 EST
*** Bug 224466 has been marked as a duplicate of this bug. ***
Comment 73 Jeremy Katz 2007-01-25 15:26:34 EST
*** Bug 224463 has been marked as a duplicate of this bug. ***
Comment 74 Will Woods 2007-01-25 15:44:28 EST
*** Bug 224470 has been marked as a duplicate of this bug. ***
Comment 75 Dr. Rob Higgins 2007-01-25 16:26:41 EST
I ran 'yum clean all' and then 'yum -y update'

But Package Updater still gives the same error.

Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Not sure if I've missed something ... since this but is marked closed and
nextrelease ... 

Comment 76 Will Woods 2007-01-25 16:49:06 EST
*** Bug 224474 has been marked as a duplicate of this bug. ***
Comment 77 Will Woods 2007-01-25 16:49:25 EST
*** Bug 224478 has been marked as a duplicate of this bug. ***
Comment 78 Will Woods 2007-01-25 16:49:42 EST
*** Bug 224486 has been marked as a duplicate of this bug. ***
Comment 79 Will Woods 2007-01-25 16:50:27 EST
*** Bug 224485 has been marked as a duplicate of this bug. ***
Comment 80 Michael Schwendt 2007-01-25 17:02:16 EST
*** Bug 224492 has been marked as a duplicate of this bug. ***
Comment 81 Michael Schwendt 2007-01-25 17:03:17 EST
*** Bug 224469 has been marked as a duplicate of this bug. ***
Comment 82 Will Woods 2007-01-25 17:38:19 EST
*** Bug 224495 has been marked as a duplicate of this bug. ***
Comment 83 Will Woods 2007-01-25 17:46:10 EST
*** Bug 224502 has been marked as a duplicate of this bug. ***
Comment 84 Peter Bullock 2007-01-25 18:09:01 EST
Just like Comment #75, above, from Rob, I ran 'yum clean all' and then 'yum -y
update'.  The update command ran in terminal and said it completed successfully.
 I rebooted the machine and then attempted to run the Package Manager again from
the Applications/Add-Remove Software menu.  The window popped up requesting my
root p/w, which I input and was accepted.  The Package Manager opened a window
and began to run, but soon ended with a crash - same as before (Bug # 244463). I
copy the crash dump below:

Component: Software Manager
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 449, in main
    pm.run()
  File "/usr/sbin/pirut", line 358, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 373, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0x9193110>
child: <Element 'packagereq' at 0x9193020>

The above two commands did not resolve my original problem.  How do I re-open
this bug, or do I need to re-enter the bug as NEW?
Comment 85 Bill Wadley 2007-01-25 23:30:25 EST
I have run 'yum clean all' and then 'yum -y update', and both pirut and yumex
have successfully run, updated, searched for software, and installed it. Thank you!
Comment 86 Dr. Rob Higgins 2007-01-26 05:57:56 EST
re comment #75: software updater seems to work this morning

Thanks folks.
Comment 87 Jeremy Katz 2007-01-26 10:33:53 EST
*** Bug 224508 has been marked as a duplicate of this bug. ***
Comment 88 Jeremy Katz 2007-01-26 10:34:09 EST
*** Bug 224525 has been marked as a duplicate of this bug. ***
Comment 89 Jeremy Katz 2007-01-26 10:34:34 EST
*** Bug 224505 has been marked as a duplicate of this bug. ***
Comment 90 Jeremy Katz 2007-01-26 10:34:48 EST
*** Bug 224517 has been marked as a duplicate of this bug. ***
Comment 91 Jeremy Katz 2007-01-26 10:34:48 EST
*** Bug 224520 has been marked as a duplicate of this bug. ***
Comment 92 Jeremy Katz 2007-01-26 10:34:52 EST
*** Bug 224533 has been marked as a duplicate of this bug. ***
Comment 93 Jeremy Katz 2007-01-26 10:35:15 EST
*** Bug 224513 has been marked as a duplicate of this bug. ***
Comment 94 Peter Bullock 2007-01-26 14:08:19 EST
(In reply to comment #84)
> Just like Comment #75, above, from Rob, I ran 'yum clean all' and then 'yum -y
> update'.  The update command ran in terminal and said it completed successfully.
>  I rebooted the machine and then attempted to run the Package Manager again from
> the Applications/Add-Remove Software menu.  The window popped up requesting my
> root p/w, which I input and was accepted.  The Package Manager opened a window
> and began to run, but soon ended with a crash - same as before (Bug # 244463). I
> copy the crash dump below:
> 
> Component: Software Manager
> Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException
> 
> Traceback (most recent call last):
>   File "/usr/sbin/pirut", line 453, in ?
>     main()
>   File "/usr/sbin/pirut", line 449, in main
>     pm.run()
>   File "/usr/sbin/pirut", line 358, in run
>     self.doRefresh()
>   File "/usr/sbin/pirut", line 373, in doRefresh
>     self.reposSetup(pbar)
>   File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in
reposSetup
>     self.doGroupSetup()
>   File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in
doGroupSetup
>     self.comps.add(groupfile)
>   File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
>     group = Group(elem)
>   File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
>     self.parse(elem)
>   File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
>     self.parse_package_list(child)
>   File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
> parse_package_list
>     raise CompsException
> CompsException
> 
> Local variables in innermost frame:
> genre: optinoal
> self: Graphics
> package: digikam
> packagelist_elem: <Element 'packagelist' at 0x9193110>
> child: <Element 'packagereq' at 0x9193020>
> 
> The above two commands did not resolve my original problem.  How do I re-open
> this bug, or do I need to re-enter the bug as NEW?
> 


UPDATED Jan 26, 2007
I just ran the Package Manager (yum) and Software Updater (pirut) again today,
and they ran without error.  Not sure what happened there.  I did have a
filesystem problem (different problem altogether) that I fixed this AM - so
maybe that was causing my difficulty listed above.  Everything seems to be
working fine now.  Thanks for the help on this one! 
Comment 95 Andy Burns 2007-01-26 15:22:02 EST
I hit this(?) problem, but seem to have landed in a worse boat than most, yum
absolutely refuses to do anything now, 

yumex hangs
yum clean all           hangs
yum --disablerepo=* --noplugins clean all      hangs

when I say hangs, even ctrl-c wont kill it, needs to be killed -9 from another
session,

tried purging /var/cache/yum, no help

I seem trapped :-(
Comment 96 Michael Schwendt 2007-01-27 19:19:18 EST
*** Bug 225047 has been marked as a duplicate of this bug. ***
Comment 97 Michael Schwendt 2007-01-27 19:24:52 EST
*** Bug 224503 has been marked as a duplicate of this bug. ***
Comment 98 Michael Schwendt 2007-01-27 19:26:02 EST
*** Bug 224368 has been marked as a duplicate of this bug. ***
Comment 99 Michael Schwendt 2007-01-27 19:26:46 EST
*** Bug 224371 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.