Bug 216581 - Port bug #216377 & bug #209575 from RHEL-5 to Rawhide
Port bug #216377 & bug #209575 from RHEL-5 to Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-chewing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
: i18n
Depends On: 216377
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 01:45 EST by Caius Chance
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: scim-chewing-0.3.1-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 23:27:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File used to test OpenOffice with scim-chewing issue (13.50 KB, application/vnd.oasis.opendocument.text)
2007-01-11 23:30 EST, Ramakrishna Reddy Yekulla
no flags Details
PO file used to test it with Kbabel. (2.61 KB, text/x-gettext-translation)
2007-01-11 23:33 EST, Ramakrishna Reddy Yekulla
no flags Details

  None (edit)
Description Caius Chance 2006-11-21 01:45:49 EST
+++ This bug was initially created as a clone of Bug #216377 +++

Description of problem:
In kbabel PgDown/PgUp key doesn't work when Chewing is activated. The problem
was not found with other IM, such as SmartPinyin, Wubi, Cangjie.

Version-Release number of selected component (if applicable):
scim-chewing
libchewing

How reproducible:
Always

Steps to Reproduce:
1. Launch kbabel on zh_TW locale.
2. Start Chewing by Ctrl+Space.
3. Input some words and click PgDown to move to next item.
  
Actual results:
PgDown/PgUp key doesn't work.

Expected results:


Additional info:

-- Additional comment from llim@redhat.com on 2006-11-19 21:54 EST --
If other IME is working then chewing could be handling the keypress and didn't
get to the application. Could you please try with gedit to confirm? 

-- Additional comment from pm-rhel@redhat.com on 2006-11-19 22:00 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

-- Additional comment from llch@redhat.com on 2006-11-19 23:00 EST --
Looks like scim-chewing is ambitious on taking page_dn/page_up key events if it
is not being used at all. Reassign this bug over to cchance.

-- Additional comment from cchance@redhat.com on 2006-11-20 22:28 EST --
It is not just affecting kbabel, it does also oowriter and gedit.

Likely a universal problem which chewing tries to catch such key events even it
is not being used, as llch said on above.

Similar IME with preedit buffer, anthy, doesn't have same problem instead.

-- Additional comment from cchance@redhat.com on 2006-11-21 01:42 EST --
The problem exists because scim-chewing & libchewing hasn't catch the event,
which made the event stuck at chewing layer.

Patched and built. Pending for QA.
Comment 1 Caius Chance 2006-11-21 02:29:27 EST
+++ This bug was initially created as a clone of Bug #216377 +++
+++ This bug was initially created as a clone of Bug #209575 +++
Comment 2 Caius Chance 2006-11-21 03:15:54 EST
Patched and built. Pending for QA.

Please QE test both behaviors of bug #216377 and bug #209575 both.

Thank you very much.

I will clone to upstream asap.
Comment 3 Ramakrishna Reddy Yekulla 2007-01-11 23:27:10 EST
Environment Setup ::
1. Sample PO file
2. scim-chewing
3. oowriter, gedit and kbabel
4. scim-chewing-0.3.1-9.fc7
5. [Ctrl - space ] to activate it.

Steps to reproduce
o Gnome-terminal
o rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" scim\* | sort
Steps to reproduce ::
o Applications --> Accessories -> Terminal

o For the #216377
For Gedit
double-click several times after the second word 我
After following the steps to reproduce mentioned in the original bug. After
ji3+Enter+ji3, Not getting it as a single word as mentioned above, and further
double clicking after keysequence deletes the word 我, since its in the preedit
state.

For Open Office ::
1. Either the method followed for gedit.
2. SourceFile for testing ::
http://groups.google.com/group/zhongth0/browse_thread/thread/40d7e7f88200c96b/cfa48dd75d4efa97?hl=zh-TW#cfa48dd75d4efa97

3. Between the input ji3 enter ji3 to get it
4. Test for pageup and page down keys

For kbabel
1. Open the sample PO file attached with the bug
2. Active scim-chewing
3. Page Up / Page Down, look for the behavior in the field id |Original String|
translated String | Menu
4. Input some characters in the Translated String (msgstr) filed
5. Changes take place

Observation for #216377
They work fine, attaching the sample doc zn_TW.odt used for testing.


oo For #209575 (from the bug)
o make sure gedit, scim, scim-chewing are installed.
o Application -> Terminal.
o input `GTK_IM_MODULE=scim gedit`, gedit launches
o click on tray icon and select Chinese (Traditional) -> Chewing, in gedit
input field, press 'j' 'i' '3' keys and click「Enter」, still 'j' 'i' '3' keys
and click「Enter」, it should be '我我'
o. select first'我', and press 'c'
o Gedit must not crash.

Observations for #209575
====
o The following bug is resolved for the steps mentioned above.
Comment 4 Ramakrishna Reddy Yekulla 2007-01-11 23:30:12 EST
Created attachment 145425 [details]
File used to test OpenOffice with scim-chewing issue

I have used the following file to test page up / page down behavior  for
scim-chewing, please report if any changes can be done
Comment 5 Ramakrishna Reddy Yekulla 2007-01-11 23:33:33 EST
Created attachment 145426 [details]
PO file used to test it with Kbabel.

The following PO file was used to test the functionality of scim-chweing with
Kbabel, inputiing character and PageUp and Page Down was checked

Note You need to log in before you can comment on or make changes to this bug.