Bug 216652 - Firefox (and other Mozilla based browser) crashes randomly with no error
Firefox (and other Mozilla based browser) crashes randomly with no error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 07:47 EST by Ralf Schoenberg
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 08:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (748 bytes, patch)
2007-05-02 12:15 EDT, Martin Stransky
no flags Details | Diff

  None (edit)
Description Ralf Schoenberg 2006-11-21 07:47:27 EST
Description of problem:

Firefox and also other Mozilla based web browser are crashing randomly in the 
middle of the work. There is no error coming back, the application just 
terminates.
I have a new FC6 install on a new AMD 64 but I had exactly the same problem 
with my old i686 and FC5. 
It shuts down all open Firefox windows. The same is happening to Seamonkey 
When using Konqueror only the active window will shut down.

The issue is not isolated to e-bay but easily to reproduce there.


Version-Release number of selected component (if applicable):

Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.0.8) Gecko/20061107 
Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8


How reproducible:

As it is not always it might take some time to reproduce. But it is almost 
always happening on e-bay.


Steps to Reproduce:
1. goto www.ebay.de (no need to log in)
2. goto "Kaufen"
3. goto "Modellbau"
4. goto "Rennbahnen&Slotcars" and most likely it chrashes there
  
Actual results:

Firefox terminates


Expected results:

Firefox to continue browsing


Additional info:

Please let me know if you need any traces from my machine (but please send me 
the exact commands to execute).
Comment 1 Jake Langham 2006-11-29 17:31:05 EST
I can confirm this bug - it's getting increasingly frustrating.

Running FC6 x86_64 and Firefox 1.5.0.8-1.fc6.x86_64.

I also receive no errors on program termination.
Comment 2 rob 2006-12-03 08:12:14 EST
Confirm this bug on FC6 i386 and Firefox 1.5.0.8.  It is very frustrating.
Comment 3 cornel panceac 2006-12-04 14:47:58 EST
same thing happens if you try to "save as"
ftp://ftp.iasi.roedu.net/mirrors/centos.org/4.4/isos/i386/CentOS-4.4-i386-binDVD.torrent

i've launched from terminal and i get:

$ firefox --verbose

(Gecko:24376): Gdk-CRITICAL **: gdk_colormap_get_screen: assertion
`GDK_IS_COLORMAP (cmap)' failed

(Gecko:24376): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT
(object)' failed

(Gecko:24376): Gdk-CRITICAL **: gdk_colormap_get_visual: assertion
`GDK_IS_COLORMAP (colormap)' failed
/usr/lib/firefox-1.5.0.8/run-mozilla.sh: line 131: 24376 Segmentation fault    
 "$prog" ${1+"$@"}
$
Comment 4 Nathanael Noblet 2007-02-02 12:34:14 EST
I can confirm similar behaviour with FC6, x86_64 1GB RAM. firefox-1.5.0.9
Comment 5 Matěj Cepl 2007-02-05 12:20:11 EST
rob, do you have 32-bit or 64-bit? I cannot reproduce this on 32-bit.
Comment 6 rob 2007-02-05 12:25:09 EST
32 bit (see original post - "i386").  I didnt think about running verbose.  I'm
not using ff1.5 any more (using 2.0.0.1 with relatively few problems) but will
reinstall 1.5 and play about see if i can replicate it again.
Comment 7 Shaun Dudley 2007-04-15 21:27:31 EDT
Seeing the same random crashing of Firefox happening on my Compaq nx6325 (AMD
Turion64 x2). Firefox seems to crash more frequently when clicking on hyperlinks
that call another application such as a hyperlink for a torrent calling the
BitTorrent client or a hyperlink calling the PDF reader for a PDF etc. I don't
remember this being a problem during earlier versions of the kernal if that has
anything to do with it. 
Additional Data: 2.6.20-1.2944.fc6 #1 SMP Tue Apr 10 17:46:00 EDT 2007 x86_64
x86_64 x86_64
Interestingly enough when I yum -info firefox it shows the two recent versions
of Firefox installed. 1.5.0.9 & 1.5.0.10 in 32 and 64 bit versions. I have not
done any custom complilations of Firefox. Everything was updated with the yum
utility.


Comment 8 Christopher Aillon 2007-04-15 22:23:03 EDT
Martin, can you look at this?  I believe this is also causing a bunch of
Epiphany crashes.  http://bugzilla.gnome.org/show_bug.cgi?id=413350
Comment 9 Martin Stransky 2007-04-16 04:49:27 EDT
Can you please try to get a bactrace? how-to is here -
http://people.redhat.com/stransky/mozilla
Comment 10 Christopher Aillon 2007-04-16 10:52:48 EDT
The gnome bug has tons of backtraces and about 30+ dupes.  They are all on FC6
x86-64.
Comment 11 Martin Stransky 2007-04-16 10:57:06 EDT
aha, okay.
Comment 12 Martin Stransky 2007-04-19 10:03:24 EDT
yeah, finally I can reproduduce this crash (
http://bugzilla.gnome.org/show_bug.cgi?id=413350)
Comment 13 Martin Stransky 2007-05-02 12:15:47 EDT
Created attachment 153965 [details]
proposed patch
Comment 14 Martin Stransky 2007-05-02 12:22:36 EDT
Kai,

what do you think about this patch? 

The Main thread is registered by nsIThread::SetMainThread (and via.
PR_SetThreadPrivate) and it's released in _PR_DestroyThreadPrivate (during
exit()), right?

So I think this hack in nsThread::Shutdown should not be there.
Comment 15 Christopher Aillon 2007-05-02 17:08:55 EDT
*** Bug 238770 has been marked as a duplicate of this bug. ***
Comment 16 Kai Engert (:kaie) 2007-05-02 18:02:12 EDT
(In reply to comment #12)
> yeah, finally I can reproduduce this crash (
> http://bugzilla.gnome.org/show_bug.cgi?id=413350)

Martin, did you reproduce the crash using Firefox or Epiphany? Or both?
Comment 17 Kai Engert (:kaie) 2007-05-02 18:20:00 EDT
Ralf reported this bug in November 2006 against Firefox and SeaMonkey.

I do NOT see crashes using Firefox or SeaMonkey.


The Gnome bug got filed on 2007-03-01.
All duplicate bug reports are against Epiphany, and they all got filed after
2007-03-01.

I CAN reproduce the epiphany crash.

I conclude the epiphany crash got introduced on or closely before 2007-03-01, by
new FC 6 update packages.


I suspect these are different bugs.


(In reply to comment #14)
> So I think this hack in nsThread::Shutdown should not be there.

If you hover this code in:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpcom/threads/nsThread.cpp&rev=1.60&cvsroot=/cvsroot
you'll see that it got added 7 years ago.

I think it's more likely the bug is caused by something else.


Martin, did you actually test your proposed patch?
Did it fix the crash for you?

If this call is the cause of the crash, why is nsThread::Shutdown not listed in
the stack traces?
Comment 18 Kai Engert (:kaie) 2007-05-02 18:26:11 EDT
While I'm still interested in the answer to above questions, maybe Martin is
right that his patch can help. I realize with NSPR 4.6.5 we added a patch that
makes thread cleanup work better.

NSPR 4.6.5 for FC6 got released by the end of february 2007, so it might be
related to the many crashes that got reported with epiphany starting in March.

However, it would not explain why Ralf crashed before that date.
Comment 19 Kai Engert (:kaie) 2007-05-02 18:35:58 EDT
I'm answering some of my own questions:

(In reply to comment #17)
> If this call is the cause of the crash, why is nsThread::Shutdown not listed in
> the stack traces?

Because probably nsThread::Shutdown called it first, and the NSPR thread cleanup
code (added with nspr-4.6.5.fc6) called it afterwards.
Comment 20 Kai Engert (:kaie) 2007-05-02 21:37:22 EDT
I have reopened bug 238770, because I know what caused it, it got introduced
after 2007-02-24 and it is a crash-on-exit only.

This bug is clearly something else, because Ralf experiences it in the middle of
his work, and he saw this bug 3 months earlier.

Comment 8 up to comment 19 in this bug really belong to bug 238770.
While Martin found the right place to fix this issue, I'll propose and explain a
different patch in bug 238770.
Comment 21 Martin Stransky 2007-05-16 08:39:33 EDT
Anyway, I still can't reproduce the original bug. Closing a worksforme.
Reporter, please reopen and attach the backtrace when it appears again.
Comment 22 Matěj Cepl 2007-07-04 12:25:06 EDT
Martin, I think this upstream bug 413350
(http://bugzilla.gnome.org/show_bug.cgi?id=413350), which is a bug with most
duplicates I have seen in my life.
Comment 23 Kai Engert (:kaie) 2007-07-06 18:46:44 EDT
(In reply to comment #22)
> Martin, I think this upstream bug 413350
> (http://bugzilla.gnome.org/show_bug.cgi?id=413350), which is a bug with most
> duplicates I have seen in my life.

Matej, I think gnome 413350 is related to the "crash on exit" only.
We understand why it crashes on exit and have a fix, we just haven't pushed out
the fix to all channels yet.

This bug 216652 is about random crashes, in the middle of using Firefox, and for
this separate problem we don't yet understand why it happens.

Note You need to log in before you can comment on or make changes to this bug.