Bug 238770 - Epiphany crashes on closing
Epiphany crashes on closing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kai Engert (:kaie)
: Reopened
: 232378 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 17:06 EDT by Ashish Shukla
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.6.7-0.7.1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 13:02:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
epiphany backtrace + strace (a bit) (1.46 KB, text/plain)
2007-05-23 13:48 EDT, Michal Babej
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 435312 None None None Never
Mozilla Foundation 379550 None None None Never
Mozilla Foundation 383977 None None None Never

  None (edit)
Description Ashish Shukla 2007-05-02 17:06:05 EDT
Description of problem:
Epiphany crashes on closing

Version-Release number of selected component (if applicable):
epiphany-2.16.3-4.fc6

How reproducible:
On closing Epiphany web browser it crashes. It is reproducible every time.

Steps to Reproduce:
1. Close the Epiphany web browser.
  
Actual results:
It crashes.

Expected results:
It should not crash.

Additional info:
System: Linux 2.6.20-1.2944.fc6 #1 SMP Tue Apr 10 17:46:00 EDT 2007 x86_64
X Vendor: The X.Org Foundation
X Vendor Release: 70101000
Selinux: Enforcing
Accessibility: Disabled

Memory status: size: 592179200 vsize: 592179200 resident: 40402944 share:
22466560 rss: 40402944 rss_rlim: -1
CPU usage: start_time: 1178139633 rtime: 152 utime: 132 stime: 20 cutime:0
cstime: 0 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/epiphany'

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912496448832 (LWP 10984)]
0x000000304b00d96f in waitpid () from /lib64/libpthread.so.0
#0  0x000000304b00d96f in waitpid () from /lib64/libpthread.so.0
#1  0x0000003de1c56d07 in gnome_gtk_module_info_get () from
/usr/lib64/libgnomeui-2.so.0
#2  0x0000003de0411d03 in
nsSupportsWeakReference::~nsSupportsWeakReference$base () from
/usr/lib64/firefox-1.5.0.10/libgtkembedmoz.so
#3  <signal handler called>
#4  0x0000000000bd68f0 in ?? ()
#5  0x0000003703413d9d in PR_NewRWLock () from /usr/lib64/libnspr4.so
#6  0x0000003703426a71 in PR_ProcessExit () from /usr/lib64/libnspr4.so
#7  0x0000003703426b4e in PR_ProcessExit () from /usr/lib64/libnspr4.so
#8  0x000000370340ce82 in __cxa_pure_virtual () from /usr/lib64/libnspr4.so
#9  0x00007fffd0539a10 in ?? ()
#10 0x000000370342a7c1 in _fini () from /usr/lib64/libnspr4.so
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 46912496448832 (LWP 10984)):
#0  0x000000304b00d96f in waitpid () from /lib64/libpthread.so.0
No symbol table info available.
#1  0x0000003de1c56d07 in gnome_gtk_module_info_get () from
/usr/lib64/libgnomeui-2.so.0
No symbol table info available.
#2  0x0000003de0411d03 in
nsSupportsWeakReference::~nsSupportsWeakReference$base () from
/usr/lib64/firefox-1.5.0.10/libgtkembedmoz.so
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x0000000000bd68f0 in ?? ()
No symbol table info available.
#5  0x0000003703413d9d in PR_NewRWLock () from /usr/lib64/libnspr4.so
No symbol table info available.
#6  0x0000003703426a71 in PR_ProcessExit () from /usr/lib64/libnspr4.so
No symbol table info available.
#7  0x0000003703426b4e in PR_ProcessExit () from /usr/lib64/libnspr4.so
No symbol table info available.
#8  0x000000370340ce82 in __cxa_pure_virtual () from /usr/lib64/libnspr4.so
No symbol table info available.
#9  0x00007fffd0539a10 in ?? ()
No symbol table info available.
#10 0x000000370342a7c1 in _fini () from /usr/lib64/libnspr4.so
No symbol table info available.
#11 0x0000000000000000 in ?? ()
No symbol table info available.
#0  0x000000304b00d96f in waitpid () from /lib64/libpthread.so.0


----------- .xsession-errors ---------------------
  Major opcode:  54
  Minor opcode:  0
  Resource id:  0x181ecf3
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  156
  Minor opcode:  6
  Resource id:  0x181ecf3
X Error: BadPixmap (invalid Pixmap parameter) 4
  Major opcode:  54
  Minor opcode:  0
  Resource id:  0x181ecf4
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  156
  Minor opcode:  6
  Resource id:  0x181ecf4
--------------------------------------------------
Comment 1 Christopher Aillon 2007-05-02 17:08:42 EDT

*** This bug has been marked as a duplicate of 216652 ***
Comment 2 Kai Engert (:kaie) 2007-05-02 21:31:13 EDT
I'm reopening this bug, I have good reasons to believe it is NOT a duplicate of
bug 216652.
Comment 3 Kai Engert (:kaie) 2007-05-02 21:32:11 EDT
taking bug
Comment 4 Kai Engert (:kaie) 2007-05-02 21:47:24 EDT
Bug 216652 comment 8 up to bug 216652 comment 19 have some more thinking on this
bug, but I will summarize the final information here.

At the end of february 2007, we shipped a new NSPR package version 4.6.5. It
included an upstream patch to clean up thread local storage on application exit.
That patch was required to fix an issue around broken smart card login.

Martin correctly identified that Mozilla tries to do some cleanup on its own.
Because NSPR now does, too, that cleanup function gets called twice.

I discussed this problem with Wan-Teh Chang, who initially wrote the NSPR patch.

I'll attach a patch that will work in both cases, whether or not that NSPR patch
is applied (Official Mozilla 1.8 branch does not yet use it). This will prepare
upstream for a time when it upgrades to newer NSPR, too.

The disadvantage of that solution, until the patch gets accepted upstream, we'll
have to rebuild all mozilla based applications, like Firefox, SeaMonkey,
Epiphany, Thunderbird.
Comment 5 Kai Engert (:kaie) 2007-05-02 22:36:09 EDT
I've attached the proposed fix to upstream bug 379550.
Comment 6 Martin Stransky 2007-05-03 07:03:21 EDT
Both patches work for me, so we can pick one and use it.
Comment 7 Fedora Update System 2007-05-14 13:07:31 EDT
firefox-1.5.0.10-6.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Ashish Shukla 2007-05-15 00:48:49 EDT
Epiphany works fine after upgrade to firefox-1.5.0.10-6.fc6 :)
Comment 9 Michal Babej 2007-05-23 13:47:26 EDT
this bug is there in F7 devel (installed from 05/23/2007 tree). I think its this
bug based on comment #4 but i'll attach some info to be sure.
Comment 10 Michal Babej 2007-05-23 13:48:47 EDT
Created attachment 155281 [details]
epiphany backtrace + strace (a bit)
Comment 11 Aaron Schlaegel 2007-05-24 01:05:00 EDT
I still get this bug in FC6, despite the fact that others have had some luck
with FC6 after firefox-1.5.0.10-6.fc6. I can post stack traces with debug info
for FC6 if it would be helpful.
Comment 12 Martin Stransky 2007-05-24 04:49:28 EDT
okay, please attach the stack trace.
Comment 13 Aaron Schlaegel 2007-06-08 00:24:33 EDT
Sorry for the long delay. I found that if I uninstalled epiphany-extensions my
problems went away. Keep in mind I really like some of those extensions, like
Quick Search and Ad Blocker, but I really, really like a browser that doesn't
barf every time it closes.
Comment 14 Matěj Cepl 2007-06-29 05:20:06 EDT
looks like a dup of bug 232378
Comment 15 Matěj Cepl 2007-07-04 12:12:48 EDT
*** Bug 232378 has been marked as a duplicate of this bug. ***
Comment 16 Kai Engert (:kaie) 2007-07-06 19:01:34 EDT
I produced updated NSPR packages that should show up soon in the updates-testing
channel for FC6 and F7: nspr-4.6.7-0.7.1.fc7 and nspr-4.6.7-0.6.1.fc6

If you are able to reproduce the crash, I would like to encourage you to install
the updates-testing package and report in this bug whether it fixes the crash.

Thanks in advance for your help.
Comment 17 Fedora Update System 2007-07-09 11:45:23 EDT
nspr-4.6.7-0.7.1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Aaron Schlaegel 2007-07-10 19:36:25 EDT
I installed the testing nspr, reinstalled epiphany-extensions, and then enabled
all of the extensions I have ever used. I have yet to see it crash once, and I
have tried many times. Considering that on my systems the crash was completely
predictable, I think this bug is conquered.

Thank you (and everyone else involved) so much.
Comment 19 Fedora Update System 2007-07-16 13:01:54 EDT
nspr-4.6.7-0.7.1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.