Bug 216659 - gnome-bluetooth-manager doesn't return scan info & properties
gnome-bluetooth-manager doesn't return scan info & properties
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-bluetooth (Show other bugs)
5.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Bastien Nocera
:
: 216660 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 08:32 EST by Erik Bussink
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 19:42:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Bussink 2006-11-21 08:32:47 EST
Description of problem:

On the RHEL5 Beta2 Desktop (Client + Workstation) (x86_64), the gnome-bluetooth-
manager does not return any information from it's scan or the properties tab.

Version-Release number of selected component (if applicable):

gnome-bluetooth-manager-0.7.0-10.1
"Bluetooth Device Manager 0.7.0"

How reproducible:


Steps to Reproduce:
1. Start gnome-bluetooth-manager
2. select scan
3. from the command prompt the result from 'hcitool scan' shows what should be 
returned by the gnome-bluetooth-manager
  
Actual results:

nothing return of data

Expected results:

same as 'hcitool scan' done from a terminal

Additional info:
Comment 1 Dag Bjerkeli 2006-11-27 15:23:10 EST
I experienced the same result in Fedora Core 6 on i686, having the same version
of gnome-bluetooth-manager. Starting the gnome-bluetooth-manager from a terminal
gives some warning messages that might be relevant.

<Startup of the manager>
/usr/lib/python2.4/site-packages/gnomebt/manager.py:142: DeprecationWarning:
gnome.ui.AppBar constructor takes exactly 3 arguments, but calling old gtk.HBox
constructor for compatibility reasons.
  self.statusbar = gnome.ui.AppBar (True, True)

<After selectin Devices->scan>
/usr/lib/python2.4/site-packages/gnomebt/manager.py:220: GtkWarning:
gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed
  self.statusbar.pop ()
/usr/lib/python2.4/site-packages/gnomebt/manager.py:222: GtkWarning:
gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed
  self.statusbar.push (_("Scanning for devices..."))

(Bluetooth Device Manager:4146): GnomeUI-CRITICAL **:
gnome_appbar_set_progress_percentage: assertion `appbar->_priv->progress !=
NULL' failed
Comment 3 RHEL Product and Program Management 2006-11-28 10:02:12 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Harald Hoyer 2006-11-28 10:05:16 EST
*** Bug 216660 has been marked as a duplicate of this bug. ***
Comment 5 Rogue 2006-11-30 14:21:38 EST
I am no python expert, but from looking at the code here is what i have deciphered:

AppBar extends from HBox, and HBox has a two argument constructor which is
over-shadowing the 3 argument constructor of AppBar, when it is invoked using
just two arguments.

The third argument in AppBar is an enum on PreferencesType. Now, i am not sure
how we would specify a preferences type in the UI, but here is what I did:

/usr/lib/python2.4/site-packages/gnomebt/manager.py
changed #142 from:
    self.statusbar = gnome.ui.AppBar (True, True)
to:
    self.statusbar = gnome.ui.AppBar (True, True, 0)

This got rid of the null pointer assertions and the UI comes up fine.

Now, when I do a scan for devices, it hangs at retrieving device names! And
there are no messages on the console either.

Details:
Bluetooth Device Manager: 0.7.0
Fedora Core 6
Comment 6 Harald Hoyer 2006-12-14 11:10:07 EST
fixed with gnome-bluetooth-0.7.0-10.2.el5
Comment 7 Erik Bussink 2006-12-16 20:42:29 EST
Harald,
I've downloaded the gnome-bluetooth-0.7.0-10.2.el5 for my x86_64 install using
the path you gave me, but I cannot tell if this bug is now fixed or not. 
The gnome-bluetooth-manager application isn't in the RPM
gnome-bluetooth-0.7.0-10.2.el5.x86_64.rpm anymore. Is the removal of the
gnome-bluetooth-manager done on purpose or a mistake ?
Comment 8 Harald Hoyer 2006-12-18 04:18:50 EST
Removed on purpose, you should be using "Send To" from the nautilus context menu
on files. Btw, it's removed in newer upstream versions as well.
Comment 9 RHEL Product and Program Management 2007-02-07 19:42:33 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.