Bug 216661 - x doesn't start in libXfont-1.2.3-3.fc7
x doesn't start in libXfont-1.2.3-3.fc7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXfont (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 217032 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 08:43 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 10:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log in libXfont-1.2.3-3.fc7 (26.62 KB, text/plain)
2006-11-21 08:43 EST, sangu
no flags Details
Xorg log output.... (70.71 KB, text/plain)
2006-11-21 10:22 EST, Tom London
no flags Details
Xorg log with usually working dual head (70.40 KB, text/plain)
2006-11-21 18:28 EST, Jim Cornette
no flags Details

  None (edit)
Description sangu 2006-11-21 08:43:03 EST
Description of problem:
$cat Xorg.0.log
[...]
Could not init font path element /usr/share/X11/fonts/75dpi:unscaled, removing
from list!
Could not init font path element /usr/share/X11/fonts/100dpi:unscaled, removing
from list!
Could not init font path element /usr/share/X11/fonts/misc:unscaled, removing
from list!
Could not init font path element /usr/share/X11/fonts/Type1, removing from list!
Could not init font path element /usr/share/fonts/default/Type1, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/hanyang, removing from
list!

Fatal server error:
could not open default font 'fixed'


Version-Release number of selected component (if applicable):
1.2.3-3.fc7

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
No problem in libXfont-1.2.2-1.fc6
Comment 1 sangu 2006-11-21 08:43:03 EST
Created attachment 141763 [details]
/var/log/Xorg.0.log in libXfont-1.2.3-3.fc7
Comment 2 Tom London 2006-11-21 10:22:52 EST
Created attachment 141775 [details]
Xorg log output....

Get similar failure to start up graphical login....

Here is output from running 'startx':

[root@localhost ~]# cat err
xauth:	creating new authority file /root/.serverauth.3261


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Fedora Core 5 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.18-1.2849.fc6 #1 SMP
Fri Nov 10 12:45:28 EST 2006 i686
Build Date: 10 November 2006
Build ID: xorg-x11-server 1.1.1-51.fc7 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 21 07:00:12 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(1600x1200,Monitor0) mode clock 162MHz exceeds DDC maximum 140MHz
Could not init font path element unix/:7100, removing from list!
Could not init font path element built-ins, removing from list!

Fatal server error:
could not open default font 'fixed'
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
[root@localhost ~]# 


Reverting 'libfont*' and 'libXfont*' packages restores function.
Comment 3 Steve 2006-11-21 10:54:02 EST
I can confirm that also...
Comment 4 Jukka Ketelaars 2006-11-21 15:58:50 EST
Same problem here. xfs crashes with this version of libXfont. Running 'xfs
-nodaemon' yields: "xfs fatal error: element #0 (starting at 0) of font path is
bad or has a bad font."
Comment 5 Jim Cornette 2006-11-21 18:27:05 EST
Down for the count also. Adding to CC:
Comment 6 Jim Cornette 2006-11-21 18:28:42 EST
Created attachment 141852 [details]
Xorg log with usually working dual head
Comment 7 Jim Cornette 2006-11-21 20:53:31 EST
Rolling back to FC6 versions of libXfont avd associated packages is all that was
needed in order to get development back up and running in GUI. No other packages
are reverted.

Output below from pup - Update details.
libXfont-devel - 1.2.3-3.fc7.i386 updates libXfont-devel - 1.2.2-1.fc6.i386
libXfont - 1.2.3-3.fc7.i386 updates libXfont - 1.2.2-1.fc6.i386

Like Baretta, just don't do it.
Comment 8 Jochen Schlick 2006-11-23 03:54:52 EST
after rolling back to the FC6 versions of libXfont - X11 is running again. But
I'm now only able to run failsafe sessions! There must be also something going
wrong with KDE because the KDM login window reappears immediately after entering
name and password. 


PS: Is there a lynx optimated interface of bugzilla available ? It's very hard
to look for bug reports in bugzilla when X11 doesn't run.
Comment 9 Austin Foxley 2006-11-23 14:46:36 EST
*** Bug 217032 has been marked as a duplicate of this bug. ***
Comment 10 Mamoru TASAKA 2006-11-24 01:13:20 EST
Reproducive on 
"Intel Corporation 82852/855GM Integrated Graphics Device".

However, I tried installing mockbuild libXfont-1.2.3-3.fc7.i386
with libXfont-1.2.3-namespace-pollution.patch _removed_ and for now
there seems no problem.
Comment 11 Steve 2006-11-26 15:57:01 EST
Seems to be fixed in version 1.2.3-4.fc7!
Comment 12 Daniel Malmgren 2006-11-27 02:38:17 EST
(In reply to comment #11)
> Seems to be fixed in version 1.2.3-4.fc7!

...because the namespace patches was backed out, which I guess means 1.2.4-4 is
the same thing as 1.2.3-1, right?

I'd like to notice that this hasn't got anything with xfs to do. I don't use xfs
(I simply put the paths directly in xorg.conf).
Comment 13 Adam Jackson 2006-11-27 10:46:26 EST
Fixed now.

Note You need to log in before you can comment on or make changes to this bug.