Bug 216705 - Beagle firefox extensions loose ...
Beagle firefox extensions loose ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Nielsen
bzcl34nup
:
: 219243 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 11:53 EST by Jérôme Benoit
Modified: 2008-05-06 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jérôme Benoit 2006-11-21 11:53:21 EST
Description of problem: Beagle firefox extensions loose ...


Version-Release number of selected component (if applicable): 0.2.10-7.fc6


How reproducible:

Latest beagle updates loose beagle URL indexing


Steps to Reproduce:
1. Well install lastest beagle package 
2. Beagle extension for firefox have disapear
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alexander Larsson 2006-11-22 06:01:42 EST
caillon: This is probably related to the trigger changes. Any idea what is
causing this?
Comment 2 Christopher Aillon 2006-11-22 11:39:37 EST
No, I specifically ensured that the following cases worked:

- Beagle install on a system without firefox, then install firefox.
- Firefox install on a system without beagle, then install beagle.
- Firefox update while beagle installed
- Beagle update while firefox installed

Firefox must be restarted though to pick up changes.  It's possible that the
user needs to simply restart.
Comment 3 Jérôme Benoit 2006-11-22 12:59:55 EST
Well, i've filled this bug just because in any case you've described below,
beagle firefox extension have disapear ... Not a big deal anyway. X session
restart solve nothing, complete system reboot as well.

Thanks.
Comment 4 Jérôme Benoit 2006-11-22 22:26:29 EST
/usr/lib/beagle/beagle.xpi is there ... 

But in beagle .spec file :

%triggerin -- firefox
if [ -f %{_libdir}/beagle/beagle-plugin-path ]; then
  old=`cat %{_libdir}/beagle/beagle-plugin-path`
  rm -rf $old
  rm -rf  %{_libdir}/beagle/beagle-plugin-path
fi

# install the firefox extension
if [ -f %{grefile} ] ; then
  ffdir=$(cat %{grefile} | awk '/GRE_PATH/ { split($0,p,"="); print p[2] }')

  cd $ffdir/extensions
  mkdir beagle-extension
  unzip -q -d beagle-extension %{_libdir}/beagle/beagle.xpi
  id=`grep em:id beagle-extension/install.rdf | head -1 | sed -e 's/^ *//' -e
"s/<[^<]*>//g" | tr -d "\n\r"`
  if [ -e "$id" ]; then
    rm -rf beagle-extension
  else
    mv beagle-extension "$id"
  fi

  echo "$ffdir/extensions/$id" >  %{_libdir}/beagle/beagle-plugin-path
fi

%triggerun -- firefox
# uninstall the firefox extension
if [ $2 = 0 -a -f %{_libdir}/beagle/beagle-plugin-path ]; then
  old=`cat %{_libdir}/beagle/beagle-plugin-path`
  rm -rf $old
  rm -rf  %{_libdir}/beagle/beagle-plugin-path
fi

do not seem to have done the right thing on my system. 

The directory /usr/lib/beagle/beagle-plugin-path has been deleted ... really i
don't understand why, the spec file code seems correct. Will try to force a
beagle rpm reinstall and see what happens.
Comment 5 Christopher Aillon 2006-11-23 22:49:57 EST
Odd.  If you could track that down,  it'd be appreciated since I can't reproduce...
Comment 6 Alexander Larsson 2006-12-12 05:30:54 EST
*** Bug 219243 has been marked as a duplicate of this bug. ***
Comment 7 Jérôme Benoit 2006-12-12 13:09:15 EST
it has happened again with the latest beagle update last night ... i've
downgraded beagle, then i've done again a yum upgrade in order to try to
reproduce ... twice ... can't reproduce it, very odd, really ... 
Comment 8 vfiend 2006-12-12 22:56:22 EST
I had the same problem with the FC6 0.2.13-1 update, too. I uninstalled the
beagle rpms and reinstalled them and it worked.
Comment 9 Christopher Aillon 2006-12-13 03:13:30 EST
I suppose it would be useful to see the output of:
	grep "firefox\|beagle" /var/log/yum.log

Can someone attach that to the bug, and point out where this broke?  Trying to
recreate things in the same exact order may help figure out what is going on here.
Comment 10 vfiend 2006-12-13 19:19:19 EST
# grep "firefox\|beagle" /var/log/yum.log
Dec 11 14:49:18 Updated: libbeagle.x86_64 0.2.13-1.fc6
Dec 11 14:50:51 Updated: beagle.x86_64 0.2.13-1.fc6
Dec 11 14:50:57 Updated: beagle-gui.x86_64 0.2.13-1.fc6
Dec 11 14:51:01 Updated: beagle-evolution.x86_64 0.2.13-1.fc6
Dec 12 18:21:45 Erased: beagle-gui
Dec 12 18:21:46 Erased: beagle-evolution
Dec 12 18:21:47 Erased: beagle
Dec 12 18:23:20 Installed: beagle.x86_64 0.2.13-1.fc6
Dec 12 18:23:21 Installed: beagle-gui.x86_64 0.2.13-1.fc6
Dec 12 18:23:21 Installed: beagle-evolution.x86_64 0.2.13-1.fc6


Nope, that doesn't help. It broke at the update and was fixed by the
erase/re-install.
Comment 11 Bug Zapper 2008-04-04 00:51:13 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 12 Bug Zapper 2008-05-06 12:54:12 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.