Bug 21673 - failed kickstart install
Summary: failed kickstart install
Status: CLOSED DUPLICATE of bug 18863
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkkickstart   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-04 08:09 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-04 08:09:08 UTC
Hello,

I'm trying to get a kickstart install going with RH 7.0. After getting an
install I liked, I used 
mkkickstart to make the attached ks.cfg, which I copied to a boot disk.

When I tried the kickstart install, I got the attached error, with the
suggestion that I send it to you.

I hope it's useful to you - please let me know if you need more info.

-ben heavner


----------------------ks.cfg----------------------------
lang en_US
 
network --bootproto dhcp
 
cdrom
 
device ethernet eepro100
 
keyboard "us"
 
zerombr yes
clearpart --linux
part swap --size 259
install
 
mouse genericps/2
 
timezone America/New_York
 
xconfig --server "SVGA" --monitor "generic monitor"
         rootpw --iscrypted $1$uSil3.HB$B8Yk7rJp1Qj6vaScWLOsn1
 
auth --useshadow
 
lilo --location mbr
 
%packages
filesystem
glibc
<--snip-->
gnuplot
 
%post

----------------------anacdump.txt-----------------------
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/partitioning_text.py",
line 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in
allowLiloLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object
 
Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 8285360>
self: <lilo.LiloConfiguration instance at 82838c0>
bootDevice: None
 
ToDo object:
(itodo
ToDo
 
Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 8285360>
self: <lilo.LiloConfiguration instance at 82838c0>
bootDevice: None
 
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6
 
<failed>

Comment 1 Michael Fulbright 2000-12-04 16:16:49 UTC
Passed to QA to reproduce.

Comment 2 Brock Organ 2000-12-04 21:28:41 UTC
verified ... this is an issue with hardware raid cards (such as the SA5300) ...
thanks for your report!


Comment 3 Michael Fulbright 2000-12-05 17:11:40 UTC
Assigning to a developer.

Comment 4 Need Real Name 2000-12-07 10:54:47 UTC
Um... but I don't have a RAID card - I'm installing on a pretty average
inexpensive box (no SCSI even)

Comment 5 Arnoud Witt 2000-12-08 12:40:39 UTC
I had a similar problem. I also generated a kickstart file with mkkickstart. 
The kickstart file produced contains a swap partition entry and no others:

zerombr yes
clearpart --all
part swap --size 141
install

When I added entries for / and /boot like:

part /boot --size 20
part / --grow

installation proceeded without any problems.

Problem remains that anaconda should come with the DiskDruid screen when these 
lines are left out.

The machine I did the install on is an ordinary Intel Pentium system with one 
IDE drive and no SCSI controller.

For reference the first part of the ks.cfg file, that caused the problem 
follows. I hope this will be of help.

My conclusion: This also shows that mkkickstart does not guarantee to produce 
correct output.

------------- ks.cfg --------------------------------
lang en_US

network --bootproto dhcp

nfs --server 10.0.22.2 --dir /home/ftp/RH70

keyboard "us"

zerombr yes
clearpart --all
part swap --size 141
install

mouse genericps/2 --emulthree

timezone Europe/Amsterdam

xconfig --server "Mach64" --monitor "generic monitor"

rootpw --iscrypted $1$/3a3xfNw$M9m3VVS/q7/8VgNqwjydH/

auth --useshadow

lilo --location mbr

%packages
--- etcetera ---

%post

---------------- end of ks.cfg ---------------------------------

Comment 6 Mark Wolfgang 2001-01-05 22:05:28 UTC
This is a problem due the style of the new /etc/fstab - using LABELS instead of devices names, so yes, kickstart failed because you didn't specify a 
partition structure.

I submitted patches months ago to fix this issue but no new RPM yet....

To get my mkkickstart, go to either http://people.redhat.com/wolfgang/mkkickstart  or  http://www.dork.myip.org

Comment 7 Alan Cox 2002-12-15 04:09:00 UTC

*** This bug has been marked as a duplicate of 18863 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:47:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.