Bug 216814 - Western Australia to trial daylight saving
Western Australia to trial daylight saving
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
: 217647 217648 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 21:32 EST by lannet
Modified: 2015-05-04 21:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: FC-5, FC-6, rawhide
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 13:31:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lannet 2006-11-21 21:32:11 EST
Description of problem:
Western Australia will trial daylight saving for three years.
It will be an advance of 1 hour and will be introduced on 3 Dec 06 for this year
and then will align with eastern states for the remainder of the trial.

I cannot find anything very official other than Hansard:
http://www.parliament.wa.gov.au/hansard/hans35.nsf/(Lookup+by+Page)/20060111068005?opendocument

Probable TZ entries might be:
Australia/Perth  Sat Dec 02 17:59:59 2006 UTC = Sun Oct 29 01:59:59 2006 EST
isdst=0 gmtoff=28800
Australia/Perth  Sat Dec 02 18:00:00 2006 UTC = Sun Oct 29 03:00:00 2006 EST
isdst=1 gmtoff=32400
Australia/Perth  Sat Mar 24 17:59:59 2007 UTC = Sun Mar 25 02:59:59 2007 EST
isdst=1 gmtoff=32400
Australia/Perth  Sat Mar 24 18:00:00 2007 UTC = Sun Mar 25 02:00:00 2007 EST
isdst=0 gmtoff=28800
Australia/Perth  Sat Oct 27 17:59:59 2007 UTC = Sun Oct 28 01:59:59 2007 EST
isdst=0 gmtoff=28800
Australia/Perth  Sat Oct 27 18:00:00 2007 UTC = Sun Oct 28 03:00:00 2007 EST
isdst=1 gmtoff=32400
Australia/Perth  Sat Mar 29 17:59:59 2008 UTC = Sun Mar 30 02:59:59 2008 EST
isdst=1 gmtoff=32400
Australia/Perth  Sat Mar 29 18:00:00 2008 UTC = Sun Mar 30 02:00:00 2008 EST
isdst=0 gmtoff=28800
Australia/Perth  Sat Oct 25 17:59:59 2008 UTC = Sun Oct 26 01:59:59 2008 EST
isdst=0 gmtoff=28800
Australia/Perth  Sat Oct 25 18:00:00 2008 UTC = Sun Oct 26 03:00:00 2008 EST
isdst=1 gmtoff=32400
Australia/Perth  Sat Mar 28 17:59:59 2009 UTC = Sun Mar 29 02:59:59 2009 EST
isdst=1 gmtoff=32400
Australia/Perth  Sat Mar 28 18:00:00 2009 UTC = Sun Mar 29 02:00:00 2009 EST
isdst=0 gmtoff=28800
Comment 1 Glen Turner 2006-11-21 23:53:46 EST
This is a fault in the tzdata package, currently at version 2006m in Fedora.

Updating to version 2006o from ftp://elsie.nci.nih.gov/pub will not fix this
fault.  The tz mailing list has been discussing the changes in Western Australia
and a new tzdata version will be issued shortly and before the change takes
effect. The WA parliament has passed the legislation but not gazetted this
change, so technically there is no bug at this precise moment in time as the law
is yet to come into force.

Fedora should closely track all upstream changes to the tzdata file, preferrably
within days. That will avoid the issue with Fedora having recurring bugs against
timezones being wrong.
Comment 2 lannet 2006-11-22 00:14:41 EST
This needs to be moved from kernel to tzdata
Comment 3 Ben Caradoc-Davies 2006-11-24 18:32:28 EST
(1) Please reassign this bug to the tzdata maintainer.

(2) Upstream tzdata 2006p is still not available. Consider manually applying the
proposed patch: http://article.gmane.org/gmane.comp.time.tz/1351

(3) The Western Australian daylight saving trial start in seven (7) days. Should
this bug be urgent?

(4) This bug affects all releases, not just fc6.
Comment 4 Ben Caradoc-Davies 2006-11-24 18:48:14 EST
SuSE have applied a patch to 2006o (see attachment):

https://bugzilla.novell.com/show_bug.cgi?id=223196

Comment 5 Petr Machata 2006-11-27 13:31:42 EST
The patch should be already in rawhide since around friday, and updates for FC6
and FC5 were pushed today.
Comment 6 Ben Caradoc-Davies 2006-11-28 05:35:58 EST
The latest tzdata has just been released. It includes the adjustments for the
West Australian daylight saving trial.

    ftp://elsie.nci.nih.gov/pub/tzdata2006p.tar.gz

I have installed and tested tzdata-2006m-3.fc5 and it also works correctly.

The simple test below (tzdata-2006m-3.fc5) uses 'date "+%z"' to obtain the
numeric time zone for each time and compare it with that obtained from reading
the legislation. My local time zone is Australia/Perth.

[ben@ripley tzdata]$ ./test_wa_daylight_saving.sh
Test for compliance with WA daylight saving trial: ripley
Sun Dec  3 00:00:00 WST 2006 +0800 - OK
Sun Dec  3 01:00:00 WST 2006 +0800 - OK
Sun Dec  3 03:00:00 WST 2006 +0900 - OK
Sun Dec  3 12:00:00 WST 2006 +0900 - OK
Mon Jan  1 12:00:00 WST 2007 +0900 - OK
Sun Mar 25 01:00:00 WST 2007 +0900 - OK
Sun Mar 25 03:00:00 WST 2007 +0800 - OK
Sun Mar 25 12:00:00 WST 2007 +0800 - OK
Sun Jul  1 12:00:00 WST 2007 +0800 - OK
Sun Oct 28 00:00:00 WST 2007 +0800 - OK
Sun Oct 28 01:00:00 WST 2007 +0800 - OK
Sun Oct 28 03:00:00 WST 2007 +0900 - OK
Sun Oct 28 12:00:00 WST 2007 +0900 - OK
Tue Jan  1 12:00:00 WST 2008 +0900 - OK
Sun Mar 30 01:00:00 WST 2008 +0900 - OK
Sun Mar 30 03:00:00 WST 2008 +0800 - OK
Sun Mar 30 12:00:00 WST 2008 +0800 - OK
Tue Jul  1 12:00:00 WST 2008 +0800 - OK
Sun Oct 26 00:00:00 WST 2008 +0800 - OK
Sun Oct 26 01:00:00 WST 2008 +0800 - OK
Sun Oct 26 03:00:00 WST 2008 +0900 - OK
Sun Oct 26 12:00:00 WST 2008 +0900 - OK
Thu Jan  1 12:00:00 WST 2009 +0900 - OK
Sun Mar 29 01:00:00 WST 2009 +0900 - OK
Sun Mar 29 03:00:00 WST 2009 +0800 - OK
Sun Mar 29 12:00:00 WST 2009 +0800 - OK
Wed Jul  1 12:00:00 WST 2009 +0800 - OK
Fri Jan  1 12:00:00 WST 2010 +0800 - OK
RESULT: All daylight saving tests on ripley OK
Comment 7 Petr Machata 2006-11-29 04:17:16 EST
*** Bug 217648 has been marked as a duplicate of this bug. ***
Comment 8 Petr Machata 2006-11-29 04:17:52 EST
*** Bug 217647 has been marked as a duplicate of this bug. ***
Comment 9 Petr Machata 2006-11-29 06:28:58 EST
Thanks for thorough testing!
Btw, I commited 2006p into CVS moments ago, and sent to release team for pushing
to FC 5 and FC 6.
Comment 10 Ben Caradoc-Davies 2006-11-29 16:49:29 EST
tzdata-2006p-1.fc5 just came through and I can confirm that it also passes all
tests (for local time zone Australia/Perth).

Thanks for the quick turnaround. We apologise for our politicians.


Note You need to log in before you can comment on or make changes to this bug.