This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 217 - dhcpd needs a 255.255.255.255 route to the interfaces
dhcpd needs a 255.255.255.255 route to the interfaces
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
: 2406 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-28 19:39 EST by Marc MERLIN
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-02 16:29:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 1998-11-28 19:39:25 EST
According to the documentation, dhcpd needs a host route of
255.255.255.255 on each ethernet interface (at least for
some versions of the linux kernels, it doesn't say which
ones work without this)

I modified /etc/rc.d/init.d/network as such on my system:
--- network.redhat      Thu Aug 13 19:17:15 1998
+++ network     Fri Aug 14 14:02:34 1998
@@ -82,6 +82,11 @@

        for i in $interfaces; do
                ./ifup $i boot
+               case $i in
+               eth*)
+                   /sbin/route add -host 255.255.255.255
dev $i
+                   ;;
+               esac
        done

         touch /var/lock/subsys/network

Also, as mentionned in another bug, it'd be _really_ nice
to have a default configuration file like this one

option domain-name "localdomain";
#option domain-name-servers 192.168.1.1;
option time-offset -8;
#option ntp-servers 192.168.1.1;
#option netbios-name-servers 192.168.1.1;
# Selects point-to-point node (default is hybrid). Don't
change this unless
# you understand Netbios very well
#option netbios-node-type 2;

# 30 days
max-lease-time 2592000;
# 7 days
default-lease-time 604800;

subnet 192.168.1.0 netmask 255.255.255.0 {
  option routers 192.168.204.1;
  range dynamic-bootp 192.168.1.200 192.168.1.230;
}

It is not meant to be working, but it's very easy to modify.
You may also want to look at having /etc/dhcpd.leases in the
rpm.

Last but not least, if the machine has an fddi board, dhcpd
refuses to run:
moremagic:~# /etc/rc.d/init.d/dhcpd start
Starting dhcpd: dhcpd Internet Software Consortium DHCPD
$Name: V2-BETA-1-PATCHLEVEL-6 $
Copyright 1995, 1996, 1997, 1998 The Internet Software
Consortium.
All rights reserved.
fddi0: unknown hardware address type 774
exiting.

I know you don't support fddi, this is more an FYI thing.
Comment 1 David Lawrence 1998-11-29 20:17:59 EST
It is verified that the route 255.255.255.255 is not enable by default
but I am not really sure this is a bug since it is not always
necessary to have. According to the documentation it says that
normally this is not necessary unless using Windows clients. I am
passing this on to a developer to see how they would like to address
it.
Comment 2 Marc MERLIN 1998-11-30 04:35:59 EST
You are correct, this is only if you intend to serve windows clients.
I've had to do that and it wouldn't work without that route.
Comment 3 Marc MERLIN 1999-02-25 02:02:59 EST
FYI:

dhcp 2.0b1pl14 now works with my fddi interface

moremagic:/tmp# /etc/rc.d/init.d/dhcpd start
Starting dhcpd: dhcpd Internet Software Consortium DHCP Server
V2.0b1pl14
Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software
Consortium.
All rights reserved.

Please contribute if you find this software useful.
For info, please visit http://www.isc.org/dhcp-contrib.html

Listening on LPF/eth0/00:80:c8:47:37:72/192.168.205.0
Sending on   LPF/eth0/00:80:c8:47:37:72/192.168.205.0
Listening on
LPF/fddi0/08:00:2b:b2:9f:d8:00:00:00:00:00:00:00:00:00:00/192.168.215.0
Sending on
LPF/fddi0/08:00:2b:b2:9f:d8:00:00:00:00:00:00:00:00:00:00/192.168.215.0
Sending on   Socket/fallback/fallback-net
Comment 4 Preston Brown 1999-03-18 10:48:59 EST
the dhcp and bootp client daemons have been replaced by pump. Erik,
does pump have these limitations?
Comment 5 Marc MERLIN 1999-04-07 03:18:59 EDT
I think you are confusing dhcp and dhcpd
Unfortunately, the package that contains dhcpd is called dhcp, hence
the confusion.
Comment 6 Jeff Johnson 1999-06-02 06:46:59 EDT
I've upgraded to dhcp-2.0b1pl28 that includes support for token
ring, and has a UDP checksum fix for cable modems.

Erik, do you want the default host route added when the interface
is brought up?
Comment 7 Jeff Johnson 1999-06-02 06:47:59 EDT
*** Bug 2406 has been marked as a duplicate of this bug. ***

Two problems with the dhcpd startup script:

1. dhcpd requires adding a route to "host" 255.255.255.255
to convince Linux not to screw up the address in the offer
message.  (Both Windows DHCP clients and pump [new in RH
6.0] are picky about this.)

In older versions of RedHat, adding the line "eth0 host
255.255.255.255" to /etc/sysconfig/static-routes solved the
problem.  Now this file is ignored if linuxconf exists, but
there doesn't seem to be any way to get linuxconf to spit
out the correct route.

2. For machines with multiple interfaces, it is necessary to
give dhcpd command-line options telling it on which
interfaces to provide DHCP service.  (By default, dhcpd
assumes all interfaces, but croaks if dhcpd.conf doesn't
include configurations for all of them.)

A simple solution is to append " ${DHCP_OPTIONS}" to "daemon
/usr/sbin/dhcpd" in the startup script.  This way, the user
can add something like

  DHCP_OPTIONS="eth1 st0"

to /etc/sysconfig/network if he wants DHCP only on eth1 and
st0.
Comment 8 Erik Troan 1999-06-02 16:29:59 EDT
This is only needed for some old (broken) windows stacks

Note You need to log in before you can comment on or make changes to this bug.