Bug 2406 - dhcpd script doesn't add route or pass options
dhcpd script doesn't add route or pass options
Status: CLOSED DUPLICATE of bug 217
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-28 21:26 EDT by Ed Swierk
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-02 06:47:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Swierk 1999-04-28 21:26:45 EDT
Two problems with the dhcpd startup script:

1. dhcpd requires adding a route to "host" 255.255.255.255
to convince Linux not to screw up the address in the offer
message.  (Both Windows DHCP clients and pump [new in RH
6.0] are picky about this.)

In older versions of RedHat, adding the line "eth0 host
255.255.255.255" to /etc/sysconfig/static-routes solved the
problem.  Now this file is ignored if linuxconf exists, but
there doesn't seem to be any way to get linuxconf to spit
out the correct route.

2. For machines with multiple interfaces, it is necessary to
give dhcpd command-line options telling it on which
interfaces to provide DHCP service.  (By default, dhcpd
assumes all interfaces, but croaks if dhcpd.conf doesn't
include configurations for all of them.)

A simple solution is to append " ${DHCP_OPTIONS}" to "daemon
/usr/sbin/dhcpd" in the startup script.  This way, the user
can add something like

  DHCP_OPTIONS="eth1 st0"

to /etc/sysconfig/network if he wants DHCP only on eth1 and
st0.
Comment 1 Jeff Johnson 1999-06-02 06:47:59 EDT
*** This bug has been marked as a duplicate of 217 ***

Note You need to log in before you can comment on or make changes to this bug.