Bug 217020 - gnash 0.7.2 instantly crash
gnash 0.7.2 instantly crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 03:05 EST by Fabio Pedretti
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 01:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of gnash -v -va -vp simpleguess.swf (16.52 KB, application/octet-stream)
2006-11-23 06:31 EST, Fabio Pedretti
no flags Details
gnash backtrace (2.78 KB, text/plain)
2006-11-24 09:21 EST, Fabio Pedretti
no flags Details
output of glxinfo (4.06 KB, text/plain)
2006-12-01 08:40 EST, Fabio Pedretti
no flags Details
output of xdpyinfo (6.06 KB, application/octet-stream)
2006-12-01 08:45 EST, Fabio Pedretti
no flags Details
gnash /tmp/simpleguess.swf ; glxinfo ; xdpyinfo (10.92 KB, text/plain)
2007-01-19 16:09 EST, Michael De La Rue
no flags Details
rpm -qi gnash; cat /proc/cpuinfo; rpm -qi gcc (2.08 KB, text/plain)
2007-01-20 13:56 EST, Michael De La Rue
no flags Details
/var/lib/mock/fedora-6-i386-core/result/build.log (235.38 KB, text/plain)
2007-03-09 19:39 EST, Michael De La Rue
no flags Details
/var/lib/mock/fedora-6-i386-core/result/root.log (317.44 KB, text/plain)
2007-03-09 19:41 EST, Michael De La Rue
no flags Details

  None (edit)
Description Fabio Pedretti 2006-11-23 03:05:11 EST
Description of problem:
gnash 0.7.2 instantly crash with any swf file. Worked fine with previous version.

Version-Release number of selected component (if applicable):
gnash-0.7.2-1.fc6

How reproducible:
$ gnash simpleguess.swf
libGL warning: 3D driver claims to not support visual 0x4b
Illegal instruction
Comment 1 Patrice Dumas 2006-11-23 06:22:17 EST
It works for me on devel. Could you attach the result of

gnash -v -va -vp simpleguess.swf
Comment 2 Fabio Pedretti 2006-11-23 06:31:16 EST
Created attachment 141984 [details]
output of gnash -v -va -vp simpleguess.swf
Comment 3 Patrice Dumas 2006-11-23 09:23:03 EST
Could you also, if possible run gnash under gdb after installing 
gnash-debuginfo, and give a backtrace. Something along

gdb --args gnash simpleguess.swf
....
(gdb) run
...
(gdb) bt
Comment 4 Fabio Pedretti 2006-11-24 09:21:58 EST
Created attachment 142067 [details]
gnash backtrace
Comment 5 Patrice Dumas 2006-11-30 16:43:20 EST
Could you also please run 
glxinfo
xdpyinfo
Comment 6 Fabio Pedretti 2006-12-01 08:40:51 EST
Created attachment 142563 [details]
output of glxinfo
Comment 7 Fabio Pedretti 2006-12-01 08:45:16 EST
Created attachment 142564 [details]
output of xdpyinfo

If you think this a problem of the X server, you may also be interested in bug
#198890.
Comment 8 Sandro Santilli 2006-12-25 18:53:47 EST
Fabio, could you try with current CVS version of Gnash ?
If the problem persist, please also try using AGG as a renderer, to at least
remove the GL part out of your path.
Comment 9 Fabio Pedretti 2007-01-02 05:52:15 EST
I have done the following test:

gnash 0.7.2 builded from source, compiled with no options (using opengl/gtk/no
sound): works fine.

current CVS, compiled with agg-2.5 compiled from source(using agg/gtk/sdl
sound/no mp3): works fine.

Seems the problem is only with the fedora package.
Comment 10 Patrice Dumas 2007-01-03 08:51:24 EST
That's very weird. Could you please try to ./configure with 
--disable-rpath --enable-sound=GST and look if it still crashes?
Comment 11 Fabio Pedretti 2007-01-04 05:02:18 EST
I did a:

cd gnash-0.7.2
./configure --disable-rpath --enable-sound=GST && make
cd ../flash-test
../gnash-0.7.2/gui/gnash simpleguess.swf

and works well.
Comment 12 Patrice Dumas 2007-01-06 12:08:33 EST
I don't see any other possibility that something going wrong with
the CFLAGS. Also make sure that you don't link against installed 
libraries. The rpm optflags are

-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables

the next step would be to sort out which one is causing the issue...
Comment 13 Fabio Pedretti 2007-01-16 07:43:18 EST
I have tried a:

OPTFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables"
cd gnash-0.7.2 && make clean && ./configure CFLAGS="$OPTFLAGS"
CXXFLAGS="$OPTFLAGS" FFLAGS="$OPTFLAGS" && make

and the compiled gnash works fine...
Comment 14 Michael De La Rue 2007-01-19 16:09:19 EST
Created attachment 146034 [details]
gnash /tmp/simpleguess.swf ; glxinfo ; xdpyinfo

I have pretty much the same thing.  Gnash always gives me a grey screen of
death (fortunately limited to it's own window rather than the whole OS :-)

Attached output of
 gnash /tmp/simpleguess.swf
 glxinfo
 xdpyinfo
Comment 15 Michael De La Rue 2007-01-20 13:37:29 EST
I had gnash-0.7.2-1.fc6 installed automatically.  Simply downloading
gnash-0.7.2-1.fc6.src.rpm (MD5 SUM 54dfed465fe87b9117db5a86af9a4226) and
recompiling with rpmbuild -ba (as a freshly created plain normal user) and
installing the resulting rpm makes my problem goes away.  Reinstalling the
default rpm (actually upgrading back to it with "yum update") makes it come back
again.  

Maybe during the build process an object file not compatible with my processor
managed to sneak in???
Comment 16 Michael De La Rue 2007-01-20 13:56:36 EST
Created attachment 146061 [details]
rpm -qi gnash; cat /proc/cpuinfo; rpm -qi gcc
Comment 17 Patrice Dumas 2007-01-29 04:40:29 EST
(In reply to comment #15)
> I had gnash-0.7.2-1.fc6 installed automatically.  Simply downloading
> gnash-0.7.2-1.fc6.src.rpm (MD5 SUM 54dfed465fe87b9117db5a86af9a4226) and
> recompiling with rpmbuild -ba (as a freshly created plain normal user) and
> installing the resulting rpm makes my problem goes away.  Reinstalling the
> default rpm (actually upgrading back to it with "yum update") makes it come back
> again.  
> 
> Maybe during the build process an object file not compatible with my processor
> managed to sneak in???

That's very very strange. Could you please try a mock build?
Comment 18 Michael De La Rue 2007-02-27 01:25:33 EST
(after a little time to think about how to do that)
Gnash built with 
 mock gnash-0.7.2-1.fc6.src.rpm 
works fine (well; actually it has many limitations, but it does what it's
expected to do ....).  Gnash installed with yum continues crash in the same
places.  
Comment 19 Patrice Dumas 2007-03-09 11:42:53 EST
Could you please attach the mock build log to the bug such that
I can compare with the one from the buildsystem.
Comment 20 Michael De La Rue 2007-03-09 19:39:07 EST
Created attachment 149758 [details]
/var/lib/mock/fedora-6-i386-core/result/build.log

build log as requested
Comment 21 Michael De La Rue 2007-03-09 19:41:44 EST
Created attachment 149759 [details]
/var/lib/mock/fedora-6-i386-core/result/root.log

root log in case of different packages
Comment 22 Patrice Dumas 2007-03-10 18:07:08 EST
I have rebuild the package. Could you please verify that
the problem is still there before I compare the build logs?
(there should be some time before the build is signed and
pushed to the mirrors).
Comment 23 Michael De La Rue 2007-03-12 17:55:28 EDT
gnash-0.7.2-1.fc6.1 (built 10th of march) continues to show the same problem.  
More or less instant failure when I move the mouse over or if just left for some
time; e.g. 

gnash /usr/share/gallery2/modules/core/test/data/flash.swf

gives

libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
zsh: illegal hardware instruction  gnash
/usr/share/gallery2/modules/core/test/data/flash.swf

and dies.
Comment 24 Patrice Dumas 2007-03-18 08:26:53 EDT
(In reply to comment #21)
> Created an attachment (id=149759) [edit]
> /var/lib/mock/fedora-6-i386-core/result/root.log
> 
> root log in case of different packages

Could you please also attach build.log?
Comment 25 Fabio Pedretti 2007-06-13 08:42:30 EDT
I am the original reporter of this bug: I have just yum-upgraded my machine to
F7 and gnash works fine.
Comment 26 Patrice Dumas 2007-09-14 01:16:30 EDT
There is certainly something along a compiler bug or the like
going on. Not easy to reproduce, closing.

Note You need to log in before you can comment on or make changes to this bug.