Bug 217063 - Fails to access http://www.itu.int - possible TCP issue
Fails to access http://www.itu.int - possible TCP issue
Status: CLOSED DUPLICATE of bug 207373
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 10:45 EST by Pierre Thibaudeau
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 16:51:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tcpdump while doing "telnet www.itu.int 80" from a FC6 host (1.04 KB, application/octet-stream)
2006-11-23 14:55 EST, Pierre Thibaudeau
no flags Details
tcpdump while doing "telnet www.itu.int 80" from a WindowsXP host (4.60 KB, application/octet-stream)
2006-11-23 14:57 EST, Pierre Thibaudeau
no flags Details

  None (edit)
Description Pierre Thibaudeau 2006-11-23 10:45:18 EST
Description of problem:

Access to http://www.itu.int is impossible.

Not only from a browser (firefox), but also from more basic methods

   wget http://www.itu.int

   telnet www.itu.int 80
   GET /home/index.html

Either way, the transfer starts, but rapidly comes to a crawl.

One could say the problem should be reported to the site admin, but because
there is no problem accessing this site from a WindowsXP machine they probably
wont be very responsive :)

Note that it works with the "telnet" method on WindowsXP so there is nothing
specific to the browser itself.

Also note that the WindowsXP machine from which I can access this site
successfully is on the same network (hence going through the very same
router/firewall) as the linux machines from which I observe the failure.

Bottom line, it looks like a TCP issue specific to linux and this Web site. (I
have the same result with various flavours of linux - Ubuntu, Knoppix, FC4.)
Comment 1 Pierre Thibaudeau 2006-11-23 14:55:11 EST
Created attachment 142015 [details]
tcpdump while doing "telnet www.itu.int 80" from a FC6 host

Can be examined with "tcpdump -nnv -r <filename>

This attachement show the bug (look at the timestamps).
Comment 2 Pierre Thibaudeau 2006-11-23 14:57:40 EST
Created attachment 142018 [details]
tcpdump while doing "telnet www.itu.int 80" from a WindowsXP host

Can be view with "tcpdump -nnv -r <filename>.

This one show a transfer that works diligently.
Comment 3 Pierre Thibaudeau 2006-11-23 15:15:19 EST
I have noticed two differences between the two tcpdump's provided above.

1. the ack sent from FC6 are tagged "tox 0x10" while they are tagged "tox 0x0"
   from WindowsXP.

   I have forced a "tos 0x0" with the following
 iptables -A OUTPUT -t mangle -p tcp --dport 80 -j TOS --set-tos 0x0

   no change.

2. in those same ack packets, I see the "win" value much smaller from FC6 than
from XP
   
   I did not find a way to force that to a higher value.

3. I have taken a tcpdump while doing a http transfer from another site. It
shows the same behaviour as the one that fails from www.itu.int on FC6. i.e.
"tos 0x10" and small "win" value. But the transfer works just fine.
Comment 4 Dave Jones 2006-11-24 16:51:11 EST

*** This bug has been marked as a duplicate of 207373 ***

Note You need to log in before you can comment on or make changes to this bug.