Bug 207373 - (windowscaling) cannot download from itu.int
cannot download from itu.int
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
: 209630 216815 217063 219483 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-09-20 16:56 EDT by Nerijus Baliūnas
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-16 18:15:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nerijus Baliūnas 2006-09-20 16:56:45 EDT

If I use any kernel above 2.6.16 (2.6.17-1.2187_FC5smp for example), I cannot
download this file (with wget for example) -
http://www.itu.int/plenipotentiary/2006/structure/draft-tmp.doc .
Download is very slow and timeouts, and with a sniffer I see a lot of packets
with  TCP segment of a reassembled PDU. If I boot 2.6.16-1.2122_FC5smp kernel,
file is downloaded OK.
It happens only on some PCs, usually when they are connected to DSL.
Comment 1 Nerijus Baliūnas 2006-10-13 05:42:34 EDT
The same or similar problem is with projects.ivija.com - for example, links
https://projects.ivija.com/ timeouts. But it works if I boot 2.6.16-1.2133_FC5
Comment 2 Konrad Rzeszutek 2006-10-13 11:36:27 EDT
What does 'ifconfig <eth> device' tell you for the MTU on each kernel?
Comment 4 John W. Linville 2006-10-13 14:21:28 EDT
Please include the output of running "sysreport"...thanks!
Comment 5 Nerijus Baliūnas 2006-10-13 19:18:49 EDT
MTU:1500. I tried changing (lowering) it, didn't help.
Comment 6 Nerijus Baliūnas 2006-10-13 19:42:00 EDT
sysreport output file was quite large. But I don't think you need it - it
happens on about 5 different PCs in different locations - both 32 and 64 bit,
different network cards (e100 and 3c59x), both new FC5 installations and systems
upgraded from earlier Fedora versions. SELinux is disabled. What matters is
internet connection (equipment - routers etc) - it works on my home PC, which is
connected to 10 mbps LAN, and doesn't work on servers connected to ADSL or T1.
Comment 7 Konrad Rzeszutek 2006-10-16 10:51:20 EDT

There was a change in the 2.6.17 and later kernels to the TCP stack that
resulted in the problem that TCP packets wouldn't go through certain routers -
which is exactly what you are hitting.  I did see a fix, but I can't recall
where and when I saw it - searching my e-mail archives did not yield anything
either. John, who this bug is assigned to, would probably have a better idea.

Comment 8 Nerijus Baliūnas 2006-10-16 12:32:18 EDT
kernel-2.6.18-1.2200.fc5.i686 still has this problem.
Comment 9 John W. Linville 2006-10-16 14:36:29 EDT
Konrad, comment 7 doesn't "ring any bells" for me.  Comment 8 would seem to 
indicate that this is another issue.

Nerijus, please attach the information I requested in comment 4.  I'm sorry, 
but "works on my home PC...doesn't work on servers connected to ADSL or T1" 
and "lot of packets with  TCP segment of a reassembled PDU" just isn't enough 
Comment 10 Dave Jones 2006-10-16 14:36:31 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 11 Nerijus Baliūnas 2006-10-16 15:43:43 EDT
Why another issue? Konrad said "There was a change in the 2.6.17 and later
kernels...", so it doesn't mean it is fixed in 2.6.18. He "did see a fix, but I
can't recall where and when" - so I assume the fix was not applied to 2.6.18,
and as I already told, the problem still exists in 2.6.18-1.2200.fc5.

I can't attach sysreport output, as tar file was more than 500 MB, and I
canceled bzip2'ing after few minutes. I think bz2 file will be too big to attach

I know it isn't enough information, but I believe it's "There was a change in
the 2.6.17 and later kernels to the TCP stack that resulted in the problem that
TCP packets wouldn't go through certain routers - which is exactly what you are
hitting". So either you can reproduce it or send me a fix which I can try (I'll
try to find it in linux-kernel list archives).
Comment 12 Dave Jones 2006-10-16 16:54:14 EDT
John, I think Konrad was referring to the window scaling changes that happened
circa 2.6.17
Comment 13 John W. Linville 2006-10-16 17:10:33 EDT
Thanks for the tip, Dave...

Nerijus, you might try doing this (as root) before connecting to the sites in 

   echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

For a slightly less "ham-handed" approach, you could try this:

   echo 4096 87380 174760 > /proc/sys/net/ipv4/tcp_rmem

Please try those (at least the first one) and post the results here...thanks!

P.S.  Links of interest:

   http://lwn.net/Articles/92727/ (old, but decent background info)
Comment 14 Dave Jones 2006-10-16 17:22:44 EDT
*** Bug 209630 has been marked as a duplicate of this bug. ***
Comment 15 Nerijus Baliūnas 2006-10-16 17:41:27 EDT
John, both workarounds worked, thanks (I tried them on different servers).
Should I use one of them or will updated kernel be released?
Comment 16 Dave Jones 2006-10-16 18:05:29 EDT
It isn't a kernel bug. It's a sign of a broken router between you and the target
host that can't do window scaling correctly.
Comment 17 Nerijus Baliūnas 2006-10-16 18:17:43 EDT
It is probably worth to add info about this problem to FC6 release notes.
Comment 18 Konrad Rzeszutek 2006-10-17 11:20:00 EDT
Dave amd John,

Thanks for coming to rescue. 
Comment 19 Jarod Wilson 2006-11-22 10:05:21 EST
*** Bug 216815 has been marked as a duplicate of this bug. ***
Comment 20 Dave Jones 2006-11-24 16:51:46 EST
*** Bug 217063 has been marked as a duplicate of this bug. ***
Comment 21 Dave Jones 2006-12-18 22:42:15 EST
*** Bug 219483 has been marked as a duplicate of this bug. ***
Comment 22 Gerwin Krist 2006-12-19 02:06:37 EST
Oke this work-around does work oke. But saying it's the routers fault it's a
little bit to easy imho. Previous versions in the FC 5 kernels didn't have the
problems. Oh well the workaround works well enough :)

Note You need to log in before you can comment on or make changes to this bug.