Bug 217173 - fuse 2.60 fails fuse-sshfs, fuse-encfs etc
fuse 2.60 fails fuse-sshfs, fuse-encfs etc
Status: CLOSED DUPLICATE of bug 217075
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 12:00 EST by Leo
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-25 01:46:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leo 2006-11-24 12:00:56 EST
Description of problem:
With fuse 2.60, being in the 'fuse' group isn't adequate for non-root user to do
sshfs and encfs etc.

Reports has been set the fedora user list:
http://thread.gmane.org/gmane.linux.redhat.fedora.general/220123/focus=220123
http://thread.gmane.org/gmane.linux.redhat.fedora.general/220129/focus=220129

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 gene c 2006-11-24 14:11:57 EST
Confirmed here - but on fc6
/dev/fuse is rw by group fuse - fails with Operation not permitted.
lsmod shows module is loaded fine.

fuse-libs-2.6.0-1.fc6
fuse-encfs-1.3.1-3.fc6
fuse-sshfs-1.7.2.fc6
fuse-2.6.0-1.fc6
kernel-2.6.18-1.2849.fc6
Comment 2 jonathan baron 2006-11-24 14:48:41 EST
I think this bug is fixed by
chmod 4755 /usr/bin/fusermount

I'm not sure it is the same bug though.  For me, the problem was that sshfs gave
me this error message and would not work.  That problem is fixed by this change.
Comment 3 Peter Lemenkov 2006-11-25 01:46:28 EST

*** This bug has been marked as a duplicate of 217075 ***

Note You need to log in before you can comment on or make changes to this bug.