This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 217186 - /bin/sh: @MKINSTALLDIRS@: No such file or directory
/bin/sh: @MKINSTALLDIRS@: No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 219925 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 15:10 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-16 18:30:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-11-24 15:10:44 EST
Description of problem:
Did you ever try to build util-linux using the packages autoconf-2.61-2 and/or 
automake-1.10-2? I guess not, because it will die this way:

[...]
test -z "/usr/sbin" || /bin/mkdir -p "/var/tmp/util-linux-root/usr/sbin"
  /usr/bin/install -c 'addpart' '/var/tmp/util-linux-root/usr/sbin/addpart'
  /usr/bin/install -c 'delpart' '/var/tmp/util-linux-root/usr/sbin/delpart'
  /usr/bin/install -c 'partx' '/var/tmp/util-linux-root/usr/sbin/partx'
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/usr/src/rpm/BUILD/util-linux-2.13-pre6/partx'
make[1]: Leaving directory `/usr/src/rpm/BUILD/util-linux-2.13-pre6/partx'
Making install in po
make[1]: Entering directory `/usr/src/rpm/BUILD/util-linux-2.13-pre6/po'
/bin/sh @MKINSTALLDIRS@ /var/tmp/util-linux-root/usr/share
/bin/sh: @MKINSTALLDIRS@: No such file or directory
make[1]: *** [install-data-yes] Error 127
make[1]: Leaving directory `/usr/src/rpm/BUILD/util-linux-2.13-pre6/po'
make: *** [install-recursive] Error 1


Version-Release number of selected component (if applicable):
autoconf-2.61-2
automake-1.10-2
util-linux-2.13-0.45.1

How reproducible:
Everytime, see above.

Actual results:
Rebuilding ends with an error message.

Expected results:
No error and working rebuild ;-)
Comment 1 Robert Scheck 2006-12-16 16:36:47 EST
Nope, anything is broken anyway when rebuilding util-linux-2.13-0.47:

-rw-r--r--    1 root    root           204297 Dez 16 22:33 /share/locale/ca/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           154228 Dez 16 22:33 /share/locale/cs/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           190129 Dez 16 22:33 /share/locale/da/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           205035 Dez 16 22:33 /share/locale/de/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           200239 Dez 16 22:33 /share/locale/es/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           110942 Dez 16 22:33 /share/locale/et/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           196419 Dez 16 22:33 /share/locale/fi/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           202782 Dez 16 22:33 /share/locale/fr/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           199175 Dez 16 22:33 /share/locale/id/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           185157 Dez 16 22:33 /share/locale/it/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           164131 Dez 16 22:33 /share/locale/ja/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           194435 Dez 16 22:33 /share/locale/nl/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           153997 Dez 16 22:33 /share/locale/pt_BR/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           197326 Dez 16 22:33 /share/locale/ru/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           188985 Dez 16 22:33 /share/locale/sl/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           190173 Dez 16 22:33 /share/locale/sv/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           200491 Dez 16 22:33 /share/locale/tr/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           253721 Dez 16 22:33 /share/locale/uk/
LC_MESSAGES/util-linux.mo
-rw-r--r--    1 root    root           209401 Dez 16 22:33 /share/locale/vi/
LC_MESSAGES/util-linux.mo

Could you please try to fix this problem really? :)
Comment 2 Karel Zak 2006-12-16 18:21:27 EST
*** Bug 219925 has been marked as a duplicate of this bug. ***
Comment 3 Karel Zak 2006-12-16 18:30:19 EST
I think shorter paths are better paths :-)

Well, fixed in util-linux-2.13-0.48.fc7. Thanks for your feedback.

Note You need to log in before you can comment on or make changes to this bug.