Bug 217188 - OpenOffice.org dictionaries should be symlinked into thunderbird
Summary: OpenOffice.org dictionaries should be symlinked into thunderbird
Status: CLOSED DUPLICATE of bug 202403
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-24 20:39 UTC by David Monniaux
Modified: 2018-04-11 13:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 10:53:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Monniaux 2006-11-24 20:39:31 UTC
Description of problem:
Dictionaries installed in OpenOffice.org should also be useable from Thunderbird.

Version-Release number of selected component (if applicable):
1.5.0.8

How reproducible:
always

Steps to Reproduce:
1. Install OpenOffice.org + dictionaries of languages other than English, and
Thunderbird
2. Try spell checking under Thunderbird
3.
  
Actual results:
no other language than English shows up in the Thunderbird language dialog box

Expected results:
it should offer the OpenOffice.org dictionaries

Additional info:
Thunderbird can use two kinds of dictionaries:
* xpi format, from mozilla.org, but these cannot be installed on Fedora's
Thunderbird (see bug 217187)
* OpenOffice.org's dictionaries (.aff and .dic files).

Simply symlinking .aff and .dic files for the spelling dictionaries of
OpenOffice.org into the Thunderbird dictionary tree works wonders.

Simple demonstration script:
cd /usr/lib64/thunderbird-1.5.0.8/components/myspell
cat ooo-import-dict.sh

#!/bin/sh
ooopath=/usr/lib64/openoffice.org2.0/share/dict/ooo
for file in $ooopath/??_??.dic $ooopath/??_??.aff ;
do
  file2=`echo $file|sed -e s/_/-/ -e s+$ooopath/++`
  ln -s $file $file2
done

The language packs for OpenOffice.org should add these symlinks for free.

Comment 1 Matěj Cepl 2007-07-23 10:53:43 UTC

*** This bug has been marked as a duplicate of 202403 ***


Note You need to log in before you can comment on or make changes to this bug.