Bug 217193 - ftview could not allocate display surface
ftview could not allocate display surface
Status: CLOSED DUPLICATE of bug 216222
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: freetype (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Brock Organ
:
Depends On: 212199
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 18:23 EST by Behdad Esfahbod
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-25 10:00:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2006-11-24 18:23:33 EST
+++ This bug was initially created as a clone of Bug #212199 +++

Description of problem:
I can't  seem to get ftview to work 

[apodtele@prosha dejavu-lgc]$ ftview 12 DejaVuLGCSans-Bold.ttf
could not allocate display surface
  error = 0x0000


Version-Release number of selected component (if applicable):
freetype-demos-2.2.1-10

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

-- Additional comment from apodtele@ucsd.edu on 2006-11-17 10:44 EST --
Could this be a solution?
http://lists.nongnu.org/archive/html/freetype/2006-11/msg00025.html

ftview seem to look for X under /usr/X11R6. So old-fashioned!

-- Additional comment from mclasen@redhat.com on 2006-11-17 16:25 EST --
Sounds likely. Thanks for the pointer

-- Additional comment from besfahbo@redhat.com on 2006-11-21 16:15 EST --
Thanks for the pointer.  Seems like it.  Last time I looked into it, I was
surprised to find that ftview is not linked to xlib at all.  This explains it.

-- Additional comment from apodtele@ucsd.edu on 2006-11-21 18:43 EST --
I look forward to seeing an update. ;) 


-- Additional comment from besfahbo@redhat.com on 2006-11-24 18:20 EST --
Fixed in freetype-2.2.1-14.fc6 submitted for Update Testing.
Comment 1 Matthias Clasen 2006-11-25 10:00:33 EST
Behdad, correct me if I am wrong, but I believe this is just a duplicate of the
earlier clone bug 216222 ?

*** This bug has been marked as a duplicate of 216222 ***
Comment 2 Behdad Esfahbod 2006-11-27 01:40:40 EST
You are right.  My bad.

Note You need to log in before you can comment on or make changes to this bug.