Bug 217235 - touchpad won't work after suspend to ram (s3)
touchpad won't work after suspend to ram (s3)
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Cunningham
: 187098 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-11-25 09:32 EST by Aleksander Zdyb
Modified: 2008-05-06 12:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:57:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg log (122.43 KB, text/plain)
2008-03-27 18:02 EDT, Mat Booth
no flags Details

  None (edit)
Description Aleksander Zdyb 2006-11-25 09:32:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv: Gecko/20061107 Fedora/ Firefox/

Description of problem:
After my laptop hp nx6310 is woken up from suspend to ram the touchpad won't work.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. put laptop to sleep (echo mem >/sys/power/state or by menu in gnome-power-properites applet)
2. wake it up

Actual Results:
touchpad does not work. can't move cursor nor click. keyboard works. after reboot everything is ok.

Expected Results:
touchpad should work.

Additional info:
i though it may be relevant to so called "bad state" in hp notebooks so i recompiled standard i686 kernel (2.6.18-1.2849, from src.rpm) with psmouse switched to build as module (that was the only change). then, after laptop was woken up, i tried to reload psmouse (modprobe -r psmouse; modprobe psmouse) and touchpad started to work but all special features such as tap for click, double tap for drag, vertical scroll, etc, were gone. so i was only able to move cursor with touchpad and use buttons, but it's not so comfortable as using taps, scrolls, etc.
Comment 1 Nigel Cunningham 2007-07-02 22:12:18 EDT
Could you please try adding i8042.reset=1 to the kernel command line?

Reassigning to me as it looks more like a kernel driver issue.
Comment 2 Matěj Cepl 2007-11-14 04:28:04 EST
*** Bug 187098 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Cepl 2007-11-14 04:29:52 EST
Somebody suggested in bug 187098 that this might have upstream in
http://bugzilla.kernel.org/show_bug.cgi?id=7977. I am not that much involved in
kernel stuff, but he is IMHO right.

Comment 4 Mat Booth 2008-03-27 18:01:49 EDT
I'm suffering with almost this same issue in the F9 Beta/Rawhide on my Asus F3SR
with Synaptics touchpad. Though I didn't notice it until I changed some
synaptics driver options away from the defaults.

What happens for me is that when I resume from S3 suspend, all the synaptics
options I've changed in xorg.conf seem to be ignored.

Output from "synclient -l" indicates that my settings were read correctly from
xorg.conf, but behaviour has reverted back to the default. Setting options with
synclient no longer works after resuming. Restarting X with a Ctrl-Alt-Bkspc
fixes the problem.

My xorg.conf contains:

Section "ServerLayout"
        ... etc ...
        InputDevice    "TouchPad" "CorePointer"

Section "InputDevice"
        Driver "synaptics"
        Identifier "TouchPad"
        Option "Protocol" "auto-dev"
        Option "TapButton1" "1"
        Option "RTCornerButton" "2" 
        Option "RBCornerButton" "3" 
        Option "SHMConfig" "on"

See attached Xorg.log

I tried adding "i8042.reset=1" to the kernel command line as suggested in
comment 1. The problem still persists, only now I get a "An internal system
error has occurred" popup when I resume from the suspended state. :-)
Comment 5 Mat Booth 2008-03-27 18:02:21 EDT
Created attachment 299396 [details]
Xorg log
Comment 6 Bug Zapper 2008-04-04 00:56:02 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2008-05-06 12:57:03 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.