This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 217292 - /boot is empty after install
/boot is empty after install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
: 217416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-26 12:11 EST by Bruno Wolff III
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 14:40:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log from text install (132.50 KB, text/plain)
2006-11-29 10:50 EST, Bruno Wolff III
no flags Details
anaconda.log from graphical install (133.33 KB, text/plain)
2006-11-29 10:55 EST, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2006-11-26 12:11:35 EST
Description of problem:
I made a respin using anaconda and libdhcp from rawhide and otherwise took the
latest updates from fc6. When I do installs /boot gets reformatted but no grub
or kernels get put there. I am able to make respins successfully using the fc6
version of ananconda. So I am not sure if this is user error, a problem with
ananconda or that the versions of some packages required for the fc7 anaconda
haven't been updated and I used ones from fc6 that were too old.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.1-1 (I built new rpms from the source rpm under fc6 after
installing the fc7 libdchp* stuff to meet a requirement for rebuilding anaconda.

How reproducible:
While installing from the respun dvd it happens every time whether doing a text
or graphical install that I have tried. I have been unchecking the office (?)
package selection, but otherwise not doing any customization of packages to be
installed.

Steps to Reproduce:
This might be hard for you to do, though you could try doing an install with
rawhide and see if you get the same results. I can't test that yet, because I
don't have more than a couple of the rawhide rpms downloaded.
  
Actual results:
/boot just contained lost+fond

Expected results:
It should have had a grub directory and some parts of the kernel needed to boot.


Additional info:
I saw some errors in the install log that might or might not be related.
Right at the start was:
error: failed to stat /mnt/sysimage/sys: No such file or directory
I had a lot of errors reporting that /proc didn't get mnounted.

I used two raid partitions for the install, one for /, the other for /boot.
There were other raid partitions on the disks that weren't used in the install.
Comment 1 Jeremy Katz 2006-11-28 13:35:35 EST
Can you attach /var/log/anaconda.log?
Comment 2 Bruno Wolff III 2006-11-29 10:50:43 EST
Created attachment 142385 [details]
anaconda.log from text install

This is from a text based install I was doing to test for the software raid
issue.
Comment 3 Bruno Wolff III 2006-11-29 10:55:03 EST
Created attachment 142386 [details]
anaconda.log from graphical install

Now that I check the timestamps, I am not absolutly sure the previous log was
from a text based install. This one is from a graphical install for sure, since

I made a big oops and wrote over the wrong /dev/md5 array and I clearly
remember
doing that in a graphical install.
Comment 4 Chris Lumens 2006-12-01 13:53:06 EST
/boot is getting mounted onto /mnt/sysimage/boot first, and then / is getting
mounted onto /mnt/sysimage later.  So all the grub stuff is being written to
/boot on the root device, not on the boot device.  That leaves the boot device
empty when you reboot.
Comment 5 Chris Lumens 2006-12-01 14:40:07 EST
This will be fixed in the next build of anaconda.
Comment 6 Bruno Wolff III 2006-12-01 15:07:37 EST
Thanks. I'll keep an eye out for the update, retest it when it shows up and
report back.
Comment 7 Prarit Bhargava 2006-12-05 12:06:45 EST
*** Bug 217416 has been marked as a duplicate of this bug. ***
Comment 8 Bruno Wolff III 2006-12-05 16:31:39 EST
The update still hasn't shown up yet (rawhide's anaconda is still from Nov 30).
Is there someplace I can grab the source, so that I get feedback on the fix back
to you a bit sooner? I tried using anonymous CVS as documented on
http://fedora.redhat.com/About/Projects/anaconda-installer/ but the login
command failed.
Comment 9 Bruno Wolff III 2006-12-07 00:58:20 EST
Nevermind about my last comment. CVS works, I was just stupidly copying and
pasting the 3 commands at once, so that the 3rd command was being sent as the
password and causing the login to fail.
Comment 10 Doug Chapman 2006-12-15 09:13:02 EST
Is there a reason the anaconda in the full rawhide tree has not been built since
Nov 30?  It would be nice to be able to install again but installing nightly
builds is still blocked due to this.

Note You need to log in before you can comment on or make changes to this bug.