Bug 217416 - /proc and /sys are not mounted during the system install
/proc and /sys are not mounted during the system install
Status: CLOSED DUPLICATE of bug 217292
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-11-27 15:29 EST by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 12:06:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log from rawhide-20061129 install (108.63 KB, text/plain)
2006-11-29 12:46 EST, Doug Chapman
no flags Details
anaconda.syslog from rawhide-20061129 install (16.57 KB, text/plain)
2006-11-29 12:47 EST, Doug Chapman
no flags Details
install.log from rawhide-20061129 install (23.12 KB, text/plain)
2006-11-29 12:48 EST, Doug Chapman
no flags Details
install.log.syslog from rawhide-20061129 install (10.47 KB, text/plain)
2006-11-29 12:48 EST, Doug Chapman
no flags Details

  None (edit)
Description Prarit Bhargava 2006-11-27 15:29:25 EST
Description of problem:

/proc and /sys are not mounted during the system install.

Version-Release number of selected component (if applicable): rawhide-20061127


How reproducible: 100%


Steps to Reproduce:
1. Attempt to install rawhide-20061127 on hp rx2600
  
Actual results:

Install is very screwed up, and install log shows

GC Warning: GC_get_nprocs() returned -1
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
/usr/bin/rebuild-gcj-db: line 5:  3665 Segmentation fault      /usr/bin/gcj-dbt4
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
xargs: /usr/bin/gcj-dbtool: terminated by signal 11
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
Installing ccid - 1.1.0-2.ia64
Installing xorg-x11-drv-evdev - 1.1.2-2.1.ia64
Installing rpm-libs - 4.4.2-36.fc7.ia64
Installing rpm-python - 4.4.2-36.fc7.ia64
Installing yum - 3.0.1-2.fc7.noarch
Installing system-config-network-tui - 1.3.96-1.fc6.noarch
Installing firstboot-tui - 1.4.25-1.fc7.noarch
Installing system-config-network - 1.3.96-1.fc6.noarch
Installing system-config-users - 1.2.48-1.fc7.noarch
Installing coolkey - 1.0.1-13.fc7.ia64
Installing antlr - 2.7.6-4jpp.2.ia64
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
/usr/bin/rebuild-gcj-db: line 5:  3768 Segmentation fault      /usr/bin/gcj-dbt4
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
xargs: /usr/bin/gcj-dbtool: terminated by signal 11
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
Installing gjdoc - 0.7.7-14.fc7.ia64
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
/usr/bin/rebuild-gcj-db: line 5:  3779 Segmentation fault      /usr/bin/gcj-dbt4
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
xargs: /usr/bin/gcj-dbtool: terminated by signal 11
GC Warning: Couldn't read /proc/stat
GC Warning: GC_get_nprocs() returned -1
Installing gnome-bluetooth - 0.8.0-1.fc7.ia64
/proc is empty (not mounted ?)

Expected results: Install should suceed.


Additional info: Seen only on rx2600 series
Comment 1 Prarit Bhargava 2006-11-28 10:12:26 EST
I've verified that this works on the Altix boxes.  It seems like it is something
restricted to the rx2600 series.

P.
Comment 2 Doug Chapman 2006-11-28 11:03:51 EST
Prarit,

I think this might be some sort of a timing issue.  I have been experiementing
and have had successful and unsuccessful installs on the same box.  I am doing
some installs with remote syslog debugging set up to gather more data.
Comment 3 Jeremy Katz 2006-11-28 13:43:38 EST
/proc definitely should be being mounted...  this might just be a kernel issue.
Comment 4 Prarit Bhargava 2006-11-28 13:45:48 EST
(In reply to comment #3)
> /proc definitely should be being mounted...  this might just be a kernel issue.

It doesn't seem like it :/.  I don't see any strangeness when I boot the kernel
rpm on top of a stable FC ...

I'm still investigating though....

P.
Comment 5 Prarit Bhargava 2006-11-28 15:24:50 EST
It seems that at some point during the rpm installs, /tmp/proc and /tmp/sys get
mounted to /mnt/sysimage/proc and /mnt/sysimage/sys.

Comment 6 Prarit Bhargava 2006-11-28 18:56:15 EST
Yeah -- it definately looks like during the RPM installs one of the RPMs is
setting the /proc and /sys mount points to /tmp/proc and /tmp/sys .

I'm still investigating...

P.
Comment 7 Doug Chapman 2006-11-29 12:43:41 EST
One important item Prarit didn't mention is the end result of all this is the
/boot/efi partition does not get set up correctly so that the system is not
bootable.

I sometimes hit this and other times it installs OK.  I have not yet determined
what conditions cause it to fail (may be a timing issue?).  Prarit says he hits
it all the time.

I just hit this again on todays rawhide build: rawhide-20061129
I will attach all the log files.  I don't see any smoking gun there but perhaps
someone else will find something of note.

Comment 8 Doug Chapman 2006-11-29 12:46:39 EST
Created attachment 142392 [details]
anaconda.log from rawhide-20061129 install
Comment 9 Doug Chapman 2006-11-29 12:47:13 EST
Created attachment 142393 [details]
anaconda.syslog from rawhide-20061129 install
Comment 10 Doug Chapman 2006-11-29 12:48:20 EST
Created attachment 142394 [details]
install.log from rawhide-20061129 install
Comment 11 Doug Chapman 2006-11-29 12:48:52 EST
Created attachment 142395 [details]
install.log.syslog from rawhide-20061129 install
Comment 12 Prarit Bhargava 2006-12-05 12:06:41 EST

*** This bug has been marked as a duplicate of 217292 ***

Note You need to log in before you can comment on or make changes to this bug.