Bug 217442 - oowriter crash on text entry...
oowriter crash on text entry...
Status: CLOSED DUPLICATE of bug 217234
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 17:17 EST by Frank de Lange
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 03:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank de Lange 2006-11-27 17:17:13 EST
Description of problem:
oowriter crashes when a key is pressed in the content frame or content is added
in any other way (eg. pasted from the clipboard). Accessing the menu (from main
menu bar or context menu) does NOT crash the program.

The OO.org crash handler is NOT activated, the program just fails. There is no
output on the command line.

Running soffice.bin through gdb gives this:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1218606240 (LWP 3174)]
0x009ccae2 in cppu::ImplHelper_getImplementationId ()
   from /usr/lib/openoffice.org2.1/program/libuno_cppuhelpergcc3.so.3

Debuginfo package is not installed (does not fit on the drive, 438 M is a bit
muchhh.) so no symbols or anything. Sorry...

Version-Release number of selected component (if applicable):
openoffice.org-2.1.0-5.1.src.rpm


How reproducible:
Enter text in oowriter content frame. 


Steps to Reproduce:
1. start oowriter
2. press any key...
3. *boom*
  
Actual results:
*boom*

Expected results:
no boom. I'd say it would be nice if the character represented by the key just
depressed was entered in the content frame...

Additional info:
Fedora core development updated 20061127@21:30UTC
Comment 1 Caolan McNamara 2006-11-28 03:52:59 EST

*** This bug has been marked as a duplicate of 217234 ***

Note You need to log in before you can comment on or make changes to this bug.