Bug 217485 - /dev/dm-[0-9] device names not created for device-manager ICH5R partitions.
Summary: /dev/dm-[0-9] device names not created for device-manager ICH5R partitions.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords:
: 217486 217487 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-28 06:11 UTC by Dave Frailey
Modified: 2007-11-30 22:11 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 16:53:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Frailey 2006-11-28 06:11:21 UTC
Description of problem:

  /dev/dm-[0-9] device names not created for device-manager ICH5R partitions.

Version-Release number of selected component (if applicable):

  device-mapper-1.02.07-3

How reproducible:

  always

Steps to Reproduce:

  [root@fc6 ~]# df
 
Actual results:

  Filesystem           1K-blocks      Used Available Use% Mounted on
  /dev/mapper/isw_gccbdjgid_ICH5Rp5
                         3968092   1915032   1848236  51% /
  /dev/mapper/isw_gccbdjgid_ICH5Rp1
                          194442     14593    169810   8% /boot
  tmpfs                   517064         0    517064   0% /dev/shm
  /dev/mapper/isw_gccbdjgid_ICH5Rp2
                          988116     84392    852720  10% /var
  /dev/mapper/isw_gccbdjgid_ICH5Rp6
                        73662128       544  73661584   1% /vol1

Expected results:

  Filesystem           1K-blocks      Used Available Use% Mounted on
  /dev/dm-5              3968092   1915032   1848236  51% /
  /dev/dm-1               194442     14593    169810   8% /boot
  tmpfs                   517064         0    517064   0% /dev/shm
  /dev/dm-2               988116     84392    852720  10% /var
  /dev/dm-6             73662128       544  73661584   1% /vol1

Additional info:

Comment 1 Dave Frailey 2006-11-28 06:28:52 UTC
*** Bug 217487 has been marked as a duplicate of this bug. ***

Comment 2 Dave Frailey 2006-11-28 06:30:35 UTC
*** Bug 217486 has been marked as a duplicate of this bug. ***

Comment 7 Alasdair Kergon 2007-01-10 16:53:26 UTC
kpartx

If you want /dev/dm-* device names then you're free to add udev rules to
create/destroy them, but in general this is a bad idea as they are free to
change after each reboot whereas the /dev/mapper/* names should be more persistent.


Note You need to log in before you can comment on or make changes to this bug.