Bug 217563 - Can't install using VNC on zSeries
Can't install using VNC on zSeries
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On: 278261
Blocks: 234654 227613 303961
  Show dependency treegraph
 
Reported: 2006-11-28 12:05 EST by Bastien Nocera
Modified: 2010-10-22 03:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0644
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:18:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (RHEL5.1-Server-20070904.nightly) (10.64 KB, text/plain)
2007-09-04 16:12 EDT, James Laska
no flags Details

  None (edit)
Description Bastien Nocera 2006-11-28 12:05:26 EST
Using RHEL5 beta 20061107 (M9), try a VNC installation

It looks like the images are busted.

The logs show:

vncserver log:
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 893, in ?
    runVNC(vncpassword, vncconnecthost, vncconnectport, doStartupX11Actions)
  File "/usr/bin/anaconda", line 405, in runVNC
    vncStartedCB=vncStartedCB)
  File "/usr/lib/anaconda/vnc.py", line 269, in startVNCServer
    os.execv(args[0], args)
OSError: [Errno 2] No such file or directory

anaconda.log:
15:42:08 INFO    : 253752 kB are available
15:42:08 INFO    : modules to insert cramfs fat vfat sunrpc lockd fscache
nfs_acl nfs loop isofs floppy edd pcspkr squashfs
15:42:08 INFO    : loaded cramfs from /modules/modules.cgz
15:42:08 INFO    : loaded fat from /modules/modules.cgz
15:42:08 INFO    : loaded vfat from /modules/modules.cgz
15:42:08 INFO    : loaded sunrpc from /modules/modules.cgz
15:42:08 INFO    : loaded lockd from /modules/modules.cgz
15:42:08 INFO    : loaded fscache from /modules/modules.cgz
15:42:08 INFO    : loaded nfs_acl from /modules/modules.cgz
15:42:08 INFO    : loaded nfs from /modules/modules.cgz
15:42:08 INFO    : loaded loop from /modules/modules.cgz
15:42:08 INFO    : loaded squashfs from /modules/modules.cgz
15:42:08 DEBUG   : module(s) isofs floppy edd pcspkr not found
15:42:08 INFO    : inserted /tmp/cramfs.ko
15:42:08 INFO    : inserted /tmp/fat.ko
15:42:08 INFO    : inserted /tmp/vfat.ko
15:42:08 INFO    : inserted /tmp/sunrpc.ko
15:42:08 INFO    : inserted /tmp/lockd.ko
15:42:08 INFO    : inserted /tmp/fscache.ko
15:42:08 INFO    : inserted /tmp/nfs_acl.ko
15:42:08 INFO    : inserted /tmp/nfs.ko
15:42:08 INFO    : inserted /tmp/loop.ko
15:42:08 INFO    : inserted /tmp/squashfs.ko
15:42:08 INFO    : load module set done
15:42:08 INFO    : modules to insert
15:42:08 INFO    : load module set done
15:42:08 INFO    : modules to insert cdrom ide-cd
15:42:09 INFO    : loaded cdrom from /modules/modules.cgz
15:42:09 DEBUG   : module(s) ide-cd not found
15:42:09 INFO    : inserted /tmp/cdrom.ko
15:42:09 INFO    : load module set done
15:42:09 INFO    : modules to insert scsi_mod sd_mod sr_mod
15:42:09 INFO    : loaded scsi_mod from /modules/modules.cgz
15:42:09 INFO    : loaded sd_mod from /modules/modules.cgz
15:42:09 INFO    : loaded sr_mod from /modules/modules.cgz
15:42:09 INFO    : inserted /tmp/scsi_mod.ko
15:42:09 INFO    : inserted /tmp/sd_mod.ko
15:42:09 INFO    : inserted /tmp/sr_mod.ko
15:42:09 INFO    : load module set done
15:42:09 INFO    : modules to insert scsi_transport_fc zfcp
15:42:10 INFO    : loaded scsi_transport_fc from /modules/modules.cgz
15:42:10 INFO    : loaded zfcp from /modules/modules.cgz
15:42:10 INFO    : inserted /tmp/scsi_transport_fc.ko
15:42:10 INFO    : inserted /tmp/zfcp.ko
15:42:10 INFO    : load module set done
15:42:10 INFO    : modules to insert scsi_transport_iscsi libiscsi iscsi_tcp
15:42:10 INFO    : loaded scsi_transport_iscsi from /modules/modules.cgz
15:42:10 INFO    : loaded libiscsi from /modules/modules.cgz
15:42:10 INFO    : loaded iscsi_tcp from /modules/modules.cgz
15:42:10 INFO    : inserted /tmp/scsi_transport_iscsi.ko
15:42:10 INFO    : inserted /tmp/libiscsi.ko
15:42:10 INFO    : inserted /tmp/iscsi_tcp.ko
15:42:10 INFO    : load module set done
15:42:10 INFO    : modules to insert dasd_mod
15:42:11 INFO    : loaded dasd_mod from /modules/modules.cgz
15:42:11 INFO    : inserted /tmp/dasd_mod.ko
15:42:11 INFO    : load module set done
15:42:11 INFO    : modules to insert dasd_diag_mod dasd_fba_mod dasd_eckd_mod
15:42:11 INFO    : loaded dasd_diag_mod from /modules/modules.cgz
15:42:11 INFO    : loaded dasd_fba_mod from /modules/modules.cgz
15:42:11 INFO    : loaded dasd_eckd_mod from /modules/modules.cgz
15:42:11 INFO    : inserted /tmp/dasd_diag_mod.ko
15:42:11 INFO    : inserted /tmp/dasd_fba_mod.ko
15:42:11 INFO    : inserted /tmp/dasd_eckd_mod.ko
15:42:11 INFO    : load module set done
15:42:11 INFO    : looking for usb controllers
15:42:11 DEBUG   : no usb controller found
15:42:11 INFO    : no firewire controller found
15:42:11 DEBUG   : no pcic controller found
15:42:11 DEBUG   : probing buses
15:42:11 DEBUG   : finished bus probing
15:42:11 INFO    : found nothing
15:42:11 ERROR   : got to setupCdrom without a CD device
15:45:13 DEBUG   : going to set language to en_US.UTF-8
15:45:13 INFO    : setting language to en_US.UTF-8
15:45:15 INFO    : need to set up networking
15:45:15 INFO    : going to pick interface
15:45:15 INFO    : only have one network device: eth0
15:45:15 INFO    : going to do getNetConfig
15:45:15 INFO    : doing kickstart... setting it up
15:45:15 DEBUG   : waiting for link eth0...
15:45:15 DEBUG   :    0 seconds.
15:45:15 ERROR   : no DNS servers, can't look up hostname
15:45:15 INFO    : starting to STEP_URL
15:45:36 ERROR   : got to setupCdrom without a CD device
15:45:36 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/updates.img to a fd
15:45:36 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/product.img to a fd
15:45:36 INFO    : 253752 kB are available
15:45:36 INFO    : 253752 kB are available
15:45:36 WARNING : URLINSTALL falling back to non-GUI stage2 due to insufficient RAM
15:45:36 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/minstg2.img to a fd
15:45:53 ERROR   : got to setupCdrom without a CD device
15:45:53 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/updates.img to a fd
15:45:53 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/product.img to a fd
15:45:54 INFO    : 253752 kB are available
15:45:54 INFO    : 253752 kB are available
15:45:54 WARNING : URLINSTALL falling back to non-GUI stage2 due to insufficient RAM
15:45:54 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/minstg2.img to a fd
15:46:17 ERROR   : got to setupCdrom without a CD device
15:46:17 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/updates.img to a fd
15:46:17 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/disc1/images/updates.img to a fd
15:46:17 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/product.img to a fd
15:46:17 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/disc1/images/product.img to a fd
15:46:17 INFO    : 253752 kB are available
15:46:17 INFO    : 253752 kB are available
15:46:17 WARNING : URLINSTALL falling back to non-GUI stage2 due to insufficient RAM
15:46:17 INFO    : transferring
ftp://172.16.59.148//var/ftp/pub/tree-s390x/images/minstg2.img to a fd
15:46:20 DEBUG   : copied 39350272 bytes to /tmp/ramfs/minstg2.img (complete)
15:46:20 INFO    : mntloop loop0 on /mnt/runtime as /tmp/ramfs/minstg2.img fd is 14
15:46:20 INFO    : got url
ftp://archanakr:%75%6e%64%65%75%78%31%32@172.16.59.148//var/ftp/pub/tree-s390x
15:46:20 INFO    : Loading SELinux policy
15:46:20 INFO    : getting ready to spawn shell now
15:46:20 INFO    : modules to insert ide-cd
15:46:21 DEBUG   : module(s) ide-cd not found
15:46:21 INFO    : load module set done
15:46:21 INFO    : modules to insert
15:46:21 INFO    : load module set done
15:46:21 INFO    : modules to insert
15:46:21 INFO    : load module set done
15:46:21 INFO    : modules to insert
15:46:21 INFO    : load module set done
15:46:21 DEBUG   : probing buses
15:46:21 DEBUG   : finished bus probing
15:46:21 INFO    : found nothing
15:46:21 INFO    : modules to insert md raid0 raid1 raid5 raid6 xor raid456
msdos gfs2 lock_nolock reiserfs jfs xfs dm-mod dm15:46:21 INFO    : loaded raid0
from /modules/modules.cgz
15:46:21 INFO    : loaded raid1 from /modules/modules.cgz
15:46:21 INFO    : loaded xor from /modules/modules.cgz
15:46:21 INFO    : loaded raid456 from /modules/modules.cgz
15:46:21 INFO    : loaded msdos from /modules/modules.cgz
15:46:21 INFO    : loaded gfs2 from /modules/modules.cgz
15:46:21 INFO    : loaded lock_nolock from /modules/modules.cgz
15:46:21 INFO    : loaded dm-mod from /modules/modules.cgz
15:46:21 INFO    : loaded dm-zero from /modules/modules.cgz
15:46:21 INFO    : loaded dm-mirror from /modules/modules.cgz
15:46:21 INFO    : loaded dm-snapshot from /modules/modules.cgz
15:46:21 INFO    : loaded dm-multipath from /modules/modules.cgz
15:46:21 INFO    : loaded dm-round-robin from /modules/modules.cgz
15:46:21 INFO    : loaded dm-emc from /modules/modules.cgz
15:46:21 DEBUG   : module(s) md raid5 raid6 reiserfs jfs xfs not found
15:46:21 INFO    : inserted /tmp/raid0.ko
15:46:21 INFO    : inserted /tmp/raid1.ko
15:46:22 INFO    : inserted /tmp/xor.ko
15:46:22 INFO    : inserted /tmp/raid456.ko
15:46:22 INFO    : inserted /tmp/msdos.ko
15:46:22 INFO    : inserted /tmp/gfs2.ko
15:46:22 INFO    : inserted /tmp/lock_nolock.ko
15:46:22 INFO    : inserted /tmp/dm-mod.ko
15:46:22 INFO    : inserted /tmp/dm-zero.ko
15:46:22 INFO    : inserted /tmp/dm-mirror.ko
15:46:22 INFO    : inserted /tmp/dm-snapshot.ko
15:46:22 INFO    : inserted /tmp/dm-multipath.ko
15:46:22 INFO    : inserted /tmp/dm-round-robin.ko
15:46:22 INFO    : inserted /tmp/dm-emc.ko
15:46:22 INFO    : load module set done
15:46:22 INFO    : looking for USB mouse...
15:46:22 INFO    : Running anaconda script /usr/bin/anaconda
15:46:22 DEBUG   : adding extraArg --vnc
15:46:24 INFO    : using only installclass Red Hat Enterprise Linux
15:46:24 INFO    : Red Hat Enterprise Linux is only installclass, using it
15:46:24 INFO    : Display mode = g
15:46:24 INFO    : Method =
ftp://archanakr:%75%6e%64%65%75%78%31%32@172.16.59.148//var/ftp/pub/tree-s390x
15:46:24 WARNING : no floppy devices found but we'll try fd0 anyway
15:46:28 INFO    : Starting VNC...
15:46:28 INFO    : ip of eth0 is 192.168.5.56
15:46:28 WARNING :

WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.


15:46:28 INFO    : The VNC server is now running.
15:46:28 INFO    : Please connect to 192.168.5.56:1 to begin the install...
15:46:28 INFO    : Started mini-wm
15:46:28 INFO    : Starting graphical installation...
15:46:28 ERROR   : Exception starting GUI installer: No module named gtk
Comment 1 RHEL Product and Program Management 2006-11-28 12:30:22 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Jeremy Katz 2006-11-28 13:47:25 EST
Does this happen with the final beta2?
Comment 4 Jeremy Katz 2006-11-28 14:26:32 EST
Oh, wait -- this is an ftp install with ~ 256 megs of RAM.  So you're getting
bumped to minstg2.img, which doesn't have vnc.  We shouldn't be trying to do vnc
if only text mode is available (which is the case here)
Comment 5 David Cantrell 2007-01-09 11:04:34 EST
This is still present in RHEL-5 nightly trees.  If we don't have X stuff
available on the stage2 image, we shouldn't give the user the option of running VNC.

Setting the RHEL-5.1 flag to ?
Comment 9 James Laska 2007-08-28 15:07:54 EDT
Tested HTTP VNC installs on a s390x guest with 768Mb ... VNC started without error.

Testing HTTP VNC installs on a s390x guest with mem=256m yields:

The VNC server is now running.
Please connect to lister.z900.redhat.com:1 to begin the install...
Press <enter> for a shell
Starting graphical installation...
Exception starting GUI installer: No module named gtk
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 875, in ?
    anaconda.setInstallInterface(opts.display_mode)
  File "/usr/bin/anaconda", line 514, in setInstallInterface
    isys.vtActivate (1)
  File "/usr/lib/anaconda/isys.py", line 831, in vtActivate
    _isys.vtActivate (num)
SystemError: (22, 'Invalid argument')

Do we need to adjust our documentation for the mem limits?
Comment 10 David Cantrell 2007-08-29 14:47:33 EDT
Yeah, this is a documentation issue or release notes issue.  Will 512MB work as
the lower bound?
Comment 11 James Laska 2007-08-29 14:50:00 EDT
I think it should ... but let me pull in jjarvis for IBM's take on this. 
Perhaps there is a bound and it's just not clear.
Comment 12 Brad Hinson 2007-08-29 15:31:52 EDT
Looking at comment 4 and comment 5, this doesn't seem to be a documentation
issue.  How complex would it be to add a memory size check before starting the
graphical install?  If we're using minstg2, we really shouldn't attempt to start
VNC.  If my understanding of comments 4 and 5 are incorrect please let me know.
Comment 13 David Cantrell 2007-08-29 16:03:31 EDT
I added the check for an exectuable Xvnc back in April, which is what the fix
for this bug was originally.  The traceback now shows:

Exception starting GUI installer: No module named gtk

So we're missing a lot of libraries and/or python modules, so we're probably
still in minstg2 but somehow have Xvnc.  I'm not sure.
Comment 14 David Cantrell 2007-08-29 16:11:24 EDT
OK, looking in to it more, what's happening is that the memory check _is_
working and the graphical install fails.  We catch the failure in anaconda and
move you to text install.  But on s390x, our vtActivate() function fails, most
likely because we can't perform that ioctl() on s390x (chalk up another one for
the mainframe being unique).  Here's the code:

try:
    from gui import InstallInterface
except Exception, e:
    stdoutLog.error("Exception starting GUI installer: %s" %(e,))
    if flags.test:
        sys.exit(1)
    # if we're not going to really go into GUI mode, we need to get
    # back to vc1 where the text install is going to pop up.
    if not x_already_set:
        isys.vtActivate (1)
    stdoutLog.warning("GUI installer startup failed, falling back to text mode.")
    display_mode = 't'
    if 'DISPLAY' in os.environ.keys():
        del os.environ['DISPLAY']
    time.sleep(2)

I think we need to just not run vtActivate() for s390x.  There are no VTs on
that platform at that point and the device isn't really present, so that makes
sense that it would fail.

Making a patch.
Comment 15 David Cantrell 2007-08-29 16:12:21 EDT
OK, here's my proposed patch:

Index: isys/isys.py
===================================================================
RCS file: /usr/local/CVS/anaconda/isys/isys.py,v
retrieving revision 1.193.4.16
diff -u -p -r1.193.4.16 isys.py
--- isys/isys.py        10 Aug 2007 17:40:34 -0000      1.193.4.16
+++ isys/isys.py        29 Aug 2007 20:00:26 -0000
@@ -828,6 +828,8 @@ def driveIsIscsi(device):
     return False
 
 def vtActivate (num):
+    if rhpl.getArch() == "s390":
+        return
     _isys.vtActivate (num)
 
 def isPsudoTTY (fd):

Simple fix to not run vtActivate() on s390 since we don't have VTs.
Comment 17 David Cantrell 2007-08-29 16:38:13 EDT
Patched committed.  Will be in anaconda-11.1.2.69-1.
Comment 19 James Laska 2007-09-04 16:11:50 EDT
Testing against RHEL5.1-Server-20070904.nightly (anaconda-11.1.2.71-1)

19:57:07 WARNING : URLINSTALL falling back to non-GUI stage2 due to insufficient
 RAM 

However the main attached console shows ...

20:01:58 INFO    : Running anaconda script /usr/bin/anaconda^M
20:01:58 DEBUG   : adding extraArg --vnc^M
20:01:59 INFO    : using only installclass Red Hat Enterprise Linux^M
20:01:59 INFO    : Red Hat Enterprise Linux is only installclass, using it^M
20:01:59 INFO    : Display mode = g^M
20:01:59 INFO    : Method =
http://porkchop.redhat.com/nightly/RHEL5.1-Server-20070904.nightly/tree-s390x^M
20:01:59 WARNING : no floppy devices found but we'll try fd0 anyway^M
20:02:02 INFO    : Starting VNC...^M
20:02:02 WARNING : ^M
^M
WARNING!!! VNC server running with NO PASSWORD!^M
You can use the vncpassword=<password> boot option^M
if you would like to secure the server.^M
^M
^M
20:02:02 INFO    : The VNC server is now running.^M
20:02:02 INFO    : Please connect to lister.z900.redhat.com:1 to begin the
install...^M
20:02:02 INFO    : Started mini-wm^M
20:02:02 INFO    : Starting graphical installation...^M
20:02:02 ERROR   : Exception starting GUI installer: No module named gtk^M
20:02:02 WARNING : GUI installer startup failed, falling back to text mode.^M
20:02:05 WARNING : Unable to find temp path, going to use ramfs path^M
20:02:05 INFO    : Detected 256M of memory^M
20:02:05 INFO    : Swap attempt of 256M to 512M^M
20:02:05 WARNING : step installtype does not exist^M
20:02:05 WARNING : step complete does not exist^M
20:02:05 INFO    : moving (1) to step welcome^M


I then am presented with stage#2 over ssh ... but keyboard inputs do not respond

                           ┌──────┤ Red Hat Enterprise Linux Server ├──────┐   
                       
                           │                                               │   
                       
                           │ Welcome to Red Hat Enterprise Linux Server!   │   
                       
                           │                                               │   
                       
                           │                                               │   
                       
                           │                    ┌────┐                     │   
                       
                           │                    │ OK │                     │   
                       
                           │                    └────┘                     │   
                       
                           │                                               │   
                       
                           │                                               │   
                       
                           └───────────────────────────────────────────────┘   
                       
                                                                               
                       
Comment 20 James Laska 2007-09-04 16:12:30 EDT
Created attachment 186581 [details]
anaconda.log (RHEL5.1-Server-20070904.nightly)
Comment 21 David Cantrell 2007-09-05 15:53:52 EDT
With the patch from bug #278261, the problem described here goes away.  VNC
installs work fine.
Comment 23 JM Bassett 2007-09-09 21:16:13 EDT
Possible related bug -- attempted a VNC install of Fedora 7.90 (F8T1) tonight on
an i386 platform, similar symptoms. Is this already fixed in the 7.91 install media?
Comment 24 James Laska 2007-09-24 15:15:54 EDT
VERIFIED original problem on RHEL5.1-Server-20070920.1

19:10:37 WARNING : URLINSTALL falling back to non-GUI stage2 due to insufficient
RAM                               
19:10:37 INFO    : transferring
http://porkchop.redhat.com//rel-eng/RHEL5.1-Server-20070920.1/tree-s390x/images/min
19:10:41 DEBUG   : copied 44269568 bytes to /tmp/ramfs/minstg2.img (complete)  
                                   
19:10:41 INFO    : mntloop loop0 on /mnt/runtime as /tmp/ramfs/minstg2.img fd is
9                                 

 <snip>

19:10:43 INFO    : Running anaconda script /usr/bin/anaconda                   
                                   
19:10:43 DEBUG   : adding extraArg --vnc                                       
                                   
19:10:46 INFO    : using only installclass Red Hat Enterprise Linux            
                                   
19:10:46 INFO    : Red Hat Enterprise Linux is only installclass, using it     
                                   
19:10:46 INFO    : Display mode = g                                            
                                   
19:10:46 INFO    : Method =
http://porkchop.redhat.com/rel-eng/RHEL5.1-Server-20070920.1/tree-s390x        
       
19:10:46 WARNING : no floppy devices found but we'll try fd0 anyway            
                                   
19:10:50 INFO    : Starting VNC...                                             
                                   
19:10:50 INFO    : ip of eth0 is None                                          
                                   
19:10:50 WARNING :                                                             
                                   
                                                                               
                                   
WARNING!!! VNC server running with NO PASSWORD!                                
                                   
You can use the vncpassword=<password> boot option                             
                                   
if you would like to secure the server.                                        
                                   
                                                                               
                                   
                                                                               
                                   
19:10:50 INFO    : The VNC server is now running.                              
                                   
19:10:50 INFO    : Please connect to localhost.localdomain:1 to begin the
install...                               
19:10:50 INFO    : Started mini-wm                                             
                                   
19:10:50 INFO    : Starting graphical installation...                          
                                   
19:10:51 ERROR   : Exception starting GUI installer: No module named gtk       
                                   
19:10:51 WARNING : GUI installer startup failed, falling back to text mode.    
                                   
19:10:54 WARNING : Unable to find temp path, going to use ramfs path           
                                   
19:10:54 INFO    : Detected 256M of memory                                     
                                   
19:10:54 INFO    : Swap attempt of 256M to 512M                                
                                   
19:10:54 WARNING : step installtype does not exist                             
                                   
19:10:54 WARNING : step complete does not exist                                
                                   
19:10:54 INFO    : moving (1) to step welcome                                  
                                   
19:11:16 INFO    : moving (1) to step regkey                                   
                                   

The keyboard/input problem remains ... I'm able to F12 to the regkey step, but
then stuck there.  I don't seem to see a text-mode cursor.

So I don't get the traceback anymore, and I imagine one could do a kickstart
install in this environment now.  I'm unable to perform an attended installation
in a mem=256m s390x zVM guest.

dcantrell: Should we close out this issue since the original traceback isn't
occuring, and open a new issue to track the keyboard focus issue?
Comment 25 James Laska 2007-09-24 16:34:50 EDT
Moving to VERIFIED ... will track the keyboard input issue as a separate request
(see bug#303961)
Comment 28 errata-xmlrpc 2007-11-07 12:18:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0644.html

Note You need to log in before you can comment on or make changes to this bug.