Bug 217631 - Evolution fails to decode headers.
Evolution fails to decode headers.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 20:01 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 05:03:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-11-28 20:01:36 EST
Given a header like this:

Subject: =?UTF-8?Q?[MTD]=20CAF=C3=89=20NAND:=20Add=20'slowtiming'=20parameter,
        =20default=20usedma=20and=20checkecc=20on?=

... Evolution fails to decode it because of the whitespace in it (the newline).

Note that this is Evolution's "raw" message view, and may be
whitespace-corrupted by Evolution (bug 83257, January 2003). But it does seem to
be the line break which upsets Evolution.

AFAICT Evolution doesn't handle =?UTF-8?B?...?= format at all, either.
Comment 1 David Woodhouse 2006-11-29 05:03:23 EST
The =UTF8?Q?...?= bug with the newline in seems to be a mailman bug (bug 217667)
-- I think RFC2047 exonerates Evolution on that score, although perhaps an
argument could be made for being liberal in what we accept.

I was sure that I'd also seen Evolution consistently fail to decode headers of
the form =?UTF-8?B?SGVsbG8=?= too, but upon testing it seems to work, so either
it's fixed in FC6 or I was imagining it -- or it was just badly formed in the
spam I was looking at. Closing this bug accordingly.

Note You need to log in before you can comment on or make changes to this bug.