Bug 217729 - gij aborts on ppc64
gij aborts on ppc64
Status: CLOSED DUPLICATE of bug 217775
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 12:22 EST by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 07:36:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2006-11-29 12:22:56 EST
Description of problem:
I can't get gij to run on current rawhide (2006-11-29) ppc64.

mock-chroot> gij -Dgnu.gcj.precompiled.db.path="" -cp
/usr/share/java/eclipse-ecj.jar org.eclipse.jdt.internal.compiler.batch.Main
HelloWorld.java  
Aborted
mock-chroot> gij -cp /usr/share/java/eclipse-ecj.jar
org.eclipse.jdt.internal.compiler.batch.Main HelloWorld.java                   
               
Aborted

gcj -C also fails:

mock-chroot> gcj -C HelloWorld.java 
HelloWorld.java:3: error: 'class' or 'this' expected.
        System.out.println(Hello, world.);
                                           ^
1 error

locally, with my gcc-4.1.1-30.i386, it returns immediately with the compiled class.

gcj-dbtool also fails:

mock-chroot> gcj-dbtool     
Aborted

Version-Release number of selected component (if applicable):
gij (GNU libgcj) version 4.1.1 20061120 (Red Hat 4.1.1-41)

How reproducible:
Always

Steps to Reproduce:
1. Get access to the ppc64 chroot I have from dgregor (ask him or me on IRC)
2. cd /tmp
3. gij -cp /usr/share/java/eclipse-ecj.jar
org.eclipse.jdt.internal.compiler.batch.Main HelloWorld.java
  
Actual results:
Abort

Expected results:
Class compilation

Additional info:
I can't get anything sensible out of gdb:

mock-chroot> gdb --args java -cp /usr/share/java/eclipse-ecj.jar
org.eclipse.jdt.internal.compiler.batch.Main HelloWorld.java            
GNU gdb Red Hat Linux (6.5-18.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "ppc64-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".

(gdb) r
Starting program: /usr/bin/java -cp /usr/share/java/eclipse-ecj.jar
org.eclipse.jdt.internal.compiler.batch.Main HelloWorld.java
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 549813676944 (LWP 14167)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
Warning:
Cannot insert breakpoint -2.
Error accessing memory address 0x9b20: Input/output error.
Cannot insert breakpoint -3.
Error accessing memory address 0x9b30: Input/output error.

(gdb) bt
#0  0x00000080000086c0 in .dl_main () from /lib64/ld64.so.1
#1  0x00000080000221b4 in ._dl_sysdep_start () from /lib64/ld64.so.1
#2  0x0000008000005cc4 in ._dl_start_final () from /lib64/ld64.so.1
#3  0x0000008000005f9c in ._dl_start () from /lib64/ld64.so.1
#4  0x0000008000005490 in ._start () from /lib64/ld64.so.1
Previous frame inner to this frame (corrupt stack?)
Comment 1 Jakub Jelinek 2006-11-29 14:03:08 EST
Can you try gcc-4.1.1-42.el5 (dist-5E)?
Comment 2 Andrew Overholt 2006-11-29 14:04:44 EST
(In reply to comment #1)
> Can you try gcc-4.1.1-42.el5 (dist-5E)?

No.  I don't have a local machine to try with.  I guess I could ask releng for a
5E buildroot to chroot into ...
Comment 5 Jakub Jelinek 2006-12-01 07:36:27 EST

*** This bug has been marked as a duplicate of 217775 ***

Note You need to log in before you can comment on or make changes to this bug.