Bug 217775 - gcj-dbtool crashes
Summary: gcj-dbtool crashes
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: rawhide
Hardware: ppc64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 217729 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-29 21:09 UTC by Stepan Kasal
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.5.90-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 12:35:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stepan Kasal 2006-11-29 21:09:57 UTC
gcj-dbtool seems to crash with signal 6 (Abort) each time is is called, or at
least when called as

gcj-dbtool -n foo.db.tmp

This was in mock, in pure ppc64 chrooted environment.
The underlying kernel is 2.6.9-34.EL.

Comment 4 Jakub Jelinek 2006-11-30 11:01:12 UTC
Initial investigation shows this might not be related to any recent change in
gcc, but glibc, particularly:
- add -fasynchronous-unwind-tables to CFLAGS (#216518)
in glibc-2.5.90-8.


Comment 5 Jakub Jelinek 2006-11-30 13:22:00 UTC
In particular it is something in unwind info of libc-2.5.90.so, replacing
2.5.90-8 /lib64/libc-2.5.90.so with 2.5.90-7 libc-2.5.90.so cures this.
Unfortunately gdb is upset too so it is hard to debug it and I haven't managed
to reproduce it with more simple testcases so far.

Comment 6 Jakub Jelinek 2006-12-01 12:35:29 UTC
Should be fixed in glibc-2.5.90-10 in rawhide.

Comment 7 Jakub Jelinek 2006-12-01 12:36:52 UTC
*** Bug 217729 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.