Bug 217762 - yum fails to notice an unsuccesful update
Summary: yum fails to notice an unsuccesful update
Status: CLOSED DUPLICATE of bug 186945
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-29 20:04 UTC by Michal Jaegermann
Modified: 2014-01-21 22:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 18:51:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2006-11-29 20:04:13 UTC
Description of problem:

Due to errors in a package an update fails.  See bug 217750 for
details of that with a new ncurses package.  yum prints on a screen

  Updating  : ncurses                      ##################### [ 18/162]
error: unpacking of archive failed on file /lib/terminfo/v/vt220;456dcf2f: cpio:
link

although not in log. Still in /var/log/yum.log one can find later

Nov 29 11:20:26 Updated: ncurses.x86_64 5.5-25.20060715.fc7
Nov 29 11:21:29 Updated: ncurses-devel.x86_64 5.5-25.20060715.fc7

while, after that "update" 'rpm -q' reports ncurses-5.5-24.20060715
and indeed ncurses-devel-5.5-25.20060715.fc7 even if ncurses-devel
have an explicit dependency 'ncurses = 5.5-25.20060715.fc7'.  Ugh!

Version-Release number of selected component (if applicable):
yum-3.0.1-2.fc7

Comment 1 Jeremy Katz 2007-04-25 18:51:03 UTC

*** This bug has been marked as a duplicate of 186945 ***


Note You need to log in before you can comment on or make changes to this bug.