Bug 2177853 - Logout/reboot/poweroff timeout leaves the session in a broken state, doesn't perform the action
Summary: Logout/reboot/poweroff timeout leaves the session in a broken state, doesn't ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 2176536 (view as bug list)
Depends On:
Blocks: F38FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2023-03-13 17:09 UTC by Kamil Páral
Modified: 2023-03-24 02:03 UTC (History)
10 users (show)

Fixed In Version: gnome-shell-44.0-2.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-24 02:03:35 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-shell issues 6506 0 None opened Logout/reboot/poweroff timeout leaves the session in a broken state, doesn't perform the action 2023-03-13 17:09:38 UTC
GNOME Gitlab GNOME gnome-shell merge_requests 2696 0 None opened modalDialog: Fix fading out dialog 2023-03-17 17:41:18 UTC

Description Kamil Páral 2023-03-13 17:09:38 UTC
Please see:
https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/6506

Proposing for a blocker discussion. There are two problems:
1) The logout/reboot/poweroff doesn't happen (you might be relying on that in some cases, I guess. Sending acpi signals to remote machines? Something like that).
2) It's not clear how to get out of the broken state. So if you click logout/reboot/poweroff and then turn around to a colleague/somebody and return back after more than 60 seconds, you don't know how to quit the session.

Comment 1 Kamil Páral 2023-03-13 17:12:35 UTC
*** Bug 2176536 has been marked as a duplicate of this bug. ***

Comment 2 Geoffrey Marr 2023-03-13 19:27:23 UTC
Discussed during the 2023-03-13 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker (Final)" was made as a conditional violation of the following criterion:

"Shutting down [etc]...must work using...the mechanisms offered (if any) by all release-blocking desktops" in the case where you wait for the automatic action to happen after the timeout.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2023-03-13/f38-blocker-review.2023-03-13-16.00.txt

Comment 3 Fedora Update System 2023-03-22 23:30:01 UTC
FEDORA-2023-26137c2392 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-26137c2392

Comment 4 Adam Williamson 2023-03-22 23:42:02 UTC
The fix for this was backported in gnome-shell-44.0-2.fc38, which is in the 44 megaupdate. Please test and confirm it. Thanks!

Comment 5 Fedora Update System 2023-03-23 02:56:31 UTC
FEDORA-2023-26137c2392 has been pushed to the Fedora 38 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-26137c2392

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Kamil Páral 2023-03-23 10:05:35 UTC
(In reply to Fedora Update System from comment #3)
> FEDORA-2023-26137c2392 has been submitted as an update to Fedora 38.
> https://bodhi.fedoraproject.org/updates/FEDORA-2023-26137c2392

Fixed it.

Comment 7 Fedora Update System 2023-03-24 02:03:35 UTC
FEDORA-2023-26137c2392 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.