Bug 217915 - kernel BUG at lib/list_debug.c:70! invalid opcode: 0000 [#1] SMP
kernel BUG at lib/list_debug.c:70! invalid opcode: 0000 [#1] SMP
Status: CLOSED DUPLICATE of bug 217914
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 14:14 EST by Chris Nighswonger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 16:09:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Nighswonger 2006-11-30 14:14:26 EST
Description of problem:

     The problem occurs in exactly the same circumstances on two otherwise very
stable different hardware platforms. When performing multiple mount/umount of
network shares of type 'cifs' the initilization of SELinux causes the kernel to
crash. The problem is reproducable on these two machines with regularity.
However, various amounts of log are available depending on how fast the kernel
killed itself.

Version-Release number of selected component (if applicable):

System A: 2.6.18-1.2849.fc6

System B: 2.6.18-1.2798.fc6

How reproducible:

     Consistantly

Steps to Reproduce:

     Repeatedly mount/umount a network share of type 'cifs' using a mount
command similar to this:

mount -t cifs //192.168.x.x/sharename /mnt/sharename -o\
credentials=credentials.txt,dir_mode=0777,file_mode=0777

     ...along with a simple 'umount /mnt/sharename'

  
Actual results:

     Eventual kernel crash.

Expected results:

     Stable system operations.

Additional info:

     Please feel free to contact me for further information. I am willing to
assist with the debug process.
Comment 1 Dan Carpenter 2006-11-30 15:41:41 EST
This is the same as bug 214622.

A couple other people have reported this bug too...

People were also getting bug 216001 which has a similar trace.  One of those
reporters was using cifs, but i'm not sure about the other.
Comment 2 Adam Jackson 2006-12-15 16:09:18 EST

*** This bug has been marked as a duplicate of 217914 ***

Note You need to log in before you can comment on or make changes to this bug.