Bug 217941 - HTS: RHEL 5 usb test failed on system with internal hub chip
HTS: RHEL 5 usb test failed on system with internal hub chip
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Greg Nichols
Greg Nichols
:
: 217940 (view as bug list)
Depends On:
Blocks: 217940
  Show dependency treegraph
 
Reported: 2006-11-30 15:45 EST by Garry Wong
Modified: 2008-07-16 17:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 11:35:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hts test logs (965.03 KB, application/octet-stream)
2006-11-30 15:45 EST, Garry Wong
no flags Details
hal txt (99.59 KB, text/plain)
2006-12-06 16:59 EST, Garry Wong
no flags Details
hal-device log (88.88 KB, text/plain)
2007-01-04 18:06 EST, Hien Nguyen
no flags Details
usb info in hts 17 (1.56 MB, application/x-zip-compressed)
2007-01-19 17:14 EST, Garry Wong
no flags Details

  None (edit)
Description Garry Wong 2006-11-30 15:45:19 EST
Description of problem:

-Rhel 5 usb test failed on system with additional internal 2.0 hub chip
-However, the usb test passed on system without additional internal 2.0 hub 
such as ProLiant DL360 G5

Version-Release number of selected component (if applicable):

Version-Release number of selected component (if applicable): rhel5 hts 
version 5 release 9

How reproducible:


Steps to Reproduce:
1. Install rhel5 x86 beta2 without Virtualization capability onto system under 
test -ProLiant DL365 G1
2. Install rhel5 x86 beta2 onto network test server
3. Install rhel5 hts version 5 release 9 test suite onto both system under 
test and network test server (with IPV4 status ip address 10.1.1.10)
4. On network test server ---> hts  server start
5. On system under test ----> hts plan ----> hts certify --server 10.1.1.10

  
Actual results: Test failed


Expected results: Test should pass as on ProLiant DL360 G5 server


Additional info: See attached.
Comment 1 Garry Wong 2006-11-30 15:45:22 EST
Created attachment 142523 [details]
hts test logs
Comment 2 Garry Wong 2006-11-30 17:57:18 EST
It did not recognize the usb device when the test was asking you to plug the 
device. But it does recognize outside the test. The internal usb 2.0 hub is a 
Cypress chip.
Comment 3 YangKun 2006-12-06 04:32:57 EST
*** Bug 217940 has been marked as a duplicate of this bug. ***
Comment 4 Greg Nichols 2006-12-06 10:19:54 EST
Please attach a HAL dump with the USB device plugged in:

1) Plug in the USB device into a port
2) run: "hal-device > hal.txt"

Thanks!
Comment 5 Garry Wong 2006-12-06 16:59:26 EST
Created attachment 142997 [details]
hal txt

hal-device > hal.txt
Comment 6 Garry Wong 2006-12-11 14:44:59 EST
See attached hal txt.
Comment 7 Garry Wong 2006-12-14 15:34:58 EST
I tried the hts version 14 and this problem still exists.

Thanks,
Comment 9 Hien Nguyen 2007-01-04 18:03:50 EST
I tried hts version 14 on pSeries systems and it hangs at the end of the text on
the console. Then it showed usb test failed when I hit <Enter> after 2 hours of
hanging there:
----
How many unused USB sockets are there ?
response: 2
Cypress Semiconductor Corp. USB-2.0 IDE Adapter appears to be plugged into bus
number 1 port number 1
Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub" appears to be plugged
into bus number 1 port number 1
Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub" appears to be plugged
into bus number 1 port number 1
IBM Corp. IBM MM2 appears to be plugged into bus number 2 port number 1
testing socket 1 of 2...
Please plug in a USB device - continue? (yes|no)   Vendor: Generic   Model: USB
Flash Drive   Rev: 1.00
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sdb: 495616 512-byte hdwr sectors (254 MB)
sdb: Write Protect is off
sdb: assuming drive cache: write through
SCSI device sdb: 495616 512-byte hdwr sectors (254 MB)
sdb: Write Protect is off
sdb: assuming drive cache: write through
sd 5:0:0:0: Attached scsi removable disk sdb
sd 5:0:0:0: Attached scsi generic sg3 type 0
   ..... usb test hangs here ......
Hit <Enter>, then it continues...

...finished running ./usb.py, exit code=1
recovered exit code=1
rhts-report-result /HTS/hts/usb FAIL /var/log/hts/runs/2/usb/output.log
saveOutput: /var/log/hts/runs/2/usb/output.log
-----------------
Comment 10 Hien Nguyen 2007-01-04 18:06:46 EST
Created attachment 144864 [details]
hal-device log

hal log on pSeries system Power5 720
Comment 11 Hien Nguyen 2007-01-04 18:13:57 EST
However, the test command I ran is:

hts certify --test=usb
Comment 12 Hien Nguyen 2007-01-09 17:43:40 EST
I tried HTS-5.0-15 and the results is the same. usb test failed.
Comment 13 Greg Nichols 2007-01-12 15:06:30 EST
Fixed R16.
Comment 15 Garry Wong 2007-01-19 17:14:40 EST
Created attachment 146043 [details]
usb info in hts 17

I used hts R17 and still seeing this issue.

Thanks
Comment 20 Greg Nichols 2007-01-24 12:42:19 EST
I ran HTS R17 on a DL360 G5 without incident.  The test log follows:

USB test:
Hewlett-Packard Virtual Keyboard appears to be plugged into bus number 5 port
number 1
Hewlett-Packard Virtual Hub appears to be plugged into bus number 5 port number 2
How many unused USB sockets are there? response: 3
testing socket 1 of 3...
Please plug in a USB device - continue? (yesno) response: yes
SanDisk Corp. U3 Cruzer Micro appears to be plugged into bus number 6 port number 5
found device at 6-5
Please unplug the device and hit the Enter key: confirmed device 6-5
testing socket 2 of 3...
Please plug in a USB device - continue? (yesno) response: yes
SanDisk Corp. U3 Cruzer Micro appears to be plugged into bus number 6 port number 3
found device at 6-3
Please unplug the device and hit the Enter key: confirmed device 6-3
testing socket 3 of 3...
Please plug in a USB device - continue? (yesno) response: yes
SanDisk Corp. U3 Cruzer Micro appears to be plugged into bus number 6 port number 4
found device at 6-4
Please unplug the device and hit the Enter key: confirmed device 6-4
...finished running ./usb.py, exit code=0
Comment 21 Greg Nichols 2007-01-24 12:49:58 EST
Please supply R17 log output similar to above.

- Thanks!
Comment 22 Garry Wong 2007-01-24 13:02:25 EST
The system is DL365 G1 which I already mentioned on the repro steps, also I 
already said this in Description of problem: -However, the usb test passed on 
system without additional internal 2.0 hub 
such as ProLiant DL360 G5.

The R17 log had been submiited, see comment #15.

Thanks,
Comment 23 Greg Nichols 2007-01-26 14:03:55 EST
Fixed R21
Comment 24 Garry Wong 2007-01-26 17:41:48 EST
Verified passing in R21/
Comment 27 Issue Tracker 2007-07-09 09:47:08 EDT
Hello IBM,
Closing IT based on update from:
----- Additional Comments From hien1@us.ibm.com  2007-01-27 11:35 EDT
-------
HTS-5.0-21: fixed USB test.
I tested on three different systems: JS20, JS21, p5 720. All PASSED.
Congratulation ! 

Thank You
Joe kachuck

Internal Status set to 'Resolved'
Status set to: Closed by Client
Resolution set to: 'Closed by Client'

This event sent from IssueTracker by jkachuck 
 issue 111170

Note You need to log in before you can comment on or make changes to this bug.